Gitlab Server v11.6.5 – Bugfix-Update erschienen

gitlab-11-6-5-bugfix-update-internetblogger-de

Hallo geehrter Blogleser und Gitlab Server Admin! Neue Gitlab-Updates gab es und diese können ab nun installiert werden. Das jeweilige Update Gitlab v11.6.5 habe ich meiner Gitlab-Installation bereits mit Erfolg angetan. Manchmal vergesse ich, aus dem Verzeichnis /etc/yum.repos.d das Gitlab Repo zu entfernen. Wenn dann Plesk Updates macht, werden auch Gitlab Updates gemacht, aber das … Weiterlesen

Sicherheitsupdate vom TikiWiki v18.2 ist draussen – Updaten sehr empfehlenswert

tikiwiki-18-2-bugfix-sicherheitsupdate-internetblogger-de

Hallo Blogleser! News gibt es heute seitens des TikiWikis und dem neulichen Security-Bugfix-Update. Das Update wurde herausgebracht und sollte dringenderweise zeitnah installiert werden.

TikiWiki hat einen breiten Update-Zyklus, sodass es keine Belästigung ist, zweimal im Jahr ein Update zu machen. So kommt es auch derzeit und jetzt eben machte ich mein Tiki-Update unter https://tikiwiki.eu im Projekt. Das Update gelang mir auf die Schnelle, sodass es keinerlei Fehler nach sich zog.

Vorher loggte ich mich in Control Panels ein und nach dem Hochladen aller FTP-Files refreshte ich die Seite. Das wär’s auch schon. Zudem wird dir im Control Panel der SSH-Befehl zum Aktualisieren der Tiki-Datenbank angezeigt. Dieser ist zu nutzen und per Kommandozeile auszuführen. Erst dann kannst du dazu übergehen, wieder im Tiki zu arbeiten.

Per Konsole ist es sehr schnell getan, denn der SSH-Befehl wird lediglich kopiert und in der Konsole fallen gelassen. Das ist alles.

Unter https://tiki.org/article453-Security-and-bug-fix-updates-Tiki-18-2-Tiki-15-7-and-Tiki-12-14-released haben die Entwickler kurz etwas gepostet, aber ohne grossartig Content. Jedenfalls verfolge ich alle TikiWiki-Updates über die Developer-Plattform unter https://sourceforge.net , wo du jeden Software-Download virus-geprüft in Anspruch nehmen kannst. SourceForge.net bietet allerhand Funktionen für die Entwickler einer Software und so manch eine App ist nur dort zu finden und nicht bzw. nicht mehr auf Github.

Schaue es dir bei Zeiten auch an.

Paar Anpassungen im eigenen Tiki vorgenommen

Da wäre es die Bolt CMS Dienstleistung, die derzeit rege promotet wird. So passe ich alle Portfolio-Projekte in kommender Zeit noch an, sodass jeder Bescheid weiss von den Partnern und Webnutzern.

Für diesen Moment ist es auch schon alles, was zum Update gesagt werden kann. Mache es und sorge für die sichere Umgebung deines Shared Hostings bzw. gar eines eigenen dedizierten Rootservers wie bei mir.

Bei Fragen zum Tiki-Update via WebFTP bzw. SFTP wende dich hier drunter im Kommentarbereich an mich und wir werden sicherlich eine Problemlösung finden, falls etwas sein sollte. Stabile Tiki-Updates machen keine Zicken mehr, wie man es früher so manch eines Males erlebte.

by Alexander Liebrecht

Sicherheitsupdate des Gitlab Servers v11.2.3 erschienen – bitte dringend updaten

gitlab-11-2-3-sicherheitsupdate-internetblogger-de

Hallo Blogleser, eine ganze Menge hat sich bei mit im Portfolio getan und aktuell promote ich meine Bolt CMS Dienstleistung so gut es mir machbar ist. Aber hierbei geht es speziell um das neue Sicherheitsupdate des Gitlab Servers, welches herausgekommen ist. Darum wird es in diesem Blogpost gerne gehen. Gitlab Updates sind sehr gut und … Weiterlesen

Gitlab v11.1.2 Sicherheitsupdate draussen – du sollst zeitnah aktualisieren

gitlab-11-1-2-sicherheitsupdate-internetblogger-de

Hallo Blogleser und Gitlab Admin! Wie ich schon mehrmals sagte, erscheinen Gitlab Updates beinah wöchentlich und auch gestern oder heute war es damit soweit. Ein wichtiges Sicherheitsupdate wurde ins Virtuelle verfrachtet und sollte dringenderweise von dir installiert werden.

Zum Update kannst unter https://about.gitlab.com/2018/07/26/security-release-gitlab-11-dot-1-dot-2-released/ etwas nachlesen. Im Prinzip geht es um die Sicherheit deiner Gitlab Instanz und der Gitlab Installation. Das Update heute war mir sehr gelungen und so konnte ich es ohne Probleme installieren.

yum update hatte Probleme, weil so manche Repositories nicht erreichbar waren. Ich denke aber, dass es sich dabei um ein temporäres Problem handelt. Normalerweise funktionieren yum udpates immer sehr gut.

Falls du Gitlab aktualisieren willst, musst du diesen SSH-Befehl vom Root aus einsetzen.

yum update

Auch sollte genügend Space im Verzeichnis / sein. Da hatte ich neulich Probleme. Du kannst mit dem unteren SSH-Befehl checken, wie viel Platz frei ist.

df -h

Falls schon alles voll, musst du unter /var/log beigehen und doppelte sowie dreifache Logs löschen. Es gibt immer die Original Log-Datei und das was, bereits erstellt wurde. Das Doppelte kann man dabei löschen und schon gibt man Speicher frei unter /.

Eigene Gitlab Instanz

Sie habe ich unter http://gitlab.apps-tools-cms.de und dort habe ich sie schon seit einer Weile. Ich denke oder gehe davon aus, dass der Rootserver nicht mehr kaputt gehen wird. Eine zu 100-prozentige Garantie gibt es nicht, denn die Hardware wird sehr in Anspruch genommen. Immerhin habe ich 8 Power-Linux-Apps am Laufen. Das muss schon was heissen oder… Schauen wir mal!

Das ist jetzt ein kurzer Blogpost, denn wenn du das hier verfolgt hast seit Anfang, wirst du wissen, was zu tun ist. Gitlab Updates Posts bauen ja bei mir doch schon aufeinander auf, sodass man mitlernen kann.

Ich wünsche dir erfolgreiches Updaten deiner Gitlab Instanz und dass Yum Manager keine Zicken macht.

by Alexander Liebrecht

 

 

 

Gitlab Server Sicherheitsupdate v11.0.4 – bitte dringend aktualisieren

gitlab-server-11-0-4-sicherheitsupdate-internetblogger-de

Hallo Blogleser und Gitlab Admin! Es sind wichtige Sicherheitsupdates des Gitlab Servers nach draussen befördert worden und an deiner Stelle würde ich etwas Zeit finden, um zeitnah das Update zu erledigen.

Das Update wurde den Gitlab Entwicklern durch eine andere Person gemeldet und so konnte dafür eine Lösung gefunden werden. Die Entwickler selbst empfehlen wärmstens, zu aktualisieren und glücklicherweise verfolge ich das offizielle Gitlab Blog im Internet. So bekam ich es auch zeitnah mit.

Gitlab Server Updates mache ich in Linux unter Centos 7.5 OS mit diesem SSH-Befehl.

yum update

Wenn dabei nichts weiter ist, bringt der Yum-Installer das Update fehlerfrei fertig. Wenn es dem nicht so ist, checke bitte deine Instanz via Kommandozeile und diesem SSH-Befehl.

gitlab-ctl restart

gitlab-ctl tail

Mit “tail” liest du die Gitlab Logs aus und alles wird dir via SSH in der Kommandozeile angezeigt. So wirst du gleich schlauer, denn es zeigt dir allerhand Einstellungen, Prozessstarts oder wenn etwas nicht stimmt an.

Dieses Update war mir heute gut gelungen und ich kann es dann gerne weiterempfehlen. Auch wird dieser Post über meine Foren weiter getragen sowie bekannt gemacht.

Im Grossen und Ganzen wäre das auch schon und du weisst mittlerweile als Stammleser wie Gitlab Server Updates in Linux zu machen sind.

Ich wünsche dir weniger Gitlab Probleme und mache das Beste aus deiner Instanz. Schaue ab und an unter https://about.gitlab.com/2018/07/17/critical-security-release-gitlab-11-dot-0-dot-4-released/ vorbei, denn die Gitlab Autoren bloggen dort fast täglich. Man erfährt immer etwas über Updates oder wenn Sicherheitsupdates draussen sind. Auch andere gitlab-spezifische Themen werden im Gitlab Blog verbloggt.

by Alexander Liebrecht

 

Gitlab Server App 11.0.3 Update erschienen mit Fehlerbehebungen

gitlab-11-0-3-bugfix-update-draussen-internetblogger-de

Hallo Gitlab-Admin und Interessent! Ja, es war wieder soweit, sodass es zum neuen Gitlab Server Update gekommen ist. Das Update beinhaltet mehrere Bugfixes, die deiner Instanz sicherlich gut tun werden.

Das Gitlab Update habe ich erst eben eingespielt und danach hat meine Instanz funktioniert wie vorher. Das ist ein gutes Zeichen, denn manche Updates liefen nicht immer reibungslos und zogen Fehler oder die Nicht-Erreichbarkeit der Instanz im Browser nach sich.

Info-technisch hast du den offiziellen Blogpost von Gitlab hinter https://about.gitlab.com/2018/07/05/gitlab-11-0-3-released/ , wo du dich informieren kannst. Mir ist es nicht so sehr wichtig, was dann jede einzelne Fehlerbehebung ist. Die Gesamtsumme zählt immer für mich und solche Updates werden schnell umgesetzt.

Unter Centos 7 auf Gitlab 11.0.3 aktualisieren – wie geht das?

Das wird der SSH-Befehl wie darunter sein.

yum update

Normalerweise macht die Konsole alles für dich bei diesem Gitlab Update. Du kannst dennoch, wenn alles kaputt ist, diese Befehle in der Kommandozeile ausführen.

gitlab-ctl restart

gitlab-ctl tail

Mit “tail” werden Gitlab Logs ausgelesen und dir in der Konsole angezeigt, sodass man sich dann auf Fehlersuche begeben kann. In der Regel und wie ich das mit Gitlab seit paar Jahren kenne, läuft diese App stabil, sicher und meckert nicht. Warum sie im Browser nicht startet, liegt oft an Apache httpd.conf, die dann deine Virtualhost ist.

Auch kann es sein, dass die für Gitlab vorgesehenen Ports in deinem OS bereits besetzt sind. Das kannst du immer überprüfen und unter /etc/gitlab/gitlab.rb in der Datei die Ports festlegen. Ich würde da versuchen, nicht allzu sehr, die gitlab.rb zu individualisieren. Aber wenn die Ports in Rootserver schon besetzt sind, musst du natürlich etwas unternehmen, um Gitlab App zum Laufen zu bekommen.

Eigene Gitlab-Instanz

Diese kannst du meinerseits unter http://gitlab.apps-tools-cms.de gerne aufrufen und dich darin umschauen. Ich habe den Header individuell gestaltet und meine Projekte mit den Repos platziert. Nach und nach werden diese mit Leben gefüllt und ich sorge für neue Inhalte. Gitlab Repositories können in Rootserver mit “git clone url-zu-projekt” geclont werden. Ich arbeite ab und  an auch mit der GIT-Versionskontrolle, um da etwas zu lernen und mir das GIT-Wissen anzueignen. Das klappt auch auf Github, online auf Gitlab und Bitbucket.

So viel dieses Mal zum Gitlab-Bugfix-Update v11.0.3. Ich wünsche dir weiterhin viel Spass bei der Arbeit mit dieser Linux-App.

Sorge immer für die Sicherheit sowie die Stabilität deiner Server-Umgebung, denn das ist das A und O, wenn du einen Server hast. Aus diesem Grunde alle Updates immer brav installieren.

by Alexander Liebrecht

 

 

Gitlab Server Fehlerbehebungsupdate v11.0.2 erschienen

gitlab-11-0-2-server-app-bugfix-update-internetblogger-de

Hallo Blogleser! Freust du dich schon auf das nächste Gitlab Server Update, weil es ja draussen ist und zwar in der neuen Version 11.0.2.

Gitlab Server App ist rasant in der stetigen Entwicklung und kaum eine ganze Woche vergeht, gibt es neue Updates. Sie sind alle zu machen, insbesondere dann, wenn die Sicherheit erwähnt wird. Dieses Update v11.0.2 war den Bugfixes geschuldet, welche wiederum deine Instanz besser funktionieren lassen.

Das Update ist bei mir schon erfolgt, was ja mittels SSH schnell geht. Zwischenfälle gab es keinerlei und solche Updates werden auch bei dir schnell zur reinen Routine.

Gitlab App kann individuell gestaltet werden. Du kannst einen Text im Footer, Header und auf der Login-Page hinzufügen. Das geht über die Einstellungen im Admin Sektor. Auch kann die 2-Schritte-Auth aktiviert werden, was derzeit denke mal sehr sicher ist. Ich arbeite nur noch so, wo es technisch gesehen klappt.

Nun kurz zu den Update-SSH-Befehlen.

Gitlab Update auf Version 11.0.2

yum update

Das kennst du als Centos 7 Admin sicherlich schon. Auch gibt es diese Befehle, die immer sehr hilfreich sind, wenn es brennt.

gitlab-ctl reconfigure

gitlab-ctl restart

gitlab-ctl tail

Mit “tail” liest du direkt in der Konsole die Logs aus und sie sind sehr aufschlussreich. Wenn mit Gitlab etwas nicht stimmt, dann tauchen diese Zeilen auch in den Logs auf. Manchmal war es so bei mir, dass Unicorn Port belegt war in Linux oder es tauchen Fehlermeldungen aus dem Gitlab Monitor auf, was du wiederum mit “tail” auslesen kannst.

Ich habe mittlerweile um die 8 Linux Apps auf dem Rootserver und sie müssen funktionieren, da auch verschiedene Ports. Manchmal ist es so, dass diese Apps von Haus aus dieselben Ports belegen wollen. Dann gilt es, diese zu ändern.

Gitlab Server habe ich für dich unter http://gitlab.apps-tools-cms.de und es noch frisch entstanden, weil ich einen Crash mit den Festplatten hatte. Jetzt ist alles wieder bestens und kann neu aufgebaut bzw. eingerichtet werden.

Gitlab fühlt sich bei genügend RAM-Speicher und Disk Space wohl.

Du kannst einfach mal mittels Konsole das ausführen.

df -h

So wird dir angezeigt, was wie viel Platz belegt. Bitte komme nie auf die Idee, von den Partitionen Festplattenspeicher wegzunehmen. Es kann zum Ausfall der Festplatte oder gar dem Ruinieren der Festplatte kommen. Lieber direkt via SSH/SFTP-Verzeichnisse und Logs aus /var/log löschen.

OK, zurück zu Gitlab und ich finde einen grossen Gefallen an dieser App. Es hat Codeschnipsel, readme.md, Projekte, Wiki, Tickets und das nutze ich gerne, um mich frei zu entfalten. Alle Updates werden regelmässig installiert, denn es ist die Sicherheit deines Rootservers.

Nun wäre das alles für diesen Moment und ich wünsche dir weiterhin Spass an der Gitlab Server App.

by Alexander Liebrecht

 

 

MediaWiki 1.31.0 – Bugfix-Funktionsupdate – hat geklappt

mediawiki-1-31-0-bugfix-funktionsupdate-internetblogger-de

Hallo Blogleser und MediaWiki-Admin! Es ist mal wieder soweit, dass das nächste LTS-MediaWiki-Release den Weg ins Virtuelle gefunden hat. Die Mail bekam ich vor paar Stunden und das soll hiermit festgehalten werden, um auch dich auf den Laufenden zu bringen.

MediaWiki 1.31.0 bekam zahlreiche Fehlerbehebungen an allen Fronten und auch neue Funktionen hat es gegeben. Somit lohnt sich das Update in jedem Falle und das hat bei mir ganz passabel funktioniert.

Neue Sprachen flossen in diese Wiki-Version mit ein und eine Sprache wurde aktualisiert. Hier und da noch was für Entwickler gelassen, womit diese arbeiten können. Aber für dich als den Admin wäre doch wichtig zu wissen, wie man aktualisiert und ob du dieser Version trauen kannst. Das kannst du, was ich dir hier schon sagen kann. Ich machte mein Update bereits und behob gleich Fehler, die angezeigt wurden.

Wie datest du auf MediaWiki 1.31.0 up?

Du lädst dir die neue MediaWiki-Version herunter, auf den offiziellen Webseiten oder direkt als TAR-Archiv aus der Mail heraus, falls du den Newsletter von den Machern dieses Wikis abonniert hast. Sollte man, wenn man damit arbeitet.

Danach gilt es, alles lokal zu entpacken und arbeite hierbei mit Konsole, die du eh zum Updaten brauchst. Packe den Inhalt des Paketes zum ZIP-Archiv, lade es zum Server hoch und navigiere in der Konsole zum jeweiligen Verzeichnis mit diesem Befehl.

cd meinverzeichnis

Von dort aus musst du das Archiv so entpacken.

unzip meinarchiv.zip

Danach wieder so löschen.

rm -rf meinarchiv.zip

Als nächstes muss Composer selbst upgedatet werden, was so geht.

php composer.phar self-update

Dann aktualisierst du alle Abhängigkeiten, die in der Regel im Verzeichnis /vendor sind. Das ist das normalste, was man so macht, wenn Composer vorhanden ist.

php composer.phar update

Erst dann navigierst du mit “cd maintenance” zum Wartungsverzeichnis und führst in der Kommandozeile diesen Befehl aus.

php update.php

Beobachte das Ganze via SSH und schaue dich danach im Frontend um, logge dich im Backend ein, begutachte deine Installation, ob alles OK ist. Übrigens der visuelle Editor, der neue, meine ich, funktioniert schon seit der letzten Version nicht, weil etwas nicht laden kann. Du kannst im Quelltext-Editor arbeiten, hast aber keinen Luxus einer BlueSpice MediaWiki-Installation mit dem eigenen Wysiwyg-Editor.

Falls dir danach ist, quatsche mich per Mal darauf an und gegen eine kleine Gebühr kann ich es dir installieren.

Es sollte wohl noch im Sommer 2018 BlueSpice 3 erscheinen, welches mit MediaWiki 1.30+ kompatibel sein soll. Leider kam es dazu noch nicht, warum auch immer. Wir bleiben mal geduldig, es wird kommen, wenn die Entwickler soweit sind. Bis dahin hast du BlueSpice 2.27.3 oder so etwas und MediaWiki 1.31.0. Mit beiden Installationen wünsche ich dir Spass und Erfolg.

Das wäre es auch schon zu diesem Thema.

by Alexander Liebrecht

OpenProject v7.4.5 Bugfix-Update draussen

openproject-support-foren

Hallo Blogleser! Auch dieses Update werde ich dir nicht vorenthalten, denn es geht um eine weitere Linux App namens OpenProject, die ich unter http://op.apps-tools-cms.de laufen lasse.

 

Zum Update passend gibt es auch den offiziellen Blogpost unter https://www.openproject.org/openproject-7-4-5-released/ , was du dir hinterher mal ansehen kannst. Die neue OpenProject-Version v7.4.5 kam mit etlichen Verbesserungen sowie den Bugfixes, so genannten Fehlerbehebungen, daher. Ich habe gleich das offizielle Repo auf Github unter https://github.com/opf/openproject-ce/releases gecheckt und fand dadurch das neue Update.

Das wird dann gleich im eigenen Rootserver möglich gemacht und du brauchst lediglich das ce-repo nach /etc/yum.repos.d hochzuladen bzw. machtest es bereits bei der Erstinstallation von OpenProject. Das muss in diesem Verzeichnis zu finden sein, eher du mit “yum update” aktualisieren kannst. Das kannst du im Vorfeld checken.

Ich warte alles auf OP 4.8 mit neuem Wysiwyg-Editor

Das wird sehr spannend bis dahin, denn schon im Sommer dieses Jahres kommt OpenProject 4.8 auf den Markt. Dabei ist das eine Feature mit dem Wysiwyg-Editor sehr spannend, denn heute postest du in OP in der Textile-Sprache und kannst damit nicht so gut arbeiten. Entweder Markdown oder HTML, sage ich mir immer. Alle anderen Sprachen sind weniger nutzerfreundlich, zumindest aus meiner Nutzer/Admin-Sicht heraus gesehen.

Beide Linux Apps wie OP und Gitlab lassen sich bequemerweise mit “yum udpate” aktualisieren und damit es so ist, nimm bei der Erstinstallation immer den Package Installer so wie es in der offiziellen Doku steht. Nur so kannst du dann besser installieren und hast im Falle von OpenProject keinerlei Probleme mir rubygems oder rubys oder sonstigem, was du das haben wirst.

[bctt tweet=”#OpenProject #Bugfix #Update v7.4.5 draussen. Das Update kann ohne Probleme installiert werden!” username=”blogsash”]

So viel zu diesem Update und ich mag demnach auch kurze Blogposts schreiben, wenn es sich so anbietet. Diese sind leichter von dir, dem Leser, zu erfassen und solche Posts werden meistens bis zum Ende durchgelesen. Das weiss jeder Blogger. Ich wünsche dir erfolgreiches Upgraden deiner OP-Instanz und bei schwerwiegenden Problemen kannst du dich an das offizielle Support-Forum unter https://community.openproject.com/projects/openproject/boards wenden. Dort bekommst du meistens zeitnahe Hilfestellung bei allen OpenProject-Fragen und Problemen.

by Alexander Liebrecht

Gitlab Server v10.8.2 Sicherheitsupdate draussen – dringend updaten!

gitlab-10-8-2-sicherheitsudpate-internetblogger-de

Hallo lieber Leser! Gar nicht so einfach, bei diesen heissen Temperaturen noch dem Bloggen nachzugehen und ausserdem testete ich auf dem Rootserver neue Sicherheitslösung von Atomicorp, die sich leider nicht bewährte. Daher war mein Rootserver-Portfolio mehrmals in den letzten Tagen nicht erreichbar. Es war so, dass der gesamte Verkehr auf dem Server blockiert wurde, weil um diese Sicherheitslösung richtig einzustellen, musst du ein Linux-Profi sein und ich habe lediglich Linux-Erfahrungen.

Aber ok, jetzt darf es hier mit dem Update für Sicherheit beim neuen Gitlab Server 10.8.2 gehen. Das Update ist erschienen, soll dringenderweise schnell installiert werden und wurde unter https://about.gitlab.com/2018/05/29/security-release-gitlab-10-dot-8-dot-2-released/ dokumentiert. Dort kannst du alles entnehmen, was das Update verursachte und wie du updaten kannst, wird weiter unten zu finden sein.

Update auf Gitlab Server 10.8.2

yum update

Mit diesem SS-Befehl aktualisierst du Gitlab unter Centos 7 OS/Linux. Mein Update war mir gestern gelungen, doch Atomicorp Secure Linux blockierte alle meine Linux Apps. Da kannst du nicht im Live-Betrieb eine Woche lang alles testen und das Portfolio wird nicht erreichbar sein. Daher sah ich von dieser Sicherheitslösung nun gänzlich ab und gut so. Ich muss anders den Server sichern.

Führe bitte nach dem Gitlab-Update noch diese Befehle in der Kommandozeile aus.

gitlab-ctl restart

gitlab-ctl tail

Mit dem letzten SSH-Befehl erfährst du, was da alles startet und kannst die Gitlab-Logs in der Kommandozeile gerne auslesen. So weisst du, was richtig war und wie du Fehler beheben kannst bzw, wo du dann anpacken kannst.

Nach 30 Tagen seit dem Update werden Sicherheitsprobleme im Gitlab Issue Tracker publiziert, aber dennoch solltest du mit dem Updaten ja nicht warten. Mache es einfach, wenn du gerade mal Zeit gefunden hast. Dann wären du und dein Server auf der sicheren Seite.

Gitlab Entwicklung auf Github beobachten

Unter https://github.com/gitlabhq/gitlabhq kannst nach Updates schauen und dort musst du sie ja nicht downloaden, weil das eigentliche Update via SSH gemacht wird.

[bctt tweet=”#Gitlab #Server #Sicherheitsupdate v10.8.2 erschienen. Bitte einmal aktualisieren!” username=”blogsash”]

Meine eigene Gitlab App mit bereits erstellten 7 Projekten kann unter http://gitlab.apps-tools-cms.de aufgerufen werden. Die Confluence App hat noch Fehler, weil da in der Konsole für JAVA das Memory abgefragt wird. Diesem Problem bin ich bereits hinterher und werde es die Tage lösen.

So viel für diesen Moment zum Gitlab-Update, meiner Confluence App. Falls du Probleme via SSH bekommen solltest, sprich diese bitte hier in den Kommentaren an. Gerne poste ich diesen Blogpost zudem noch in Twitter, da ich mit Facebook derzeit nicht viel mache und weiss nicht, ob ich es noch brauche.

by Alexander Liebrecht

Gitlab 10.5.5 Fehlerbehebungsupdate erschienen

gitlab-10-5-5-update-fehlerbehebungen

Hallo Blogleser, wegen der privaten Veränderungen konnte ich hier nicht öfters bloggen, fand aber heute Zeit dafür. In diesem Blogpost geht es um das neue Gitlab Server Update auf die Version 10.5.5.

Das neue Gitlab Update hatte wieder mal etwas mit etlichen Fehlerbehebungen zu tun und sollte doch schon installiert werden. Ich machte das Update schon unter http://gitlab.liebrechts-portfolio.de und unter https://about.gitlab.com/2018/03/19/gitlab-10-5-5-released/ kannst du etwas zum neuen Update nachlesen.

Gitlab Updates lassen sich in der Regel super durchführen, wobei du nur mit der Konsole arbeitest. Via SSH lässt sich Gitlab aktualisieren.

Nimm den unteren SSH-Befehl vom Root aus in der Konsole und führe es aus.

yum update

Dabei kannst du das Update via Kommandoteile nachverfolgen und bekommst alles mit. Nach dem Update empfehle ich immer diesen beiden SSH-Befehle auszuführen, um alles zu checken.

gitlab-ctl restart

gitlab-ctl tail

Wenn die Worker gestartet sind und es der richtige Port deines Gitlab Servers ist, kannst du davon ausgehen, dass dann auch alles im Browser starten wird. Das kannst du gerne bei dir ausprobieren.

Gitlab 10.6

Das ist nicht mehr hinter den weiten Bergen und wird bald auf uns Gitlab Admins zukommen. Es wird dann vermutlich ein etwas grösseres Update sein, mit Features und neuen Fehlerbehebungen.

Ich halte dich im Portfolio jedenfalls auf dem Laufenden. Gitlab ist eine klasse Software, um mit der GIT-Versionskontrolle zu arbeiten und eigene Projekte in der GIT zu erstellen. Du kannst es dir bei mir in der Installation ansehen, die ich oben verlinkte.

Dir wünsche ich erfolgreiches Upgraden deiner Gitlab Server Instanz.

Bei Fragen zum SSH-Update feedbacke bitte darunter.

by Alexander Liebrecht

Bildquelle via https://gitlab.com

Confluence Server v6.7.2 Fehlerbehebungsupdate erschienen

confluence-server-6-7-2-fehlerbehebungsupdate-internetblogger-de

Hallo Blogleser! Heute komme ich wieder zum Bloggen hier auf Internetblogger.de und es geht gleich um das neue Confluence Server Update v6.7.2, welches heute nach draussen befördert wurde.

 

Details zu diesem Bugfix-Update gibt es auf den Seiten von Atlassian unter https://confluence.atlassian.com/doc/issues-resolved-in-6-7-2-946603654.html und dort siehst du die Fehler, die mit dem Update behoben wurden. Mir geht es immer um das erfolgreiche Aktualisieren meiner Confluence Server Instanz. Das Update gelang mir ganz gut und daher kann man das an die Stammleser des Portfolios weitertragen.

Wie kannst du auf Confluence 6.7.2 aktualisieren?

Lade dir im Vorfeld die letzte Confluence Server Version, je nach Betriebssystem von den Atlassian Webseiten herunter und entpacke den Installer nicht, denn es ist eine .bin-Datei. Sie wird denn server-technisch ins Verzeichnis /usr/bin hochgeladen und man vergibt dem Bin-Linux-Installer CHMOD von 755. So kann dieser via Konsole vom selbigen Verzeichnis aus ausgeführt werden.

Logge dich mit einem SSH-Client in der Kommandozeile ein und wechsele so zum Bin-Verzeichnis.

cd /usr/bin

Von dort aus, speziell bei dieser Confluence Version, tippst du das in der Konsole ein.

./atlassian-confluence-6.7.2-x64.bin

Das Update-System wird in der Kommandozeile starten und du wählst ein Upgrade von einer bereits existenten Installation von Confluence Server. Beobachte das Update via SSH und reagiere, wenn die Konsole nach Ja oder Nein fragt bzw. wenn du fortfahren musst, nachdem die Local Modifications ausgelesen wurden. So gilt es dann oft auf Enter zu drücken.

 

Am Update-Ende via SSH startet die Confluence Instanz neu, du geduldest dich mehrere Minuten, eher du es im Browser aufrufen kannst. Dann sollte das klappen.

Mächtige Probleme heute mit dem Rootserver

Heute war mein Rootserver-Portfolio unerreichbar, weil ist stets im Browser “connections errors” hatte. So habe ich letztendlich eine Plesk Anleitung auf Englisch gefunden, bei der ich den Port 80 mit in die Firewall aufnehmen musste. Jetzt seit einigen Stunden sind meine Blogs und Foren wieder erreichbar und ich weiss nicht, was dann wieder nachts passiert. Ich muss es weiter beobachten, eher ich offline sein kann. Es kann ja anders so nicht weitergehen.

Der Webhoster bat mich um einen Server-Test, welchen ich noch nicht kenne. Es muss durchgeführt werden, um die Server-Anbindung zu testen. Ich glaube aber nicht, dass es daran etwas auszusetzen gibt.

[bctt tweet=”#Confluence #Server #Update v6.7.2 erschienen – Fehlerbehebungen!” username=”blogsash”]

Neulich nach dem SSH-Update von php-fpm ist es gleich danach zu Server-Problemen gekommen. Ich musste mich mehrmals ins Internet anmelden und auch MariaDB immer wieder neu starten. Apache muss auch immer neu gestartet werden, was du in Centos 7 so tun kannst.

service httpd restart

service mysql restart

Diese beiden SSH-Befehle sind leicht zu merken.

Ich hoffe, dass Internetblogger.de nun wieder durchgehend erreichbar ist, ansonsten gibt es dann Rückmeldungen meiner Kunden und anderer Besucher. Daher gingen die Traffic-Zahlen der letzten 24 Stunden nach unten. Demnach konnten auch die Blog-Besucher Internetblogger.de nicht aufrufen. Das beschäftigt mich derzeit sehr.

Nun gut, ich wünsche dir erfolgreiches Upgraden deiner Confluence Server Instanz und falls es mal im Browser nicht startet, kann es an der Server-Firewall wie den iptables liegen. Diese habe ich gestoppt bei mir, was so geht.

service iptables stop

service iptables status >> so checkst du den Status dieser Firewall

In Plesk gibt es eine weitere Firewall und da muss eben der Port 80 eingetragen und die Verbindungen sollen zugelassen werden.

Soweit meine Untersuchungen heute.

by Alexander Liebrecht

 

 

Gitlab Server mit Sicherheitsupdate auf Version 10.4.3 erschienen

gitlab-support-forum

Hallo Blogleser! Denke bitte nicht, ich würde Internetblogger.de vernachlässigen. Hier wird nichts vernachlässigt und ich hatte einfach keine passenden Themen für dieses Blog in den letzten Tagen, sodass nichts publiziert werden konnte. Woanders bloggte ich aber fleissig.

 

Ich habe im Portfolio paar mehr Projekte, die aufgebaut werden müssen, daher versuche ich, mich um alles zu kümmern. Auf dem Internetblogger.de arbeite ich zudem mit allerhand Gastautoren zusammen, die mir ihre Themen vorschlagen dürfen. Jetzt aber zum wirklichen Thema dieses Blogposts.

Es waren nämlich Sicherheitsupdates für den Gitlab Server erschienen. Gitlab Server ist eine Linux App und kann beispielsweise unter Centos 7 zum Laufen gebracht werden. Das nutze ich derzeit unter http://gitlab.liebrechts-portfolio.de und dort auf der Login-Startseite musst du unten im Footer zu “Explore” gehen. Dahinter befinden sich meine Gitlab-Projekte.

Sicherheit einer Software geht weiterhin vor

Ich bin sehr vorsichtig geworden und bin aber nicht paranoid. Die Sicherheitsupdates gehören immer installiert, sodass ich mir bewusst Zeit dafür nehme. So ist es auch dieses Mal gewesen, was nach sich zog, das Gitlab Server Update v10.4.3 installieren zu müssen.

Allerhand Sicherheitsfixes sind in die neuen Versionen geflossen und auf Github kann man schon v10.4.4 downloaden. Dazu wird in den nächsten Tagen im Gitlab-Blog ein Artikel erscheinen, was ich mir jedenfalls ansehen werde. Vermutlich ein neues Bugfix/Sicherheitsupdate oder neue Funktionen. Die RC8 vom Gitlab Server 10.5 steht bereits auf Github zur Verfügung. Du kannst es nun nicht in deine Instanz bringen, weil das Update noch nicht angeboten wird mit “yum update”.

Wie kannst du auf Gitlab Server 10.4.3 aktualisieren?

Für Centos 7 OS gilt immer derselbe SSH-Befehl, der so geht.

yum update

Vorher muss unter /etc/yum.repos.d das Gitlab Repo für ce/ee Edition sein. Erst dann kannst du aktualisieren. Das heutige Update verlief ohne Probleme und ich konnte mich kaum beschweren.

Sobald du das Update via Kommandozeile vollzogen hast, entferne bitte das Gitlab Repo wieder aus /etc/yum.repos.d, denn sonst kann es mit Plesk/yum-Updates passieren, dass deine Instanz wieder aktualisiert wird. Das kann zur Folge haben, dass sie auch mal nicht erreichbar sein wird. Alles schon gewesen bei mir.

Unter https://about.gitlab.com/2018/02/07/gitlab-security-10-4-3-plus-10-3-7-plus-10-2-8-blog/ kannst du nachlesen, welche Behebungen es gegeben hatte. Ich habe mir die Seite im Browser übersetzen lassen, denn es ist die technische englische Sprache, die man erstmals beherrschen muss.

Gitlab Logs checken und Gitlab via SSH neu starten

Nach dem Konsolen-Update kannst du nochmals diese Befehle ausführen.

gitlab-ctl restart

gitlab-ctl tail

Beim “gitlab-ctl tail” siehst du, ob es deiner Instanz gut geht, denn es werden die Log-Dateien ausgelesen und dir werden Details der Prozesse in Gitlab angezeigt. So checke ich immer ob die Prozesse gestartet sind und ich die Instanz im Browser problemlos aufrufen kann. Wenn dies nicht der Fall ist, musst du diese Logs beachten und nach Fehlern suchen. Es gibt auch die Möglichkeit, sich an die Gitlab Community unter https://forum.gitlab.com/ zu wenden.

Ich bin ja bisher mit Gitlab gut weggekommen und kam gut zurecht. Nur anfangs bei den Erstinstallationen wollte dies oder jenes nicht funktionieren. Ich entschied mich dann letztendlich für die EE-Edition, die ich aber wohl dann auch nicht kaufen werde. Es schränkt mich, sie ohne Lizenz zu nutzen, insofern ein, dass mir ein paar weitere Funktionen nicht zur Verfügung stehen. Alles andere kann ich in Gitlab aber machen.

Falls du Fragen zum SSH-Update hast, bemühe dich hier um einen neuen Kommentar.

by Alexander Liebrecht

 

Gitlab Server 10.4.2 Fehlerbehebungsupdate erschienen – Update gelungen

gitlab-server-10-4-2-update-fehlerbehebungen-internetblogger-de

Hallo Blogleser! Zeit für neue Updates und den Gitlab Server erwischte es kürzlich, sodass die neue Version 10.4.2 ins Virtuelle verfrachtet wurde.

Das Update habe ich schon installiert, um auch das mal zu erleben, denn von Update zu Update kann es verschieden ausfallen und der Rootserver spielt dabei auch eine nicht ungewichtige Rolle.

Dieses Update auf die Fehlerbehebungsversion 10.4.2 kann durch dich vorgenommen werden. Selbstverständlich spielt deine Server-Konfiguration eine eigene Rolle. Mir liegt dabei Centos 7.4 mit Plesk vor, sodass meine Gitlab Server Instanz sich unter http://gitlab.liebrechts-portfolio.de befindet.

Und das neue Update wurde unter https://about.gitlab.com/2018/01/31/gitlab-10-dot-4-dot-2-released/ erwähnt sowie beschrieben. Gitlab Updates in Centos OS werden immer so durchgeführt.

yum update

Vorher sorge dafür, dass du unter /etc/yum.repos.d das Gitlab CE/EE Repository hast. Dann wird alles stattfinden mit dem Update.

Der Gitlab Server wird via Kommandozeile aktualisiert, sodass Backups gemacht werden. Die Version 10.4.1 wird entfernt, neue Version kommt drauf und am Ende starten alle Gitlab Prozesse neu. Du kannst gerne nochmals diese SSH-Befehle nacheinander ausführen.

gitlab-ctl restart

gitlab-ctl tail

Beim letzten SSH-Befehl siehst du via Konsole, was alles startet. So weisst du, ob Fehler vorliegen und kannst dann dementsprechend reagieren. Meistens oder die letzten Gitlab Server Updates verliefen zu meiner Zufriedenheit.

Somit ist das neue Fehlerbehebungsupdate zu begrüssen und kann von dir installiert werden.

So viel für diesen Moment von der Gitlab Front. Allerhand Bugs wurden gefixt und das macht nicht zuletzt den Server fit.

by Alexander Liebrecht

JIRA 7.7.0 und Bitbucket 5.7.0 Bugfixes Updates erschienen

jira-software-7-7-release-notes-bugfixes

Hi Blogleser! Neue Atlassian Updates sind draussen, nämlich JIRA Software Server 7.7.0 und Bitbucket Server 5.7.0. Beide Updates habe ich bereits erfolgreich installieren können.

Ich checke Atlassian Updates fast schon täglich, wenn nichts weiter ansteht und ich meine tägliche Atlassian-Runde mache. Bei diesen Updates haben die Entwickler im Grossen und Ganzen Verbesserungen und Fehlerbehebungen ermöglicht.

JIRA Software Server 7.7.0

Zu den Release Notes von JIRA geht es unter https://confluence.atlassian.com/jirasoftware/jira-software-7-7-x-release-notes-941594462.html und dort wird alles soweit beschrieben. Verbessert wurden zum Beispiel das Einfügen der Bilder in die Issues-Beschreibungen und auch zwei neue Sprachen wie Italienisch und Finnisch kamen zu JIRA hinzu.

Der Rest sind kleinere Verbesserungen sowie Fehlerbehebungen an der Software. Das Update kannst du durchaus durchführen, mache aber vorher ein Backup deiner Datenbank, um auf Nummer sicher zu gehen.

Das Update, wie es gemacht wird, zeige ich dir darunter.

Update auf JIRA 7.7.0 – wie geht das?

Lade dir je nach Betriebssystem wie Linux oder Windows den Bin-Installer von https://atlassian.com herunter und lade es wieder zum Server ins Verzeichnis /usr/bin hoch. Vergib dem Installer CHMOD-Rechte von 755, damit du ihn ausführen kannst. Danach folgt von diesem Verzeichnis aus dieser SSH-Befehl in der Konsole.

./atlassian-jira-software-7.7.0-x64.bin

Demnach beobachtest du Konsolen-Hinweise und machst das Update einer bereits existenten JIRA Software Server Installation. JIRA-Installer bzw. Upgrader macht die ganze Arbeit für dich und du reagierst nur auf die Wünsche des Upgraders.

Ich habe in meinem JIRA noch kaum etwas gemacht, was unter http://jira.liebrechts-portfolio.de:8090 ist. Im Frontend kannst du noch keinerlei Projekte finden, denn erst musst du die Berechtigungen dafür setzen, damit sie durch anonyme Gäste eingesehen werden können.

Nun etwas zum Bitbucket Server 5.7.0.

Bitbucket Server 5.7.0 Bugfix Update

Laut den Release Notes unter https://confluence.atlassian.com/bitbucketserver/bitbucket-server-5-7-release-notes-939918798.html kann ich entnehmen, dass die ElasticSearch aktualisiert wurde. Auch waren es zahlreiche Fehlerbehebungen beim Bitbucket Server. Das Update kannst du auch hier durchaus machen. Mache vorher ein Backup deiner Datenbank.

Wie das Update funktioniert, zeige ich dir im Folgenden und mein Update war erfolgreich. Was anderes erwartest du hier auch nicht oder….

Upgrade auf Bitbucket Server 5.7.0 – wie geht das?

Das Update machst du analog wie beim JIRA Software Server. Es gibt den Linux-Installer, welcher ins Verzeichnis /usr/bin hochgeladen wird. Dem Installer vergibst du CHMOD-Rechte von 755, damit du ihn ausführen kannst.

Danach gilt von diesem Verzeichnis aus folgender SSH-Befehl zum Upgraden.

./atlassian-bitbucket-5.7.0-x64.bin

Diesen Befehl demnach dann ausführen und du folgst allen Hinweisen in der Konsole. Es wird nicht allzu schwer sein, ein Bitbucket-Upgrade zu machen.

Das wäre eigentlich auch schon alles, was gemacht werden muss. Ach ja, ich habe es schon so oft erwähnt, dass du das MySQL-Plugin aus dem alten Bitbucket-Install-Verzeichnis wieder ins neue Install-Verzeichnis nach /opt/atlassian/bitbucket/5.7.0/app/WEB-INF/lib hochladen musst, denn andernfalls startet Bitbucket im Browser nicht.

Ich wünsche dir demnach erfolgreiches Upgraden.

by Alexander Liebrecht

 

JIRA Software Server 7.6.2 + Bitbucket Server 5.6.2 Updates erschienen

JIRA-7-6-erscheinungsnotizen-release-notes-atlassian-apps

Hallo lieber Leser! Nun, ich hoffe, dass du in das Neue Jahr 2018 gut reingekommen bist. An dieser Stelle nochmals allen tolles neues Jahr 2018 und viel Erfolg als Webworker, Blogger, Webmaster oder System-Admin. Das sollte man sich wünschen können. Nun zum Thema dieser frühen oder noch nächtlichen Stunde. Ich will jetzt sofort bloggen und habe für dich Updates von JIRA Software Server 7.6.2 und Bitbucket Server 5.6.2.

 

Diese beiden Updates habe ich heute installiert. JIRA Server habe ich unter http://jira.liebrechts-portfolio.de:8090, wobei ich dort noch keinerlei Content erstellen konnte. Die Datenbank-Tabellen müssen vom Zeichensatz UTF8 nach UTF8 Bin konvertiert werden, was noch lange dauern wird. Einen global gültigen MySQL-Query fand ich zwar auch direkt auf den Atlassian Seiten, aber dennoch konvertiert es mir einzelne Tabellen nicht. Da muss ich, wenn ich Langeweile habe, manuell heran und Tabelle für Tabelle konvertieren.

Den Bitbucket Server habe ich derzeit unter http://bitbucket.liebrechts-portfolio.de:7990 und das Projekt ist noch nicht vollständig eingerichtet, denn mir fehlen Plugin-Lizenzen, die noch dieses Jahr käuflich erworben werden müssen. Dann kann ich mit dem Projekt auch schon wesentlich mehr anfangen.

JIRA Software Server auf Version 7.6.2 bringen – wie geht das?

JIRA wie auch Bitbucket sind Linux/Windows-Apps von Atlassian und müssen per SSH upgedatet werden. Dafür musst du dir die jeweiligen beiden Linux-BIN-Installer von https://atlassian.com herunterladen, sie dann unentpackt ins Verzeichnis /usr/bin wieder hochladen. Dem einzelnen Linux-Installer vergibst du CHMOD von 755, damit dieser ausführbar ist.

Dann im Falle des aktuellen JIRA-Updates gilt dieser SSH-Befehl.

./atlassian-jira-software-7.6.2-x64.bin

Das führst du vom Verzeichnis /usr/bin aus. Vorher wechselst du dorthin mit dem unteren SSH-Befehl.

cd /usr/bin

Beim Upgrade nimmst du das Upgrade von “an existing Installation” und folgst den Anweisungen in der Konsole. JIRA wird backupt, das Alte wird gelöscht, neue Files werden entpackt und zum Schluss startet JIRA Server im Browser neu. Falls dies nicht geschieht, checkst du wie gehabt mit dem unteren Befehl, was da an JIRA im Server am Laufen ist. Das geht dann so.

ps -aux | grep jira

Findest du JIRA, dass es bereits läuft, lösche alle Tomcat-Prozesse mit dem “kill <pidid>“-Befehl.

Starte dann JIRA vom Verzeichnis /bin wieder derart neu.

su jira >> zum JIRA-User wechseln
 cd /opt/atlassian/jira/bin >> wechseln zum richtigen /bin-Verzeichnis für JIRA
 sh start-jira.sh

Oder, um das Ganze in der Konsole zu verfolgen dann so.

sh start-jira.sh -fg

Sobald du das wieder mit STR+C beendest, musst du das ohne die Endung “-fg” neu starten.
Das wäre zu JIRA Software Server und dem aktuellen Update. Das Ganze kann man beim Bitbucket Server fast schon analog anwenden.

Upgrade von Bitbucket Server auf die Version 5.6.2 >> Bugfix-Update

Lade dir den jeweiligen Linux-Installer von den Atlassian Webseiten herunter, unentpackt dann nach /usr/bin hochladen und CHMOD-Rechte von 755 vergeben.

Dann führst du von dem Verzeichnis aus diesen SSH-Befehl in der Kommandoteile aus.

./atlassian-bitbucket-5.6.2-x64.bin

Falls dir angezeigt wird, auf Englisch, dass das Binden an den Port 7992 nicht geht, suche mit dem unteren Befehl nach allen Tomcat-Prozessen für Bitbucket innerhalb des Servers. Das geht dann so.

ps -aux | grep bitbucket
 ps -aux | grep 7992
 ps -aux | grep java

Danach einfach die PidID killen, mit “kill <pidid>”

Bitbucket Server Upgrader ist keine Hexenkunst und führt dich meistens zum Erfolg. Date die bereits existente Installation up, sprich Upgrading an existing Bitbucket Installation.

Was brachten JIRA 7.6.2 und Bitbucket 5.6.2 mit?

Es waren etliche neue Fehlerbehebungen und deswegen solltest du dir etwas Zeit zum Upgraden schon noch nehmen. Bugfix-Updates sind immer gerne gesehen, denn dann funktioniert die Atlassian App auch etwas besser.

Links, die ich für dich dazu noch habe, wären wie folgt: https://confluence.atlassian.com/jirasoftware/jira-software-7-6-x-release-notes-938027181.html und https://confluence.atlassian.com/bitbucketserver/bitbucket-server-5-6-release-notes-939918647.html. Alles englisches Material, aber zum Stöbern und Nachlesen reicht das.

Bei Fragen zum Upgrade feedbacke mich darunter im Kommentar-Sektor.

by Alexander Liebrecht

Gitlab Server 10.2.5 mit Fehlerbehebungen und Performance Verbesserungen

gitlab-10-2-5-bugfixes-performance-verbesserungen-internetblogger-de

Hallo lieber Leser! Feiertage halten keinen Entwickler auf, sodass weiterhin an der hauseigenen Software wie Gitlab gearbeitet wird. Es kam nämlich die neue Version 10.2.5 heraus und das Update konnte ich erfolgreich installieren, aber…

Unter SSL funktioniert das Login nicht und es gibt etliche Untersuchungen seitens der Gitlab-Gemeinde. Leider konnte nicht ersehen wie das mit SSL geregelt werden kann. Vorher war meine Gitlab-Instanz unter http://gitlab.liebrechts-portfolio.de auch ohne SSL und wird auch demnach so bleiben. Zwecks SSL liegt es nicht am SSL-Zertifikat, sondern direkt an Gitlab und diese Software ist sehr komplex.

Falls du es ohne SSL hast, wird deine Instanz auch nach dem Update auf 10.2.5 funktionieren.

Was beinhaltet das Update auf Gitlab 10.2.5?

Es waren Fehlerbehebungen bei den CE/EE-Editionen und Performance Verbesserungen für beide Editionen. Somit lohnt sich das Updaten schon noch. Das machst du mit dem SSH-Befehl “yum update”, was unter Centos 7 OS so gilt.

Ich beanspruche die EE-Edition, von der die Lizenz gestern ausgelaufen ist. Nun werde ich es beobachten, ob die Arbeit mit meiner Instanz durch das Beenden der Lizenzgültigkeit eingeschränkt sein wird. Wenn nicht, lasse ich es erstmals so laufen, aber gerne würde ich schon noch bei der EE-Edition bleiben. Es hat bisher am besten funktioniert und die EE-Edition Lizenz kostet dann im Jahr etwas. Das setze ich mir auf die ToDo-Liste für 2018.

Unter https://about.gitlab.com/2017/12/18/gitlab-10-2-5-released/ kannst du weitere Update-Hinweise gerne entnehmen und es sind auch Fehler aufgeführt, die gefixt wurden. Alles zusammen macht unseren Gitlab Server etwas besser im Funktionieren.

CMS-Updates schneien nur noch so rein und auch kurz vor Weihnachten. Das wird alles mitgenommen im eigenen Portfolio, denn das Meiste ist eine reine Routine und kann oft schnell hinter einen gebracht werden.

Falls du Fragen zum Update hast, nutze bitte darunter die Kommentare.

by Alexander Liebrecht

 

Flarum-Erweiterung Profil-Ansichten – ProfileViews installieren

flarum-erweiterung-profil-ansichten-profileviews-installation

Hallo Blogleser! Flarum-Forum entwickelt sich rasant und immer mehr neue Erweiterungen werden den Nutzern sowie der Community zur Verfügung gestellt. Hierbei geht es um die neue Flarum-Erweiterung namens ProfileViews, sprich Profil-Ansichten(wie oft wurde dein Flarum-Profil angesehen?) Nach der Flarum-Extension mit den Ansichten der Forum-Topics kam diese Erweiterung und sie ergänzen sich doch ganz gut. Wie … Weiterlesen

Video-Anleitung zum Ausmachen der Tomcat-Prozesse von Confluence, JIRA und Bitbucket

Hallo lieber Leser und Zuschauer! Heute brachte ich ein weiteres Dailymotion-Video heraus, in welchem ich dir zeige wie du die Tomcat-Prozesse für JIRA, Bitbucket und Confluence mittels Kommandozeile ausmachen, beenden und neu starten kannst. Ich legte dabei grossen Wert darauf, dass du das mittels Kommandozeile nachvollziehen kannst. Die jeweiligen SSH-Befehle kannst du dir dann vielleicht … Weiterlesen

Confluence Server 6.5.1 draussen mit ein paar Fehlerbehebungen

confluence-6-5-1-update-bugfixes

Hallo Blogleser! Im heutigen Blogpost spreche ich kurz Confluence Server und sein Update an. Die neue Version 6.5.1 erblickte die Welt wie du unter https://confluence.atlassian.com/doc/issues-resolved-in-6-5-1-939947800.html entnehmen kannst. Das Update tat ich meiner Installation bereits erfolgreich an.

Weiterlesen

Gitlab Server auf Version 10.1.3 aktualisieren – wie geht das

gitlab-server-10-1-3-erschienen-regressions-fixes-bugfixes-update

Hallo lieber Blogleser und Gitlab Server Admin! Gitlab brachte positive News zu den Nutzern des Gitlab Servers. Ein neues Update auf die Version 10.1.3 war erschienen und dokumentiert wurde es unter https://about.gitlab.com/2017/11/10/gitlab-10-dot-1-dot-3-released/.

 

Gitlab Server kann auf verschiedenen Betriebssystemen wie auch meinerseits unter Centos 7.4 installiert werden. Meine eigene Instanz ist unter https://gitlab.liebrechts-portfolio.de aufgesetzt. Nur noch mit SSL von Let’s Encrypt klappt es nicht, weil ich die maximale Anzahl an Erneuerungen des SSL-Zertifikats bereits überschritten habe. Ich muss mich noch mehrere Tage gedulden, bis es wieder funktioniert. Aber an sich ist meine Instanz bereits aufrufbar.

Gitlab Server 10.1.3 kam mit Regressions-Fixes und Bugfixes daher

Das kannst du hinter dem oben gesetzten Linkverweis gerne vorfinden. Fehlerbehebungen seitens der Entwickler-Front sind immer wieder herzlich willkommen und das macht die Software ein Stück besser sowie funktionsfähiger. An Issues, so genannten Tickets, für Gitlab CE(Community Edition) und Gitlab EE(Enterprise Edition, was ich habe) mangelt es nicht. Die global ansässige Gitlab Community macht das Beste draus und hilft bei allen Belange und Problemen, was sehr schätzenswert ist.

Upgrade auf Gitlab Server 10.1.3 – wie geht das?

Das Upgrade konnte ich heute zum allerersten Mal erfolgreich vollbringen, wofür mir die Konsole und ein paar Befehle wie diese dienten.

yum update

“yum” >> gilt immer für RedHat/Centos OS.

Ich gehe davon aus, dass du Gitlab Server bereits aufsetztest und müsstest nur noch das Upgrade hinter dich bringen. Das geht dann mit oben gezeigtem Befehl. Falls du in Linux im Verzeichnis /etc/yum.repos.d kein Gitlab EE Repository hast, kannst du es mit diesem SSH-Befehl hinzufügen.

curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ee/script.rpm.sh | sudo bash

Meine Empfehlung, erfahrungsbedingt

Lösche bitte das Gitlab EE/CE Repo aus diesem Verzeichnis, denn Plesk und Centos aktualisieren sich oft von selbst, sodass es passieren kann, dass deine Instanz nicht mehr korrekt funktioniert. Lade die Datei mit dem Repo in einen Windows-Ordner herunter, bewahre sie dort auf und lade sie bei Bedarf und nach dem du Release Notes checktest wieder hoch. Damit sorgst für ein einwandfreies Funktionieren deiner Gitlab Server Instanz.

Mit “yum update” wird Gitlab EE/CE Repo aufgerufen, Aktualisierungen werden mittels SSH installiert und so wird deine Gitlab Instanz in der Kommandozeile neu gestartet. Das heisst, dass alle Prozesse und Ports, die für Gitlab gelten, inkl. der PostgreSQL-Datenbank werden neu gestartet. Ich zeige dir mal einen solchen Update-Ausschnitt von heute aus meinem Kommandozeilen-Update des Gitlab Server EE.

Resolving Dependencies
--> Running transaction check
---> Package gitlab-ee.x86_64 0:10.1.1-ee.0.el7 will be updated
---> Package gitlab-ee.x86_64 0:10.1.3-ee.0.el7 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================
 Package Arch Version Repository Size
====================================================================================================
Updating:
 gitlab-ee x86_64 10.1.3-ee.0.el7 gitlab_gitlab-ee 399 M

Transaction Summary
====================================================================================================
Upgrade 1 Package

Total download size: 399 M
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
gitlab-ee-10.1.3-ee.0.el7.x86_64.rpm | 399 MB 00:00:10
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
gitlab preinstall: Automatically backing up only the GitLab SQL database (excluding everything else!)
Dumping database ...
Dumping PostgreSQL database gitlabhq_production ... [DONE]
done
Dumping repositories ...
[SKIPPED]
Dumping uploads ...
[SKIPPED]
Dumping builds ...
[SKIPPED]
Dumping artifacts ...
[SKIPPED]
Dumping pages ...
[SKIPPED]
Dumping lfs objects ...
[SKIPPED]
Dumping container registry images ...
[DISABLED]
Creating backup archive: 1510739190_2017_11_15_10.1.1-ee_gitlab_backup.tar ... done
Uploading backup archive to remote storage ... skipped
Deleting tmp directories ... done
done
Deleting old backups ... skipping
 Updating : gitlab-ee-10.1.3-ee.0.el7.x86_64 1/2
 Cleanup : gitlab-ee-10.1.1-ee.0.el7.x86_64 2/2
Checking PostgreSQL executables: OK
Shutting down all GitLab services except those needed for migrations
ok: down: gitaly: 0s, normally up
ok: down: gitlab-monitor: 1s, normally up
ok: down: gitlab-workhorse: 0s, normally up
ok: down: logrotate: 1s, normally up
ok: down: node-exporter: 0s, normally up
ok: down: postgres-exporter: 1s, normally up
ok: down: postgresql: 0s, normally up
ok: down: prometheus: 0s, normally up
ok: down: redis: 1s, normally up
ok: down: redis-exporter: 0s, normally up
ok: down: sidekiq: 0s, normally up
ok: down: unicorn: 0s, normally up
ok: run: postgresql: (pid 23116) 1s
ok: run: redis: (pid 23119) 0s
run: postgresql: (pid 23116) 1s; run: log: (pid 13356) 644846s
run: redis: (pid 23119) 0s; run: log: (pid 13334) 644847s
Reconfiguring GitLab to apply migrations



* Moving existing certificates found in /opt/gitlab/embedded/ssl/certs

* Symlinking existing certificates found in /etc/gitlab/trusted-certs
gitlab Reconfigured!
Checking for an omnibus managed postgresql: OK
Checking for a newer version of PostgreSQL to install
No new version of PostgreSQL installed, nothing to upgrade to
Ensuring PostgreSQL is updated: OK
Restarting previously running GitLab services
ok: run: gitaly: (pid 23719) 0s
ok: run: gitlab-monitor: (pid 23739) 1s
ok: run: gitlab-workhorse: (pid 23698) 2s
ok: run: logrotate: (pid 23786) 0s
ok: run: node-exporter: (pid 23792) 1s
ok: run: postgres-exporter: (pid 23798) 0s
ok: run: postgresql: (pid 23116) 26s
ok: run: prometheus: (pid 23807) 0s
ok: run: redis: (pid 23119) 25s
ok: run: redis-exporter: (pid 23822) 1s
ok: run: sidekiq: (pid 23830) 0s
ok: run: unicorn: (pid 23839) 1s

_______ __ __ __
 / ____(_) /_/ / ____ _/ /_
 / / __/ / __/ / / __ \`/ __ \
 / /_/ / / /_/ /___/ /_/ / /_/ /
 \____/_/\__/_____/\__,_/_.___/



Upgrade complete! If your GitLab server is misbehaving try running
 sudo gitlab-ctl restart
before anything else.
If you need to roll back to the previous version you can use the database
backup made during the upgrade (scroll up for the filename).

Verifying : gitlab-ee-10.1.3-ee.0.el7.x86_64 1/2
 Verifying : gitlab-ee-10.1.1-ee.0.el7.x86_64 2/2

Updated:
 gitlab-ee.x86_64 0:10.1.3-ee.0.el7

So sollte es in etwa bei dir aussehen, je nachdem, welche Centos-Version du auf dem Linux-Server hast. Wenn es Centos 6 ist, musst du auch dementsprechend ein anderes Repo installieren. Zur Installation des Gitlab Servers in Centos OS kann ich dir diese Anleitung unter https://about.gitlab.com/installation/#centos-7 gerne empfehlen.

Das ist im Grossen und Ganzen die Upgrade-Prozedur. Es ist empfehlenswert, mal von Zeit zu Zeit in Google mit dem Begriff “gitlab release notes” zu suchen, um an neue Updates zu gelangen. Ich checke mittlerweile alle Atlassian Apps, OpenProject, Phabricator, Gitlab Server mit “release notes” in Google. So hast du immer, was du brauchst.

Falls du Fragen zum Upgrade hast, bemühe bitte darunter die Kommentare.

[note note_color=”#ee4821″ radius=”10″]Auch wäre es höchst erfreulich, falls du auch ein Gitlab Admin bist. Was war das Schwierigste für dich bei der Installation und was ging schnell von der Hand?[/note]

Meinerseits musste geklärt werden, an welchem Port nun Unicorn laufen soll. OpenProject ist am Port 3000, sodass der Unicorn Port schon mal am Port 6000 sein könnte. Das macht möglich, dass du OpenProject App und Gitlab Server auf einem und demselben Rootserver laufen lassen kannst. Das gilt es zu beachten.

by Alexander Liebrecht

 

 

 

Bitbucket Server 5.5.1 erschienen mit Fehlerbehebungen

bitbucket-5-5-1-erschienen-fehlerbehebungen

Hallo Blogleser! Die Kategorie Linux/Centos 7 darf wieder gefüllt werden und mir geht es um das neue Bitbucket Server Update unter Centos 7.4 in Linux OS.

Bitbucket Server 5.5.1 war mit drei Fehlerbehebungen erschienen, die du unter https://confluence.atlassian.com/bitbucketserver/bitbucket-server-5-5-release-notes-938037662.html nachschlagen kannst. Das Update verlief bei mir sehr gut unter http://bitbucket.liebrechts-portfolio.de:7990 und daher kann ich es dir auch weiter empfehlen.

Bitbucket entwickelt sich rasant weiter und manchmal gibt es ein paar Male monatlich ein solches Zwischen-Update. Das darf gerne dokumentiert werden. Wie du genau upgraden kannst, habe ich letztens schon gebracht und in diesem Blogpost nur ein paar weitere Tipps, um das Update herum.

Upgrade auf Bitbucket Server 5.5.1 – wie geht das?

Du musst den Linux-Bin-Installer von den Webseiten unter https://atlassian.com herunterladen. Noch wesentlich einfacher geht es über die Google Suche mit dem Begriff “bitbucket release notes”. So kannst du dir gleich Erscheinungsnotizen ansehen und weisst dann hoffentlich mehr über das Update.

Der Linux-Installer wird ins Verzeichnis /usr/bin hochgeladen. Danach vergibst du ihm CHMOD-Rechte von 755, damit wir ihn in der Kommandozeile ausführen können. Alle Atlassian Updates werden mittels SSH gemacht oder zumindest lernte ich den Webinstaller-Weg, falls es diesen gibt, noch nicht kennen.

In der Kommandozeile vom Verzeichnis /bin aus gibst du diesen Befehl ein.

Wechsele zuerst in das /bin-Verzeichnis so.

cd /usr/bin

Danach das eintippen.

./atlassian-bitbucket-5.5.1-x64.bin

So kannst du dich anschliessend in der Konsole orientieren. Der Verlauf des Upgrades wird dir auf Englisch angezeigt, was aber soweit verständlich sein wird. Ich habe etliche Bitbucket Server Updates hinter mir und meistens klappt es auf die Schnelle.

Bitbucket Server wird ein neues Installationsverzeichnis unter dem namen /5.5.1 beanspruchen. Der ganze Pfad dorthin lautet dann so.

/opt/atlassian/bitbucket/5.5.1

Daher muss du in der Datei httpd.conf es dementsprechend auch anpassen. Meine Bitbucket Instanz ist ohne SSL/https und daher habe ich meine Config so.

DocumentRoot "/opt/atlassian/bitbucket/5.5.1"

ProxyRequests Off
 ProxyVia Off

<Proxy *>
 Require all granted
 </Proxy>

ProxyPass / http://bitbucket.liebrechts-portfolio.de:7990/
 ProxyPassReverse / http://bitbucket.liebrechts-portfolio.de:7990/

So siehst du es nun was ich meine. Diese httpd.conf wieder hochladen und Apache neu starten.

service httpd restart

Wenn das glückt, dann sind die Konfigurationen dieser Datei korrekt.

Zudem fehlt noch im Verzeichnis /opt/atlassian/bitbucket/5.5.1/app/WEB-INF/lib der MySQL-Connector. Diesen hattest du aber schon im alten Installationsverzeichnis. Einfach von dort wieder beziehen und in das neue Verzeichnis hochladen. Ansonsten startet Bitbucket dann im Browser nicht.

Wenn du per Konsole zu Ende aktualisiertest, starte die Instanz nicht. Stoppe alle Bitbucket Services so.

service atlbitbucket stop

Danach überzeugst du dich davon, dass keinerlei Bitbucket mehr läuft mit diesem SSH-Befehl.

ps -aux | grep bitbucket

Wenn nichts ist, dann die Instanz wieder in der Konsole so starten.

service atlbitbucket start

Nachher gehst du im Browser zu deiner Instanz und lässt den Startvorgang auf dich wirken. Wenn alles im Vorfeld richtig eingestellt wurde und Apache läuft, dann startet Bitbucket Instanz nach einigen Minuten und schon kannst dich wieder dem Bitbucket Server widmen.

Das wäre so meine Prozedur mit Bitbucket Server und es sorgt immer für erfolgreiches Starten der Instanz im Browser. Falls du dazu Fragen hast, dann feedbacke darunter.

Freue mich nur über sinnvolles Feedback 😉

by Alexander Liebrecht

 

 

Flarum Erweiterung Post-Ansichten-Zähler Installation

flarum-post-views-erweiterung-installation

Hallo lieber Leser und auch Flarum Nutzer! Es gibt eine neue Flarum Erweiterung namens Discussion Views. Das heisst Post-Ansichten-Zähler in der Forumpost-Übersicht auf der Forum-Startseite. Darum geht es bei diesem Blogpost und ich will dir zeigen wie diese Flarum Erweiterung mittels Kommandozeile installiert wird.

Zur Erweiterung geht es zum englischen Support-Forum unter https://discuss.flarum.org/d/7339-discussion-views und dort steht auch der SSH-Befehl für die Installation via SSH.

Das zeige ich dir hier im Folgenden.

Discussion Views Installation via Konsole

Du loggst dich mit Bitvise Tool in der Konsole ein und navigierst zum Root deiner Flarum Installation. Falls es eine Subdomain oder ein Unterverzeichnis sind, dann mit dem “cd”-Befehl dorthin so navigieren.

cd unterverzeichnis

cd subdomain

Von dort aus führst du diesen SSH-Befehl einfach aus.

php composer.phar require michaelbelgium/flarum-discussion-views

Composer muss vorher installiert werden, sprich die Datei composer.phar muss sich im Verzeichnis befinden. Auch muss die Erweiterung phar auf dem Server installiert sein. Da kannst du höchstens bei deinem Shared Hoster danach fragen, ob es möglich wäre, mit der PHP-Erweiterung “phar” zu arbeiten. Dir wird dann meistens geholfen.

Nachdem du den Befehl ausführtest, löschst du den Flarum Cache so.

php flarum cache:clear

Das geschieht auch in der Konsole vom Rootverzeichnis aus.

Danach loggst du dich im Forum-Backend im Browser ein und unter Erweiterungen/Extensions suchst du nach “Discussion Views” und aktivierst diese Extension. Im Frontend schaut es so aus wie auf dem Beitragsbild dieses Blogposts.

Da wäre die ganze Umsetzung wegen dem Post-Ansichten-Zähler und der jeweiligen Flarum Erweiterung.

Ich wünsche dir damit viel Spass und hoffe, dass deine Flarum Posts oft aufgerufen werden.

by Alexander Liebrecht

P.S. live kannst du es dir bei mir im Flarum Board unter http://flarum.internetblogger.de ansehen.

 

Drupal 8 CMS auf Version 8.4.1 aktualisieren – wie geht das + Youtube-Video

drupal-8-4-1-update-erschienen-mit-fehlerbehebungen

Hallo lieber CMS/Blogleser! An der OpenSource CMS Front hat sich wieder etwas getan und Drupal 8 CMS in der Version 8.4.1 war erschienen. Darum wird es in diesem Blogpost gehen und ich zeige dir ebenfalls mein Update in einem Youtube-Video.

 

Über das Drupal 8.4.1 Update kannst du im englischen Post unter https://www.drupal.org/project/drupal/releases/8.4.1 etwas nachlesen. Im Grossen und Ganzen flossen in die Version 8.4.1 zahlreiche Fehlerbehebungen mit ein, sodass das zeitnahe Updaten sich in jedem Falle lohnen wird.

Eigenes D8-Update unter https://wpshopde.de verlief heute reibungslos, daher kann ich es dir auch empfehlen.

Wie machst du das Drupal 8 Update auf Version 8.4.1?

Du lädst dir die letzte D8-Version von dein Seiten unter https://drupal.org herunter, entpackst es lokal und packst den Inhalt des Download-Ordners zum ZIP-Archiv namens d8.zip. Lasse bitte die Datei .htaccess links liegen, denn sie hast du bereits im Rootverzeichnis deiner Drupal 8 Installation.

Mache ein Backup der MySQL-Datenbank, weil du oft mit Datenbank-Änderungen bei solchen Updates zu tun hast. Danach das d8.zip ins Rootverzeichnis per FTP/SFTP und Tool Bitvise hochladen. Anschliessend loggst du dich in der Kommandozeile ein und entpackst mit dem Befehl “unzip” dermassen.

unzip d8.zip

Hinterher löschst du das Archiv wieder so.

rm -rf d8.zip

Dann kannst du dich im Backend deines D8-Blogs einloggen und navigierst zum Statusbericht. Es gilt dabei in Erfahrung zu bringen, ob es neue Updates der Sprachdateien, des Kerns, der Module und Themes gibt.

Demnach alles auf den neusten Stand bringen und das Update der Datenbank erfolgt direkt im Browser unter /update.php. Dieses Mal war es bei mir so, dass die Datenbank nicht aktualisiert werden musste, sodass ich wieder zu den Verwaltungsseiten gehen konnte.

Das ist im Grossen und Ganzen die Upgrade-Prozedur und darunter ist alles auf einem Youtube-Video festgehalten. Meine CMS-Anleitungen oder Linux-Tutorials möchte ich ab nun in Begleitung von kurzen oder längeren Youtube-Videos produzieren. Das zeigt dir meine CMS-Arbeit auf dem Bildschirm und eventuell wirst du sogar einen Gefallen an der Kommandozeile finden. Das ist mein Ziel, dir diese Kenntnisse durch Video und Blogpost zu vermitteln.

Youtube-Video zum Drupal 8.4.1 Update

Das ist dann das Video. Es ist nicht perfekt, ich weiss das, aber ich bin noch ein Youtube-Beginner, sodass es einiges noch zu verbessern gilt.

Ich hoffe, dass ich dir nun etwas unter die Arme greifen konnte, wenn es heisst, ein Drupal 8 Update ansteht.

Bei Fragen zum Video oder dieser Update-Anleitung nutzt du einfach die Kommentare darunter.

Ich freue mich über jedes Feedback, welches mich besser werden lässt. Daher bitte nur sinnvoll 😉

by Alexander Liebrecht

Youtube-Videos in der Phabricator App einbetten

youtube-videos-bei-phabricator-app-einbinden-internetblogger-de

Hallo lieber Blogleser und heute geht es um die Phabricator App. Es ist eine php-basierte App und läuft wunderbar unter Linux OS. Meinerseits ist Phabricator unter Centos 7.4 mit Virtualhost installiert. Das funktioniert ganz gut.

Hier im Blog habe ich eine neue statische Seite erstellt. Darauf zeige ich dir meinen Youtube-Video-Channel und heute fragte ich mich, unterstüzt denn auch Phabricator solche Youtube-Videos?? Ja, das tut es, allerdings bedarf es des Ausführens eines SSH-Befehls in der Kommandozeile.

Du gehst als “root” zum Verzeichnis /phabricator. Das geht dann so.

cd phabricator

Von dort aus nimmst du diesen SSH-Befehl und bestätigst in der Konsole mit Enter.

./bin/config set remarkup.enable-embedded-youtube true

Das sollte auch schon reichen, damit dann die Youtube-Videos per Einfügen einer URL im Markdown-Editor angezeigt werden. Beim Bloggen in Phabricator zum Beispiel ist unter dem Editor die Vorschau und in der Vorschau werden dir dann die Youtube-Videos angezeigt. Ich glaube, dass das mit Youtube auch im Phriction-Wiki und der App Ponder(Fragen&Antworten) funktionieren wird. Die lokale Einstellung, die wir etwas höher vornahmen, sollte phabricator-weit gelten. Davon gehe ich mal aus.

Du kannst es mal ausprobieren und beim Phame-Blog kannst du mit Youtube-Videos gut arbeiten.

Das wollte ich dir in diesem Blogpost vermitteln, weil ich selbst danach recherchieren musste. In den meisten Foren geht der Youtube-BBCode wie folgt.

[*youtube]Video-ID[/youtube]

 

Aber woanders musst du schauen, welches CMS dir vorliegt und wie eingebettete Videos gehandhabt werden. Ich hoffe, dass ich dir mit diesem Post etwas helfen konnte.

Freue mich auf dein Feedback.

by Alexander Liebrecht

Wie du Bolt CMS mittels Kommandozeile updaten/upgraden kannst

bolt-cms-aktualisieren-geht-via-konsole+composer

Hallo CMS/Blog-Leser! Im heutigen Blogpost möchte ich kurz darauf eingehen wie du das OpenSource CMS namens Bolt updaten/upgraden kannst. Dabei setzen wir auf die Kommandozeile und composer.phar-Datei.

Bolt CMS ist ein bekanntes Flat File CMS guter Sorte und ich werkele damit unter https://boltcms.wpzweinull.ch herum. So stellte ich das Blog mittels yml-Konfig-Datei im Backend ein, bloggte bereits etwas auf der Webseite und installierte solche Erweiterungen wie Sitemap, CkEmbed, RelatedContent und ähnliche.

Wie geht ein Update auf Bolt 3.3.6 via Konsole?

Das Update/Upgrade wird offiziell unter https://docs.bolt.cm/3.3/upgrading/updating beschrieben und ich bediente mich dieser kurzen englischen Anleitung wie was zu machen ist.

Du loggst dich mit dem kostenlosen Tool Bitvise in der Konsole ein und navigierst zum Bolt-Root-Verzeichnis.

Falls es ein anderes Verzeichnis ist und nicht Root der Domain, dann nimm diesen SSH-Befehl.

cd meinverzeichnis

Composer muss ebenfalls installiert sein, was das Vorhandensein der Datei composer.phar im Rootverzeichnis nach sich ziehen wird.

Danach tippst du diese drei SSH-Befehle ein, um Composer zu aktualisieren, Update zu machen und die Datenbank uptodaten.

php composer.phar update
php app/nut cache:clear
php app/nut database:update

Es werden Bibliotheken und ihre Abhängigkeiten heruntergeladen und installiert. Das geht meistens ins Verzeichnis /vendor im Rootverzeichnis. Bei vielen OpenSource CMS ist es so, dass das /vendor-Verzeichnis mit im Download-Paket ist. Updates lassen sich mittels Composer und via SSH erledigen, so wie auch bei diesem coolen Bolt OpenSource CMS.

Als Nächstes loggst du dich in Bolt CMS im Browser unter /bolt als Admin ein und schaust zuunterst, wo dir Daten angezeigt werden. Es wird dann die Version 3.3.6, was derzeit möglich ist, angezeigt. Die neueste Version 3.4 beta noch was ist erst zum Testen verfügbar. Es ist aber das Pre-Produktions-Release und das Produktions-Release wird uns Bolt-Nutzer schon demnächst erreichen. Das Upgraden kannst du ebenfalls analog dann machen.

Nun denke ich mal, dass diese kleine Anleitung den Beginnern unter den Bolt-Nutzern etwas helfen kann. Eingefleischte Power-Bolt-User können denke ich mir mal mit der Konsole gut umgehen.

Bei Fragen hierzu nutze hier drunter die Kommentar-Möglichkeit.

Ich wünsche dir erfolgreiches Updaten deiner Bolt CMS Installation.

by Alexander Liebrecht

Wie du JIRA Software Server aktualisieren kannst

jira-software-server-im-frontend-liebrechts-portfolio-de

Hallo lieber Blogleser! In diesem Post geht es darum wie du eine Aktualisierung beim JIRA Software Server vornehmen kannst. JIRA ist ein klasse Ticket-System aus dem Hause Atlassian aus Australien und wird von zahlreichen, weltweit bekannten Unternehmen eingesetzt.

Mit JIRA arbeite ich selbst auch unter http://jiraissues.liebrechts-portfolio.de:8080. Diese Software zu installieren oder zu aktualisieren, bedarf des Einsatzes der Kommandozeile. So habe ich meine Instanz in Linux(Centos 7.4) vor kurzem installiert. Die eigentliche Installation ist keine Hexenkunst und eingefuchst habe ich mich bei Linux OS auf den generischen Port. Im Falle von JIRA ist es der Standard Port 8080.

Demnach musst du in Virtualhost in der Datei httpd.conf in etwa das zu stehen haben.

DocumentRoot "/opt/atlassian/jira"

ProxyRequests Off
 ProxyVia Off

<Proxy *>
 Require all granted
 </Proxy>

ProxyPass / http://jiraissues.liebrechts-projekte.de:8080/
 ProxyPassReverse / http://jiraissues.liebrechts-projekte.de:8080/

Danach startest du Apache so neu.

service httpd restart

Schon wirkt sich das aus.

JIRA Software Server aktualisieren

JIRA-Linux-Installer wird von der offiziellen Atlassian-Webseite unter https://atlassian.com bezogen und wird unentpackt ins Verzeichnis /usr/bin hochgeladen. Danach wird sich via Kommandozeile als Root eingeloggt. Als Nächstes musst du in der Kommandozeile vom /usr/bin-Verzeichnis aus dieses eingeben.

./atlassian-jira-software-7.5.0-x64.bin

Der Installer wird ausgeführt und du wirst danach gefragt, was gemacht werden sollte. Du nimmst das Upgrade einer alten Instanz. Das siehst du dann alles in der Konsole. So beobachtest du die Kommandozeile bis zum Neustart der JIRA-Instanz im Browser. Im Frontend kannst du nach wenigen Minuten deine Instanz auch schon aufrufen.

Was ist, wenn JIRA im Browser nicht startet?!

Durchaus kann es sein, dass für JIRA bereits mehrere Tomcat-Prozesse laufen. Du musst sie dann alle beenden. Suche in der Konsole nach JIRA mit diesem Befehl.

ps -aux | grep jira

Beende alle Tomcat-Prozesse dann so.

kill <pidid>

Die PidID ist die Nummer mit dem Tomcat-Prozess, die dann ebenfalls in der Zeile angezeigt wird.

Danach wechselst du zum JIRA-User so.

su jira

Du siehst in der Kommandozeile, dass du nun als JIRA-User aktiv bist. Ab dann musst du ins Verzeichnis /bin mit diesem SSH-Befehl.

cd /opt/atlassian/jira/bin

So kannst du deine JIRA-Instanz nun neustarten.

sh start-jira.sh

sh stop-jira.sh >> so stoppst du JIRA-Prozesse wieder

Das dürfte dann bestimmt helfen, damit JIRA im Browser startet. Warte kurz und schon kannst du deine JIRA-Instanz normal aufrufen.

Ich hoffe, dass ich dir zeigen konnte, wie JIRA aktualisiert und im Browser neu gestartet wird. Diese SSH-Befehle habe ich bei der Arbeit mit JIRA und der Kommandozeile auswendig gelernt und nutze sie auch bei mir in Linux/Centos 7.4.

Bei Fragen einfach hier drunter gerne kommentieren.

Ich wünsche dir weiterhin Spass bei der Arbeit mit dem Ticketsystem und dem Bugtracker in JIRA.

by Alexander Liebrecht

 

Confluence Server 6.4.2 erschienen: Fehlerbehebungen

confluence-6-4-2-bugfix-release-internetblogger-de

Hallo lieber Blogleser und Confluence-Nutzer! Seit ein paar Tagen oder gar erst seit gestern gibt es eine neue Confluence Server Version, die 6.4.2. Sie kam mit Fehlerbehebungen heraus, die unter https://confluence.atlassian.com/doc/issues-resolved-in-6-4-2-938857056.html festgemacht wurden.

Auf dem Managed Server bei meinem Webhoster kosten Updates einer solchen App etwas Geld und das ist nicht weiter tragisch, denn so oft updaten werde ich nicht. Wenn es nur Bugfixes sind und meine Instanz einwandfrei funktioniert, kann man durchaus ein halbes Jahr lang mit Updates hinauszögern. Wären es wichtige Sicherheitsupdates, dann würde ich eventuell früher handeln.

Confluence setzte ich bis vor kurzem unter Centos 7.4 in Linux ein und im Folgenden verrate ich es dir wie du Confluence Server unter Linux aktualisieren kannst. Vielleicht kennst du meine Update-Methoden bereits.

Confluence wird als Linux-Bin-Installer heruntergeladen

Das findest du auf den Atlassian-Webseiten unter https://atlassian.com und dort beziehst du den Bin-Installer, je nach eingesetztem Betriebssystem, Windows oder Linux. Der Installer muss nicht entpackt werden, er wird gleich ins Verzeichnis /usr/bin hochgeladen. Dann diesem Installer CHMOD-Rechte von 755 vergeben, damit er ausführbar ist und in der Kommandozeile mit dem “cd”-Befehl zum /bin-Verzeichnis navigieren.

cd /usr/bin

Von dort aus dieses eintippen.

./atlassian-confluence-6.4.2-x64.bin

Den Installer führst du dann aus und du wirst via SSH danach gefragt, was passieren soll. Nimm bitte dann Upgrade einer bereits existierenden Instanz bzw. Installation. Soweit ich es noch weiss, wird es die Ziffer 2 oder 3 sein. Danach auf ENTER drücken. So verfolgst du das Upgrade in der Kommandozeile und zum Schluss wird deine Instanz neu gestartet.

Bei mir auf dem Managed Server würde das alles ein Techniker vollbringen. Aber wie gesagt, bei Fehlerbehebungsupdates werde ich nicht handeln.

Warte 8 Minuten und danach startet deine Confluence Server Instanz auch im Browser. Das wäre die ganze Upgrade-Prozedur. Falls Confluence nicht startet, was ich auf Linux OS beziehe, dann gibt es immer diese Abhilfe.

ps -aux | grep confluence >> finde Tomcat-Prozesse
kill <pidid> >> beende Tomcat Prozesse
cd /opt/atlassian/confluence/bin >> navigiere zum Start-Verzeichnis/Installationsverzeichnis von Confluence
sh start-confluence.sh >> starte Confluence Instanz neu

Falls das Letztere nicht geholfen hat, nimm diesen Befehl.

sh start-confluence.sh -fg
-fg >> im Vordergrund, wobei du in der Konsole den Start mitverfolgen kannst

Ich denke, dass das alles dann geholfen hat, es sei denn, es liegen schwerwiegendere Probleme als das Nichtstarten.

Confluence hat sich gut entwickelt

Updates erscheinen mehrmals im Monat und oft sind es weitere Fehlerbehebungen oder es geht um etwas bessere Sicherheit der App. Atlassian Entwickler sind fleissig am Werkeln und wir End-Nutzer bekommen klasse Software.

Im Übrigen wird die nächste Managed Server Installation im “Internetblogger”-Portfolio das mit Bitbucket Server sein. Ich habe noch die Lizenz dafür, also schaue ich einmal danach, dass das alles eines Tages klappen kann.

Phabricator-Installation auf Shared Hosting leider nicht möglich

Das nur nebenher, weil es auch eine coole App ist. Phabricator will GRANT Permissions/Berechtigungen auf die Datenbank haben. Diese darf nur der Root haben und bei Shared Hosting bist du nur als MySQL-Nutzer aktiv und kannst in der Konsole durchaus mit MySQL-Befehlen arbeiten. Aber vielmehr auch nicht.

Daher denke ich mal, dass es leider so nicht klappen wird oder es gibt unter Umständen noch eine Lösung. Das aber noch in Zukunft.

Somit hast du in diesem Blogpost wieder erfahren wie Confluence Server Instanz aktualisiert wird und was wäre zu tun, wenn sie im Browser nicht startet.

Ich wünsche dir erfolgreiches Upgraden und weiterhin Freude bei der Arbeit mit Confluence, einer innovativen App aus dem Hause Atlassian.

by Alexander Liebrecht

 

Confluence Instanz auf Managed Server nahm heute etwas Gestalt an

confluence-internetblogger-de-blog-frontend

Hallo lieber Stammleser! Dieser Blogpost ist auch eines rein informativen Charakters. Ich habe ja neulich schon davon erzählt, dass ich das Webhosting bei Hetzner verlassen habe. So musste ich schauen, dass man auf dem Managed Server bei All-inkl. Confluence Instanz installiert bekommt.

Das hat mir der Support server-seitig ermöglicht. Da ich um die 24 GB RAM auf dem Managed Server habe, wird Confluence flüssig arbeiten. Diese Atlassian App braucht pro Instanz mindestens 2 GB RAM Speicher. Aus diesem Grunde setzt man es meistens auf Rootservern oder den vServern auf. Shared Hosting hat von Haus nie sehr viel RAM-Speicher.

Confluence ist nun hier auf dem Internetblogger.de unter http://confluenceblog.internetblogger.de installiert worden.

Einrichten von Confluence auf Managed Server

Nützlich wäre es auf dem Managed Server, wenn du die Instanz selbst neu starten darfst und nicht als Root heran musst. Als Root darf nur der Support arbeiten und du brauchst etwas anderes. Mir wurde gesagt, dass es einen Start-Script server-seitig gibt. Bei mir ist es Ubuntu 16 und vorher auf dem vServer hatte ich Centos 7.4. Das wird vielleicht etwas anders sein.

confluence-marketplace-im-backend
Confluence Marktplatz im Backend

Aber meine SSH-Befehle, die du von mir zu Confluence kennst, gelten eben für Linux oder Centos 7, je nachdem mit welchem OS du arbeitest.

MySQL-technisch musst du die mögliche Grösse der InnoDB-Log-Datei erhöhen. Sobald du Confluence vom Support installiert bekommst, werden dir im Backend diverse Meldungen angezeigt. Diesen solltest du nachgehen, ansonsten kannst du keinerlei Addons und Themes aus dem Marketplace installieren.

Auch “max allowed Packet” muss erhöht werden. Hierzu findest du Details in der jeweiligen Confluence-Meldung im Backend nach der Erstinstallation. Die Scripte auf dem Managed Server sowie der MySQL-Server müssen neu gestartet werden.

Diesen Ausschnitt habe ich aus einem englischen Forum.

Open my.cnf in "etc" with notepad++ or similar
And add following parameter 

innodb_log_file_size = 265M
Looks like:
[mysqld]
query_cache_size = 48M
max_allowed_packet = 48M
innodb_log_file_size = 256M

Auf einem Rootserver kannst du maximale Grösse des InnoDB-Log-Files in der Datei my.cnf einstellen. Maximal zugelassene Paketgrösse ebenfalls. Aber bei Shared Hosting kann dir auch gerne der Support weiter helfen, wenn du nachfragst.

Confluence benötigt eine utf8-bin Datenbank

Das lässt sich in PHPmyAdmin einstellen, bevor die Datenbank mit den Tabellen befüllt wird. Falls du das nicht machst, wird der Installer dir das dann anzeigen. Serverseitig installiert der Support und du übernimmst und installierst im Browser zu Ende. Deinen Admin-Account kannst du dabei auch mit erstellen.

Confluence einrichten, rechtliche Seiten, Foto im Profil, persönliche Daten ect.

All das kann eingestellt und eingerichtet werden. Impressum und Datenschutz müssten auch da sein, wenn du schon offiziell die Instanz hast. Ich habe noch Adsense und Share Buttons mit AddThis umgesetzt. So brauche ich auch die CookieBar. Den Code der CookieBar kannst du im benutzerdefinierten HTML im Backend in der linken Leiste weiter unten einfügen. Das wird dann auf allen Seiten deiner Confluence Instanz angezeigt.

Ersten Bereich erstellen

Das muss gemacht werden und später kannst du auch weitere Bereiche erstellen. Bereiche sind für anonyme Gäste von Haus aus versteckt und so musst die Berechtigungen für “anonym” setzen, damit die Inhalte angezeigt werden. Auch globale Berechtigungen für “anonym” muss man setzen, damit die Leser Confluence nutzen können. Du als Admin nutze alles andere, was du da hast.

Confluence Bereiche haben ein Blog

Im Blog kannst du deine Inhalte verbloggen und zudem lassen sich zahlreiche Seiten erstellen. Forum Posts solcher Foren wie des EasyForums sind auch in dem Sinne statische Seiten, die ergänzt werden können. Das ist bei Confluence so. Das Easy-Forums schaut im Frontend bei mir so aus.

 

confluence-easy-forum-im-frontend
Confluence Addon EasyForums im Frontend und zwei erstellte Foren

Das ist das EasyForums und ich habe heute nur noch zwei neue Foren erstellt. Forum-Topics erstellen, geht leicht von der Hand. Im Backend der Confluence Instanz kannst du noch den Moderator festlegen. Ich würde als Admin moderieren. Diesen Admin-User, welcher du bist, findest du durch die Optionen des EasyForums.

Irgendetwas mit Unterforen habe ich noch nicht gesehen, aber es braucht es auch nicht. Confluence Foren sind keine Forum-Software wie PHPBB oder SMF, daher gibt es dort das nicht, soweit ich weiss.

Confluence Blogpost im Frontend

confluence-instanz-blogpost-im-frontend
Confluence Blogpost im Frontend

So schaut ein Blogpost in Confluence aus. Social Share Buttons sind ein Premium Addon mit Lizenz. Unter dem Blogpost, falls du auch mit dem Premium Theme Enterprise Theme arbeitest, kannst du in den Sektion deine Inhalte unterbringen. Das kann gerne als Blogpost-Signatur gelten oder du machst auf etwas anderes aufmerksam. Das Enterprise Theme wird im Backend eingestellt, wo du auch zu den Sektionen gelangen kannst.

 

confluence-premium-theme-enterprise-sektionen
Sektionen beim Premium Theme Enterprise in Confluence 6.4.0

Leider funktioniert das Bearbeiten bzw. das Speichern der editierten Sektion in Google Chrome nicht. So muss ich dabei immer mit dem Opera Browser arbeiten. Der hat sich dann nicht so 😉

Man kann noch mehr in die Materie gehen, was ich mit diesem Blogpost eigentlich nicht beabsichtigte. Ich wollte dich viel mehr auf meine Confluence Instanz aufmerksam machen, damit du weisst, wo noch gebloggt wird.

Confluence braucht sehr viel Zeit, um es kennenzulernen. Es macht aber Spass, damit zu arbeiten und sobald du frische Lizenzen für die Instanz und die Plugins hast, bekommst du auch Atlassian Support, dann wohl eher in der Community. Nutzen, tun es inzwischen recht viele End-User.

Ich lerne aus dem Ganzen, dass Confluence auch unter Ubuntu 16 auf Managed Server funktionieren kann. Vorher dachte ich immer etwas anderes.

[note note_color=”#eecc21″ radius=”10″]Deine Erfahrungen, falls du diese mit Confluence hast, egal ob Shared Hosting oder eigener Server, würde ich gerne hier nachlesen. [/note]

by Alexander Liebrecht

Bildquellen by Alexander Liebrecht

 

 

Wie du Bitbucket Server in Linux – Centos 7 aktualisieren kannst

Hallo Blogleser! Diesen Post widme ich dem Bitbucket Server, einer Atlassian Software aus dem Premium-Sektor. Ich möchte dir gerne zeigen, wie so eine Bitbucket Server Instanz in Linux bzw. Centos 7.4 aktualisiert wird. Was Bitbucket Server im Browser darstellt, kannst du dir bei mir unter http://bitbucketrepos.liebrecht-projekte.de:7990 ansehen. Ich habe Bitbucket an einem generischen Port 7990 … Weiterlesen

TikiWiki 17.1 aus Unterverzeichnis auf eine Subdomain umgezogen

tikiwiki-17-1-blog-frontend

Hallo Blogleser! Ich arbeite weiterhin fleissig am Portfolio, damit es aufgeräumt ist und funktioniert. Heute zog ich den TikiWiki von internetblogger.de/tikiwiki auf https://tikiwiki.internetblogger.de um und das möchte ich hier kurz schildern.

 

Es gibt sicherlich solche Fälle, wo ein Projekt auf die Subdomain umgezogen werden sollte und das lag mir heute vor. Der TikiWiki ist neulich als neue Version 17.1 erschienen, wobei ich noch nichts Offizielles fand, wo man etwas nachlesen kann. Das Update verlief sehr gut und nichts mit Composer und Co. Alles via Konsole und FTP gemacht.

Dazu findest du Hinweise im TikiWiki auf der Subdomain, dort im letzten Blogpost. Der Umzug war nicht schwer und ist keine Hexenkunst, denn die Datenbank war ebenfalls auf localhost Internetblogger.de, sodass ich lediglich den FTP-Inhalt umziehen musste. Das waren mehr als 450 MB aus dem Verzeichnis /tikiwiki und mittels Konsole war ich auch recht schnell fertig.

Zippen, herunterladen, lokal entpacken, packen, zippen und hochladen ….

Weisst du, was ich meine mit dieser Überschrift 😉 Ich habe nicht das Verzeichnis /tikiwiki, sondern den Inhalt davon gebraucht. Aber zippen musst du das Verzeichnis via SSH und es bot sich auch super an. Ich wandte diesen SSH-Befehl an.

zip -r tiki.zip tikiwiki

Schnell gezipppt das Ganze, heruntergeladen, entpackt, gepackt und hochgeladen. Auch entzippen mache ich mittels Konsole. Das geht schneller als würde ich eine ganze Stunde am Umzug sitzen.

SSL wollte ich auch haben und dank Let’s Encrypt bei meinem Webhoster klappte es ganz gut. Auch eine Cookie Bar habe ich im Tiki-Header, sodass die Cookies bestätigt werden müssen. Weil ich mit Adsense und seit heute den Shariff Share Buttons arbeite, ist da nichts zu machen, wenn es Google verlangt. Die Cookie Bar sollte vorhanden sein.

Shariff Share Buttons mit Zählern in Tiki umsetzen

Eine eher leicht Aufgabe, aber es wird etwas Zeit in Anspruch nehmen. In kann es hier grob beschreiben. Du findest auf Github die beiden Repos mit Shariff JS/CSS-Dateien und das PHP-Shariff-Backend. Du kannst dann im FTP-Account entweder zwei Verzeichnisse wie /my-shariff-backend fürs PHP-Backend und /shariff für JS/CSS erstellen. Oder aber nur ein Verzeichnis und alles da hinein packen. Das funktioniert bei mir seit heute.

Nehmen wir mal das eine Verzeichnis /shariff und darin erstellst du das /tmp-Verzeichnis, vergibst dem CHMOD-Rechte von 777 und öffnest die index.php. In dieser Datei musst du den Pfad zum /tmp-Verzeichnis definieren und auch deine Domain eintragen. Trage es bitte ohne “http/s” ein, denn sonst zeigt man dir die Zähler nicht an.

Die index.php speichern, hochladen und sieh da, Shariff Share Buttons mit Counts werden angezeigt. Es werden leider nur die Counts von G+ angezeigt, weil es schon lange so ist. Da ist vermutlich bei anderen Social Networks etwas, was nach sich zieht, andere Zähler nicht anzuzeigen. Das fand ich noch nicht heraus uns so sehr wichtig sind mir die Zähler auch nicht.

Shariff Share Buttons in den Blogposts anzeigen lassen

Dazu nimmst du die Datei /templates/blog_post_postbody_content.tpl und setzt den Shariff DIV-Code ungefähr hier ein.

<div class="postbody-content panel-body">

Darunter kommt Shariff hin. Das wird dafür sorgen, dass die Buttons über jedem Blogpost, aber nicht im Anleser angezeigt werden. Für den Teaser gilt ein anderes Blog-Template, welches du ebenfalls unter /templates im FTP-Account finden kannst.

SocialMedia hin oder her, jeder nutzt es und ich habe da so meine Social Friends und Follower, die mir folgen. Vor kurzem wieder mehrere Freundschaftsanfragen auf FB akzeptiert.

Im Grossen und Ganzen wollte ich das hier jetzt loswerden und du hast erfahren, wie es um Shariff Buttons beim Tiki steht und auch dass es eine neue TikiWiki-Version gibt. Das Update auf die neue Version habe ich bereits im Tiki beschrieben. Die Konsole wirst du leider brauchen, um die Datenbank zu aktualisieren. Dazu nimmst du einen SSH-Befehl, welcher dir im Control Panels angezeigt wird und führst es vom Root aus in der Konsole aus. Das war’s. Ja, ganz klar, vorher die neuen Tiki-Dateien über die alten hochladen und alles überschreiben.

Zumindest arbeite ich auf diese Art und Weise.

Falls du Fragen zu etwas hast, raus damit. Ein paar Kommentierer werden hier nicht mehr zugelassen und wenn ich da irgendwelche Yandex-Mail-Adressen sehe, dann haue ich auch das weg. So einfach ist das.

Dir weiterhin Spass beim Arbeiten mit TikiWiki 17.1. Ein Upgrade lohnt sich in jedem Falle.

by Alexander Liebrecht

 

MyBB 2.0 Test-Installation gelungen – via Kommandozeile mit PHP 7.0, MySQL 5.7, Laravel

mybb-20-forum-frontend

Hallo lieber Leser! Per puren Zufall war ich heute im Entwicklungsrepository von MyBB 2.0 auf Github, denn es interessierte mich heute auf einmal. MyBB 2.0 ist noch eine etwas mit ein paar Bugs gefüllte Pre-Alpha-Version.

Es basiert auf Laravel Framework und kann dennoch auf Shared Webhosting installiert werden. Mir liegen diese Systemvoraussetzungen vor:

  • PHP 7.0
  • MySQL 5.7
  • Managed Server
  • Shared Webhosting
  • Ubuntu 16.x

Damit arbeite ich im Portfolio und MyBB 2.0 habe ich komplett mittels der Kommandozeile aufgesetzt. Im Folgenden verrate ich es dir, vor welchen Schwierigkeiten ich dabei stand und worauf du auch achten solltest.

Herunterladen des offiziellen MyBB 2.0 Repos

Das bekommst du auf Github unter https://github.com/mybb/mybb2. Das Paket downloaden, lokal entpacken und per FTP wieder hochladen.

Danach muss man dem Verzeichnis /storage CHMOD-Rechte von 777 vergeben. Das geht bequem via SSH und diesen Befehl.

chmod -R 777 storage/

Als Nächstes installierst du den Composer derart. Das führst du immer von dem Verzeichnis aus, wo sich die composer.json befindet.

php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
php -r "if (hash_file('SHA384', 'composer-setup.php') === '669656bab3166a7aff8a7506b8cb2d1c292f042046c5a994c43155c0be6190fa0355160742ab2e1c88d40d5be660b410') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r "unlink('composer-setup.php');"

Auch kannst du diesen SSH-Befehl mal ausführen, damit der Composer wieder uptodate ist.

php composer.phar self-update

Da du es von Null an installierst, wird er in der Version 1.5.1 oder so etwas sein. Das sollte reichen. In der composer.json-Datei sind alle Abhängigkeiten und Bibliotheken vorhanden, damit wir installieren können. Führe bitte mittels Konsole das aus.

php composer.phar install

Composer wird installiert, es entsteht im Rootverzeichnis das Verzeichnis /vendor und alle Bibliotheken nehmen darin dauerhaften Platz ein.

Normalerweise musst du dann die Datei .env im Rootverzeichnis erstellen. Sie gibt es aber schon als Beispiel und wir kopieren sie nun dermassen.

cp .env.example .env

vim .env

VIM ist ein SSH-Editor, mit welchem du super Files bearbeiten und mit Inhalt füllen kannst. Du kannst so jede Datei im FTP-Account oder in Linux und bei anderen OS mittels Konsole öffnen.

“vim .env” öffnet diese Datei und darin sind Datenbankdaten enthalten. Erstelle bitte nun eine MySQL-Datenbank und per PHPMyAdmin unter “Operationen” setze die Datenbank auf Multibyte und UTF8mb4 Zeichensatz.

Datei /config/database.php anpassen

Das musst du auch in der Datei /config/database.php machen. Das zeige ich dir hier.

'connections' => [

'sqlite' => [
 'driver' => 'sqlite',
 'database' => storage_path() . '/database.sqlite',
 'prefix' => '',
 ],
 'mysql' => [
 'driver' => 'mysql',
 'host' => env('DB_HOST', 'localhost'),
 'database' => env('DB_DATABASE', 'forge'),
 'username' => env('DB_USERNAME', 'forge'),
 'password' => env('DB_PASSWORD', ''),
 'charset' => 'utf8mb4',
 'collation' => 'utf8mb4_unicode_ci',
 'prefix' => '',
 'strict' => false,
 'engine' => 'InnoDB ROW_FORMAT=DYNAMIC',
 ],

 

So sollte es aussehen, damit wir den APP-Key, welcher normalerweise auf 1000 Bytes begrenzt ist, generieren können. Mit reinem UTF8 Zeichensatz klappt es nicht und so habe ich die Lösung für diese Problem heute ergoogelt.

Wenn das gemacht ist, generierst du mit diesem Befehl den App-Key.

php artisan key:generate

Den Schlüssel, der dir in der Konsole angezeigt wird, musst du in die Datei .env eintragen. Öffne sie so:

vim .env

Trage Datenbankdaten und den Schlüssel ein.

Danach führst du diese SSH-Befehle aus.

php artisan config:clear
 php artisan config:cache
 php artisan key:generate

Jetzt können die Datenbank-Tabellen erstellt werden, wofür du diesen SSH-Befehl brauchst.

Ach ja, noch den öffentlichen Zugang bei Packages ermöglichen mit diesem Befehl.

php artisan vendor:publish

Danach die Tabellen erstellen.

 php artisan migrate:install
 php artisan migrate

Zudem migrierst du die Datenbank-Tabellen. Warte bitte bei der Migration, denn es vergeht eine Minute oder so etwas. Da musst du dich etwas gedulden.

Zum Schluss diesen SSH-Befehl ausführen.

 php artisan db:seed

Ab nun sollte dein Forum online sein, du kannst dir ein Konto zulegen, bist dann sofort online.

Etliche Bugs in der Software sind noch

Jetzt haben wir aber etliche Bugs, die der Github-Entwickler nächste Woche fixen wird. Zum Einen kann man nicht zum User-Konto gehen, zum anderen muss ich noch herausfinden, wie ich in der Datenbank den erstellten User Admin mir zuweise bzw. wie ich meinen User-Namen mit Admin-Rechten versehen kann. Andernfalls komme ich nicht ins ACP.

Der Admin ist ja von Haus aus erstellt mit der Mail-Adresse von mybb.com. Das bringt mir aber gar nichts oder…und ich muss nun mehr wissen.

Der Fehler, der beim Ansurfen der User-Kontos angezeigt wird, ist folgender.

FatalErrorException in ProfileFieldPresenter.php line 19:Declaration of MyBB\Core\Presenters\ProfileFieldPresenter::getValidationRules(): array must be compatible with MyBB\Core\Form\RenderableInterface::getValidationRules(): string

Da läuft noch einiges schief.

Das wird bald gefixt und ich hoffe, dass ich dann mein Profil ausfüllen kann. Zudem muss ich an den Admin-Account heran und das ACP interessiert mich brennend.

Bedenke, dass MyBB 2.0 noch eine sehr frühe Alpha-Version ist und keinesfalls für die Produktion geeignet. Auf Gibhub im Repo-Wiki gibt es eine Anleitung, die ich abgearbeitet habe. So konnte ich auch installieren.

Screenshots, die mir zur Verfügung stehen

mybb-20-forum-frontend
MyBB 2.0 im Forum-Frontend

 

mybb-20-thread-ansicht
MyBB 2.0 – Thread-Ansicht

 

mybb-20-forum-frontend
MyBB 2.0 Forum-Ansicht

 

mybb-20-nutzer-account
MyBB 2.0 Nutzer-Account

 

So schaut es jeweils aus bei dieser Alpha-Version. Ganz sicherlich wird alles noch für die Produktion parat gemacht, wenn die Zeit gekommen ist. Aktuell wird daran rege entwickelt und ich denke, dass in 2 Jahren oder vielleicht schon früher aus dem Projekt etwas werden kann.

Falls du Fragen haben solltest zu diesem Tutorial, feedbacke darunter. Eventuell weiss ich schon was.

by Alexander Liebrecht

Confluence Server 6.4.0 erschienen – Bugfixes und neue Features

confluence-server-6-4-0-update-draussen-neue-funktionen-bugfixes

Hallo lieber Leser! Da ich hier im Blog eine Confluence Server Kategorie habe, sollte ich, denke ich mir mal, ab und an darin posten und es befüllen. Jetzt möchte ich auf das neue Update des Confluence Servers 6.4.0 eingehen. Das kannst du der Seite unter https://confluence.atlassian.com/doc/confluence-6-4-release-notes-934721238.html gerne entnehmen.

Ich habe in der Zwischenzeit ein Update verpasst, was aber nicht so schlimm ist, es sei denn, deine Confluence Instanz funktioniert nicht und muss gefixt werden. Meinerseits mit dem Confluence Server unter http://confluenceblog.liebrecht-projekte.de:8060 scheint soweit so gut alles Ok zu sein. Heute machte ich ein Upgrade auf Confluence 6.4.0, was erfolgreich ausging.

Das habe ich schon festgestellt, denn funktioniert deine Instanz vor dem Update, wird sie auch meistens danach funktionieren. Das Update geht immer per Kommandozeile, indem du das Verzeichnis /usr/bin mit dem “cd“-Befehl via SSH ansurfst. Dorthin lädst du den Linux-BIN-Installer mit Confluence Server hoch.

CHMOD-Rechte dem Installer mit 755 vergeben

Das kannst du gleich machen und nach dem Update kannst du es wieder zurücksetzen und löschst gar den Installer wieder.

Als Nächstes bist du im Verzeichnis /bin und gibst in der Konsole diesen SSH-Befehl ein.

./atlassian-confluence-6.4.0-x64.bin

Ab dann gilt es, ein Upgrade einer bereits existierenden Instanz zu machen. Das wird dann wohl “3+Enter” sein. Dann beobachtest du genau die Kommandozeile und reagierst auf Hinweise und Fragen von der Konsole. Wenn du das mehrmals gemacht hast, kannst du es dann wie im Schlaf.

Confluence Instanz wird zum Schluss vom Upgrade wieder gestartet, warte ca. 8 Minuten im Browser, eher du Zugriff hast. Danach kannst du dich zu den Erweiterungen im Backend begeben und schauen, ob es Updates gibt. Ich habe heute mindestens bei 20 Erweiterungen bei den Entwicklern ein Update angefordert. Wenn die Jungs und Mädels in Australien wach sind, dann wird sich bei mir gemeldet. Das ist meistens nach Mitternacht oder in den frühen Morgenstunden der Fall, je nachdem, wie die Supporter ausgelastet sind.

Addon-Updates machen immer in der Addon-Verwaltung

Das wird so sein, denn das geht einigermassen einfach. Wenn ein Addon inkompatibel ist, kannst du beim Entwickler ein Update anfordern, was auf Englisch geschehen muss. Lasse dir etwas von den Google Sprach Tools helfen, wenn es nicht anders geht.

Was ist neu bei Confluence 6.4.0

In erster Linie waren es weitere Fehlerbehebungen und Verbesserungen unter der Haube. Dann haben die Entwickler einen besseren Zugang zu den Entwürfen in Confluence ermöglicht. Auch wurde die Page History überarbeitet, sodass nun der Autor und sein Avatar erscheinen. Ich bekam so etwas nie mit, denn ich bin kein Team in meiner Instanz, arbeite immer alleine. Aber bei Team-Wikis durchaus nützlich sind die neuen Features.

Weitere Details findest du auf Atlassian-Webseite, oben bereits verlinkt. Das Upgrade ist denke mal nun klar und falls etwas ist mit Konsole, wende dich an mich. Mit SSH arbeite ich täglich.

Ich freue mich sehr, dass ich im Besitz einer Confluence/Bitbucket/JIRA-Lizenz bin, denn ich habe es mal 2016 entdeckt. Es hat dann mein Interesse geweckt und heute ist es einfach so, dass damit gerne gearbeitet wird. Etwas anderes als der BlueSpice MediaWiki, TikiWiki oder der DokuWiki. Von Unternehmen geliebt und wird vermutlich von Privatpersonen noch selten eingesetzt, weil es auch alles etwas kostet.

Dein Feedback ist hier immer gerne gesehen und dann aber etwas Mühe dabei geben. Danke!

by Alexander Liebrecht

Bildquelle via https://atlassian.com

 

MediaWiki 1.29.1 draussen – wegen zweierlei Extensions das Upgrade

mediawiki-1-29-1-bugfixes-update

Hallo lieber Blogleser! Updates, was das Auge reicht und super gerne halte ich dich über meinerseits eingesetzte Software auf dem Laufenden. Es gab nämlich ein MediaWiki-Update auf die neue Version 1.29.1. Das Update konnte ich erfolgreich unter https://liebrecht-projekte.de/cms/mediawiki installieren.

Die letzte Version kannst du wie gewöhnlich unter https://mediawiki.org erhalten und herunterladen. Das Update musste wegen zweierlei MediaWiki-Extensions erfolgen. Das betraf einmal pdfHandler und SpamBlacklist. Weitere Einzelheiten hierzu stehen mir so nicht zur Verfügung. Aber es reicht schon um zu wissen, dass man das Update machen sollte und so tat ich es auch.

Im Folgenden kann ich dir kurz erklären, wie du einen herkömmlichen MediaWiki upgraden kannst.

Upgrade MediaWiki auf Version 1.29.1

Die letzte Version wird offiziellerseits heruntergeladen und lokal entpackt. Es sind entpackt um die 140 MB. Aus diesem Grunde nehmen wir die Kommandozeile, um einfach schneller fertig zu werden. Du kannst das entpackte Paket gerne manuell per FTP hochladen, andernfalls beachte meine Update-Methode.

Also herunterladen, lokal entpacken und den Inhalt des Download-Pakets zum ZIP-Archiv namens 1291.zip machen. Das wird dann ins Rootverzeichnis hochgeladen und via Konsole derart entpackt.

unzip 1291.zip

Hinterher löschst du das Archiv wieder derart.

rm -rf 1291.zip

Sichere bitte vorher deine Datenbank, für den Fall der Fälle, falls mal etwas sein sollte. Nach dem Entpacken bzw. dem Hochladen per FTP muss der Composer so upgedatet werden. Dazu wirst du die Konsole gleich brauchen. Schaffe dir bitte das kostenlose mit Windows 10 kompatible Tool BitVise fürs SSH/SFTP an. Damit kann man sehr gut agieren und arbeiten. Du loggst dich in der Konsole ein, bist gleich im Rootverzeichnis und von dort aus navigierst du mit dem “cd”-Befehl zum Wartungsverzeichnis, was so geht.

cd maintenance

Von dort aus führst du das Update aus, wie gehabt und dermassen.

php update.php

Warte kurz, bis es zu Ende ist.

Danach loggst du dich im Backend deines Wikis ein und navigierst im Browser zu:

Spezial:Version

Und überzeugst dich von der neuen Versionsnummer. Das dürfte dann die 1.29.1 sein. Somit kannst du das Update abschliessen und widmest dich anderweitigem.

Bei Fragen zu SSH und der Konsole bitte darunter kommentieren. Ansonsten sei dir ein Update-Erfolg gewünscht und habe weiterhin viel Freude mit dem herkömmlichen MediaWiki. BlueSpice erscheint eines Tage neu, wenn MediaWiki 1.30 draussen ist. So der BlueSpice-Support vor einer Weile.

by Alexander Liebrecht

P.S. Sichere bitte vor dem Update die Datei Local-settings.php, die sich im Rootverzeichnis befindet. Dort sind allesamt Konfiguration enthalten und das darf nicht überschrieben werden. Ich erwähne es dennoch, damit man das auch weiss.

Drupal 8.3.7 als Wartungs-Sicherheitsupdate erschienen

drupal-8-3-7-wartung-sicherheit-update-internetblogger-de

Hallo lieber Leser! An der Drupal-Front gibt es mal wieder ein Wartungs-Sicherheitsupdate auf die neue Version 8.3.7. Drupal ist genau so wie WordPress, sodass es immer wieder zu den Funden von Sicherheitslecks kommt.

Diese werden aber recht schnell geschlossen und dieses Mal konnte ich zeitig reagieren und mein Update unter https://wpshopde.de einspielen. Das Update eines Drupal 8 CMS ist nicht kompliziert und da ich so etwas schnellstens erledigt haben möchte, bediene ich mich der Kommandozeile und SSH.

Bei dem neuen Update sind ansonsten keinerlei weitere Änderungen enthalten. Das Update wird dringend empfohlen, denn andernfalls öffnest du den Angreifern noch mehr Türen.

Wie kannst du auf Drupal 8.3.7 updaten?

Lade dir die letzte Version von https://www.drupal.org/project/drupal/releases/8.3.7 herunter, entpacke es lokal und packe den Inhalt des Ordners ausser der .htaccess-Datei zum ZIP-Archiv namens 837.zip.

Das lädst du ins Rootverzeichnis deiner D8-Installation hoch und entpackst in der Konsole vom Rootverzeichnis aus mit diesem SSH-Befehl.

unzip 837.zip

Danach löschst du es wieder so.

rm -rf 837.zip

Als Nächstes kannst du dich im Drupal 8 Blog einloggen, gehst zum Statusbericht und schaust dir dort alles an. Falls Aktualisierungen vorhanden sind, diese bitte erledigen. Auch kannst du Updates bei den Übersetzungen anstossen. Diese waren heute verfügbar und vier neue Übersetzungen konnten hinzugefügt werden. Alte Übersetzungen wurden aktualisiert, sodass alles seinen Gang gehen kann.

Da es nur ein Wartungsrelease war, sollte deine Drupal 8 Installation danach gut funktionieren.

Das wäre das ganze Update und ich kann dir nur viel Erfolg dabei wünschen. Bei Fragen zu SSH oder dem Update kannst du darunter kommentieren.

by Alexander Liebrecht

 

#Flarum #Erweiterungen: AutoImage und s9e/mediaembed

flarum-autoimage-erweiterung-funktioniert-internetblogger-de

Hallo lieber Leser! Es ist ein passabler Zeitpunkt für ein neues Blog-Update und mir geht es dabei um neue/alte, von mir entdeckte, Flarum-Erweiterungen. Flarum ist eine OpenSource Forum Software, die ihr zuhause unter http://flarum.org hat. Die Flarum Community offiziellerseits ist derzeit unter https://discuss.flarum.org und in der Community schaue ich regelmässig rein, um neue Extensions auszumachen und anschliessend bei mir im Board zu testen.

Zu meinem Flarum-Forum bitte unter http://flarum.internetblogger.de entlang. Heute habe ich zwei sehr nützliche Flarum-Erweiterungen wie AutoImage und Mediaembed entdeckt und nutze sie nun auch bei mir im Board.

Flarum Erweiterung: AutoImage

Beide Erweiterungen habe ich im eigens dafür erstellten Thread unter http://flarum.internetblogger.de/d/216-autoimage-flarum-erweiterung-hier-im-test im Test gehabt und alles schien zu funktionieren.

Bei der AutoImage-Extension, die du offiziell unter https://discuss.flarum.org/d/3789-autoimage-autovideo-turn-static-links-into-images-videos ausfindig machen kannst, handelt es sich von dem Konvertieren der statischen Bild-URLs in Bilder. Es werden aus losen Links Bilder im Flarum Topic, dem Post bzw. einem ganzen Thread.

Das probierte ich heute mit vollem Erfolg aus. Es ist doch schon entscheidend, ob du nun nach BBCode im Kopf suchst, wie du in Flarum ein Bild einbinden kannst, weil es ja auch noch die Markdown Syntax ist. Bilder in Markdown werden so eingebunden.

![Bild vom eigenen Garten](url-zum-bild.jpg)

So bindest du normalerweise Bilder mit Markdown ein und bei der obigen Erweiterung erübrigt sich das und du musst lediglich die URL in den Editor einfügen. Schon wird daraus ein Bild im Forum-Frontend. Das wäre diese nützliche Erweiterung und nun noch ein paar Tipps zum Installieren von AutoImage.

AutoImage Erweiterung Installation

Du loggst dich via Konsole in SSH ein und navigierst zum Root deines Flarum-Forums. Von dort aus führst du diesen SSH-Befehl aus.

php composer.phar require s9e/flarum-ext-autoimage

Danach loggst du dich im Flarum-Backend als Admin ein und navigierst zu den Erweiterungen bzw. den Extensions und installierst diese Erweiterung zu Ende. Das gilt im Forum ab dem Moment.

Jetzt spreche ich noch über das Einbinden der Youtube-Videos in Flarum.

Youtube-Videos in Flarum einbinden

Das Resultat meiner Einbindung eines Beispiel-Youtube-Videos siehst du hinter der oben gesetzten URL aus dem eigenen Flarum-Forum. Media-Content von Dritt-Anbietern wie Youtube und Co. wird per URL-Einfügen zwischen diese Tags eingebunden.

Update 09.08.2017 17:40

Leider reagiert WordPress auf die Media-Shorttags, sodass es auch nicht als Code dargestellt werden kann. Im Forum mit Markdown siehst du es dir dann besser an. Hier scheint es jetzt nicht zu gehen.

So habe ich heute ein Joomla 3.7 Video eingebunden. Vorher installiere bitte diese Flarum Erweiterung unter https://discuss.flarum.org/d/647-s9e-mediaembed-embed-videos-and-third-party-content. Das wird vom Rootverzeichnis aus mittels Kommandozeile mit diesem Befehl installiert.

php composer.phar require s9e/flarum-ext-mediaembed

Das muss ausgeführt werden. Danach wie gehabt, im Backend des Board unter Erweiterungen, die Extension aktivieren. Ab dann freie Bahn fürs Einbinden von YouTube-Videos oder des Media-Contents von Dritt-Anbietern. Ich vermute mal, dass es zahlreiche Video-Portale abdeckt.

[bctt tweet=”#Flarum #Erweiterungen zum Einbinden von Bildern und Media-Content von Dritt-Anbietern. Probiere es aus!” username=”blogsash”]

So kannst du heutzutage mit dem Flarum Forum herumwerkeln, besser Bilder und Videos einbinden. Das sollte schon noch funktionieren.

[note note_color=”#eee521″ radius=”10″]Bei Fragen zum Composer und der Kommandozeile wende dich hier drunter an mich und ich werde dir helfen.[/note]

Freue mich auch auf deine Extensions diesbezüglich bzw. deine Erfahrungen mit dem Einbinden von Bildern oder/und Videos im Flarum Forum.

by Alexander Liebrecht

P.S. Kleiner Tipp am Rande

Lösche bitte nach der Installation der beiden Erweiterungen via Konsole den Flarum Cache mit diesem SSH-Befehl.

php flarum cache:clear

 

Biete Installation von Confluence Server Instanz unter CentOS in Linux an – für 100 Euro

confluence-server-installation-unter-centos-in-linux-service-alexander-liebrecht

Hallo lieber Leser! Mit diesem Blogpost nutze ich Internetblogger.de kommerziell. Du hast dir unter Umständen schon einmal meine Confluence Instanz unter http://confluenceblog.liebrecht-projekte.de:8060 angesehen. Falls doch nicht, schaue es dir bitte an, um dir einen ersten Confluence Eindruck aus dem Frontend heraus zu verschaffen.

 

Mit Confluence habe ich seit ca. einem Jahr zu tun und mehrmals habe ich es unter Centos 7 in Linux installiert. Confluence Updates erscheinen mehr oder weniger jeden Monat, sodass ich diese auch installieren muss. Es läuft generell alles mit SSH und Kommandozeile. So ist Atlassian Software.

Confluence Server Installation auf deinem Root/vServer durch mich

Das würde ich dir gerne anbieten. Ich nehme mir die Zeit und ermögliche dir eine Confluence Server Instanz in der allerletzten Version unter Centos 7.x in Linux. Ich installiere dir Confluence und richte es ein. Du kannst anschliessend neue Bereiche erstellen. Vorher bräuchte ich lediglich die User-Daten und eine utf8bin – Datenbank. Falls du mir den Zugang zu SSH, MySQL und SFTP gewährst, wäre der Ablauf einer Installation ideal. Damit würde ich gerne bei der Installation arbeiten.

Confluence Server hat nach der Installation einmal das Installationsverzeichnis unter /opt/atlassian/confluence/ und einmal das Home-Verzeichnis unter /var/atlassian/application-data/confluence

Es werden CHMOD-Rechte dementsprechend vergeben und ich werde eine Confluence Instanz als User “confluence” und nicht als “Root” starten, denn das ist immer nötig.

Zudem werde ich sicherlich auch Probleme lösen, die mit der Installation verbunden sein werden. In der Regel installiert sich Confluence gut unter Centos 7.3 mit Plesk und in Linux. Alle Zugänge darfst du nach getaner Arbeit wieder dicht machen und Passwörter ändern. Installieren kann ich binnen paar Tage, nachdem du es mir per Mail mitteiltest oder es anfragtest. Dann mache ich mich an die Arbeit.

Arbeitsaufwand höher als bei WP+Joomla+Drupal

Aus diesem Grunde würde ich mir gerne eine einmalige Gebühr in Höhe von 100,00 Euro erlauben, nicht mehr.

Wenn du danach mit mir noch zusammenarbeiten willst, kann ich dir auch fortlaufende Confluence Server Updates installieren. Sie kommen von Monat zu Monat heraus, sodass da etwas gemacht werden müsste. Bei mir mache ich es auch.

Im Vorfeld kannst du mich per Mail unter power_sash@gmx.net erreichen und ausfragen, wie wo was. Dann entscheiden wir gemeinsam.

Ich freue mich auf deine Anfrage und diesen Blogpost pinne ich mal für etliche Monate an, um zu sichten, ob es überhaupt zu einer Anfrage kommen kann.

Kontaktdaten

Diese sind dem Impressum zu entnehmen und es gilt die Kleinunternehmerregelung nach §19, sodass meine Preise und Rechnungen keinerlei Mehrwertsteuer ausweisen. Nur damit du es im Vorfeld weisst.

by Alexander Liebrecht

Bildquelle by Alexander Liebrecht

 

#TikiWiki – #Update: Finalversion 17.0 erschienen

tikiwiki-17-0-update-erfolgreich-frontend

Hallo lieber Leser! Es leben neue Updates, könnte ich sagen, denn es gibt News seitens des TikiWikis. Eine neue Version 17.0 ist draussen, begleitet von zahlreichen Änderungen und Verbesserungen. In diesem Blogpost zeige dir gerne nochmals, was beim Updaten zu beachten gäbe und wie du das anstellen kannst.

 

Den TikiWiki lädst du immer von SourceForge.net unter https://sourceforge.net/projects/tikiwiki/ herunter. Dort hast du die Wahl zwischen den Files mit .zip und anderen.

Es gibt bereits diese Dokumentation zum TikiWiki 17 unter https://doc.tiki.org/Tiki17. Alles kann ich unmöglich ins Deutsche übersetzen, aber ich mich ein bisschen umgeschaut.

Wiki-Pages und Wiki-Plugins, daran haben die Entwickler gearbeitet. Es gab ein Favicons-Upgrade. Es gab Bugfix-Update inbezug auf Webservices und JSON bei den Inhaltstypen. Es hat einen neuen Parameter für die TikiWiki-Console gegeben.

Kennst du den SSH-Befehl zum Update der Tiki-Datenbank via Kommandozeile. Das wäre dieser:

php console.php database:update

Damit arbeitest du, wenn du nach dem Hochladen der neuen Dateien zum Server die Datenbank updaten musst. Bei grösseren Updates zwischen den Versionen ist das meistens immer notwendig. Viele weitere Änderungen und Updates, Verbesserungen hat es gegeben. Das kannst du der Tiki-17-Doku gerne entnehmen.

Das Update auf die neue Finalversion verlief heute wesentlich besser als bei Tiki 17.0 Beta. Da ging nach dem Update nichts mehr und heute ist es schon akzeptabler. Der TikiWiki bei mir unter https://internetblogger.de/tikiwiki wurde im Browser angezeigt, was ein guter Beweis dafür ist, dass zumindest das Update klappte.

Update auf TikiWiki 17.0 – Wie geht das?

Das ist keine Hexenkunst, denn ich gehe davon aus, dass du mit dem Tiki bereits arbeitest. So lädst du dir die aktuelle Version von SourceForge herunter, entpackst es lokal und packst den Inhalt zum ZIP-Archiv namens 170.zip.

Dieses Archiv muss zum Rootverzeichnis hochgeladen werden, eher es in der Konsole so entpackt wird. Vorher sichere bitte die Datenbank.

unzip 170.zip

Hinterher das Archiv wieder so löschen.

rm -rf 170.zip

Theoretisch könnte man noch alles im FTP-Account deiner Installation sichern. Aber ich mache es so nie und verlasse mich auf das jeweilige Update. Nach dem Entpacken via Konsole loggst du dich im Backend des TikiWikis ein und schaust es dir an. Falls dort ein SSH-Befehl zum Updaten der Datenbank stehen wird, dann diesen nehmen und in der Konsole vom Rootverzeichnis aus ausführen. Das wäre das ganze Update.

Teste deine Installation im Frontend, blogge damit oder poste im Forum, um alles zu checken. Wenn keinerlei Fehler da sind, ist alles im grünen Bereich. Im Control Panels heute schaute soweit alles gut aus und ich denke, dass wir diese Finalversion nutzen können.

Bei Fragen zum Update und wie du es anstellen kannst, kommentiere hier drunter den Post. Ich gehe dann nochmals darauf ein.

by Alexander Liebrecht

Bildquelle bei Alexander Liebrecht

Updates: Flarum Forum auf Managed Server mit PHP 7.0 und MySQL 5.7

flarum-update-version-0-1-0-beta7-mysql-5-7-und-php-7-0-internetblogger-de

Hallo lieber Leser und Flarum-Nutzer! Lange dauerte es mit dem neuen Flarum-Forum-Update und nun war es soweit. Das kannst du dem offiziellen Forumpost unter https://discuss.flarum.org/d/6341-flarum-v0-1-0-beta-7-released entnehmen. Die Entwickler, wie ich es erfasste, tun in deren Alltag noch andere Sachen, gehen zur Schule oder studieren. Daher dauert es lange, bis wir ein neues Update bekamen.

Weiterlesen

PHPBB 3.2.1 zwecks Wartung und mehr Sicherheit erschienen – Updaten empfohlen

phpbb-3-2-1-erschienen-sicherheit-wartung-bugfixes-internetblogger-de

Hallo Blogleser,

vor kurzem erschien die neue PHPBB 3.2.1 Version, ein neues Update, geschuldet mehr Sicherheit, Wartung und neuen Fehlerbehebungen. Das Update konnte ich bei mir erfolgreich von PHPBB 3.2.0 auf 3.2.1 einspielen. Das geschah unter http://phpbb32.wpzweinull.ch und unter https://www.phpbb.de/community/viewtopic.php?f=9&t=239967 kannst du kurz im deutschen Support-Forum im Release-Post reinlesen.

Weiterlesen

MediaWiki 1.29.0 Finalversion erschienen – stabil und mit Fehlerbehebungen + Features

mediawiki-1-29-0-finalversion-erschienen-internetblogger-de

Hallo lieber Blogleser! Seit mehreren Tagen wurde hier nichts mehr publiziert, was mitunter fehlenden CMS-Updates und anderweitiger Portfolio-Arbeit geschuldet war. Aber heute habe ich neue Updates. Im Portfolio ist meinerseits täglich etwas los, doch nicht aus allem muss ich Blogposts produzieren. Manche CMS-Updates werden routine-mässig durchgeführt, ohne dass ich sie verbloggt habe.

MediaWiki als 1.29.0 Finalversion draussen

MediaWiki 1.29.0 als stabile Finalversion war neulich erschienen, wie du unter https://www.mediawiki.org/wiki/MediaWiki_1.29 entnehmen kannst. Das grosse Update installierte ich eben bei meinem MediaWiki in der Version unter https://liebrecht-projekte.de/cms/mediawiki. Der MediaWiki funktioniert sowohl im Rootverzeichnis einer Hauptdomain, auf einer Subdomain oder wie bei mir im Unterverzeichnis.

Ausserdem gibt es den MediaWiki inzwischen in 350 verschiedenen Sprachen, sodass wirklich ein jeder Landsmann nicht zu kurz kommen wird. Installationstechnisch ist es nicht sehr kompliziert und falls doch, wende dich an mich. Ich werde dir bei der Installation gerne unter die Arme greifen.

Im Folgenden zeige ich dir noch das Updaten einer MediaWiki-Installation, wie ich es heute durchführte.

Update auf MediaWiki 1.29.0 – wie geht das?

Lade dir die letzte MediaWiki-Version von https://mediawiki.org herunter, entpacke es lokal und packe alle Dateien sowie Verzeichnisse zum ZIP-Archiv namens 1290.zip. Du arbeitest auch dieses Mal mit der Kommandozeile und FTP, dem Tool BitVise oder Filezilla, je nachdem, was dein Standard-FTP-Client ist.

Sichere bitte dieses Mal die MySQL-Datenbank und lade das vorher gepackte ZIP-Archiv ins Rootverzeichnis deiner Installation hoch.

Logge dich mit Bitvise in SSH ein und navigiere zum Rootverzeichnis deiner Installation. Von dort aus entpackst du das ZIP-Archiv dermassen.

unzip 1290.zip

Danach löschst du das Archiv wieder so.

rm -rf 1290.zip

Als Nächstest muss du den Composer updaten. Dieser befindet sich als Datei composer.phar im Rootverzichnis, wo auch die Config-Datei LocalSettings.php dauerhaften Platz eingenommen hatte. Composer wird so aktualisiert.

php composer.phar update

Dann musst du zum Wartungsverzeichnis mittels Konsole so navigieren.

cd maintenance

Von dort aus führst du diesen SSH-Befehl aus.

php udpate.php

Deine Datenbank wird aktualisiert und du kannst es dir anschliessend im Frontend deiner MediaWiki-Installation mal ansehen. Logge dich in MediaWiki ein und hänge an das Ende der URL im Browser dieses an.

/Spezial:Version

Dahinter lässt du dir die MediaWiki-Version anzeigen. Wenn es nun 1.29.0 ist, wurde das Upgrade erfolgreich durchgeführt.

Ab dann freie Bahn zum Posten in deinem MediaWiki.

Was gibt es Neues beim MediaWiki 1.29.0?

Ich zeige dir mal einen Screenshot von der Seite mit MediaWiki 1.29.0. Auf dem Bild siehst du, was alles neu ist und noch mehr kannst du hinter dem ganz oben gesetzten Link nachlesen.

mediawiki-1-29-0-news-features-bugfixes-internetblogger-de
Neues in MediaWiki 1.29.0

Es wurde an allen Ecken des MediaWikis etwas gemacht. Es sind nicht nur Fehlerbehebungen, sondern auch ein paar neue Funktionen hinzugekommen.

Wichtiger Hinweis

Bitte benenne composer.phar nach “composer” um, um deine Installation ftp-technisch etwas sicherer zu machen.

MediaWiki-Upgrade dieses Mal verlief bei mir super und ich arbeite nach der Standard-Methode, die ich erlernt habe. Es klappt damit so gut wie immer und es muss schon etwas mit dem Composer sein, was das Upgrade verhindert. Falls deine MediaWiki-Installation vorher ging, wird sie auch nachher gehen. Schliesslich sind die Entwickler dann gefragt und sie testen solche Updates für uns User im Vorfeld.

BlueSpice MediaWiki

Dieser wird erst ab MediaWiki 1.30, welcher derzeit nur als Alpha-Version vorliegt, kompatibel gemacht. Dann werde ich meine BlueSpice-Installation aktualisieren können. Derzeit ist da nichts kompatibel und es würde gleich beim BlueSpiceSkin Probleme im Frontend geben. Daher, wenn du BlueSpice einsetzen willst, musst du den MediaWiki 1.27.2 nehmen. Normaler Wiki geht direkt mit MediaWiki 1.29.0 sehr gut.

Das war mein heutiges MediaWiki-Update und bei Fragen hierzu ist es wie gehabt, wobei du mich hier drunter gerne feedbacken kannst.

  1. Welche Update-Erfahrungen hattest du dieses Mal?
  2. Was hindert dich daran, selbst MediaWiki-Updates zu machen?
  3. Wo liegen bei dir die Schwierigkeiten beim Aktualisieren?

Freue mich auf dein Feedback.

by Alexander Liebrecht

Bildquellen by https://liebrecht-projekte.de, https://mediawiki.org

MediaWiki 1.29 RC1 erschienen

mediawiki-1-29-0-RC-1-liebrecht-projekte-de

Hallo lieber Leser! Ich bin ja auf Zack, wenn es um CMS-Updates aller Art geht und heute erreichte mich eine MediaWiki-Mail mit der Nachricht, dass die neue Version 1.29.0 RC1 erschienen ist.

Zu den ReleaseNotes, den Erscheinungsnotizen, geht es unter https://www.mediawiki.org/wiki/Release_notes/1.29 und dort entnimmst du allerhand Details und Infos, was MediaWiki 1.29 angeht.

Es wird auch gesagt, dass diese Version noch nicht für den produktiven Einsatz geeignet ist. Da ich aber vorher unter https://liebrecht-projekte.de/cms/mediawiki RC 0 hatte, musste ich einfach ein Update machen. Das sorgt für mehr Fehlerbehebungen und vielleicht auch Verbesserungen in puncto Sicherheit.

Vor kurzem erste Kundeninstallation mit BlueSpice MediaWiki

Ja, dazu ist es gekommen und meinen CMS-Installation-Service promote ich wie wild im ganzen Portfolio, ohne dass ich andere Webseiten damit belästigen muss. Im Portfolio ist der richtige Platz für meine Projekte und die damit verbundene Promotion.

Dieses Update kannst du aber leider nicht bei BlueSpice machen, denn BlueSpice wird erst mit MediaWiki 1.30 kompatibel gemacht. Die Version 1.29 stable ist für den Juli 2017 geplant, also schon in diesem Monat. Da wird sicherlich ein Upgrade bei mir, wenn es soweit ist, gerne erfolgen.

In diesem Blogpost rufe ich es bei dir in Erinnerung, wie du eine MediaWiki-Installation upgraden kannst.

Wie mache ich Update auf MediaWiki 1.29.0 RC 1

Schaue dir unter https://mediawiki.org um und lade dir das letzte RC1-Release herunter, entpacke es lokal und packe den Inhalt zum ZIP-Archiv namens 129.zip. Wir arbeiten beim MediaWiki immer mit Kommandozeile, weil alle Pakete recht gross sind. Danach lädst du das Archiv ins Rootverzeichnis deiner MediaWiki-Installation auf deinem Webspace hoch und entpackst derart in der Konsole.

unzip 129.zip

Bitte mache spätestens dann ein Datenbank-Backup, um es dir etwas sicherer zu machen. Erst dann kannst du das Archiv wieder derart vom FTP-Account entfernen.

rm -rf 129.zip

Danach erfolgt das Updaten des Composers vom Rootverzeichnis aus, was so geht.

php composer.phar update bzw. install

Schlussendlich navigierst du in der Konsole zum MediaWiki-Wartungsverzeichnis mit “cd maintenance” und führst diesen SSH-Befehl dort aus.

php update.php

Warte kurz, bis 5 Sekunden vorbei sind und beobachte, wie deine Datenbank aktualisiert wird.

Das wäre dann die ganze Upgrade-Prozedur und diese musst du über dich und deine Installation ergehen lassen. Falls du dabei Bedenken hast und es ist ein stabiles Release, kannst du gerne mich damit beauftragen. Ich kann dir zeitnah deinen MediaWiki upgraden.

MediaWiki 1.29 ab PHP 5.5.9

Erst dann wird es funktionieren und es läuft schon unter PHP 7.0, eventuell auch unter PHP 7.1 schon. Das kannst du mal austesten und meistens hast du im Webhosting eine Möglichkeit, zwischen den PHP-Versionen umzuschalten. Bei All-inkl bei meinem Managed Server kann ich sogar bei jeder Subdomain einzeln eine bestimmte PHP-Version aktivieren. Das macht das Arbeiten mit verschiedenen CMS möglich.

Ich werde dich zu BlueSpice und dem MediaWiki hier auf Internetblogger.de gerne auf dem Laufenden halten. Heute war es eben das Update und dieses wurde promt erledigt.

Bei Fragen zu SSH und/oder dem Update selbst ist es wie gehabt und du kannst darunter feedbacken.

Deine Update-Erfahrungen interessieren so eine Person wie mich immer und bei jedem Update ist es etwas anders, denn das Webhosting kann nicht gleich sein. Manches Shared Webhosting läuft auf Ubuntu, anderes unter Debian oder Centos oder oder oder. Daher wäre das spannend.

by Alexander Liebrecht

Bildquelle via https://liebrecht-projekte.de

Flarum-Erweiterung eMoji-Picker Installation und Handhabung

flarum-erweiterung-emoji-picker-installation-internetblogger-de

Hallo Blogleser und Flarum-Nutzer! In diesem Blogpost widme ich mich kurz der neuen/alten Flarum-Erweiterung namens Emoji-Picker, die ich heute unter https://discuss.flarum.org/d/4787-emoji-picker entdeckte.

Installiert habe ich diese Extension, was durch den Composer via Kommandozeile funktioniert. Ich möchte dir kurz zeigen, wie du es auch installieren und hinterher handhaben kannst.

Hier über dem Post auf dem Beitragsbild siehst du nun im Text meine ersten eMojis. Sie sind sehr zahlreich existent beim Flarum und weitere kommen durch diese eMoji-Picker-Erweiterung hinzu.

Ich habe unter http://flarum.internetblogger.de/d/203-emoji-picker-fuers-flarum-forum einen Beispiel-Forum-Post mit ersten eMojis erstellt, damit du dir ein Bild davon machen kannst.

Wie installiert sich diese Erweiterung?

Gewöhne dir im Alltag das Arbeiten mit dem SFTP/SSH-Client namens BitVise. Damit hast du alles, was du als CMS/Forum-Checker brauchst. Vom Rootverzeichnis aus nutzt du diesen SSH-Befehl und führst ihn in der Kommandozeile aus.

php composer.phar require clarkwinkelmann/flarum-ext-emojionearea

Ich habe mein Flarum-Forum auf einer Subdomain, sodass ich per Kommandozeile nur einmal mit dem Befehl “cd subdomain” arbeiten muss. Falls es dir ebenfalls so geht, dann geht es mit dem “cd”-Befehl zum Wechseln in das richtige Verzeichnis innerhalb des FTP-Accounts.

Befehl ausführen und loggst dich anschliessend im Flarum-Backend ein, installierst diese Erweiterung. Im Frontend, wenn du deinen nächsten Forum-Post schreibst, findest du den Button für eMojis.

Zudem lassen sich eMojis super auswählen, wenn du einen Doppelpunkt nach dem Cursor setzt. Einfach ein “:” und schon werden Details sichtbar. Per Button beim Erstellen eines Forum-Posts ist es nur etwas bequemer, denn so hast du alle eMojis und kannst in den Kategorien schauen, was du nehmen willst.

Emojis für Github oder Google fand ich leider nicht

Damit wollte ich heute arbeiten, aber leider keine solchen eMojis gefunden. Ich habe es wohl erst mit den FontAwesome Icons verwechselt, denn sie bieten SocialNetworking-Icons an. Na gut, hier haben wir eMojis und auch ganz gut zu handhaben.

Was bringen dir diese eMojis?

 

Du kannst interaktiver im Flarum-Forum posten und deine Inhalte mit diesen kleinen Icons schmücken. Es ist etwas Visuelles und macht die Inhalte durchaus etwas leserlicher. Auch kannst du innerhalb deiner Flarum-Forumposts mit den Rautezeichen für die Headings arbeiten. Strukturiere lange Posts als würdest du bloggen. Die Forumleser danken dir hinterher.

Das wäre mal dazu und falls du Fragen zur Installation dieser Extension haben solltest, wende dich bitte hier schnell an mich.

Die PHP-Erweiterung “phar” muss auf deinem Shared Webhosting installiert sein, denn sonst wird der Composer nicht funktionieren. Falls es bei dir nicht der Fall ist, sprich deinen Hoster darauf an. Da geht sicher einiges oder…

Freue mich auf dein Feedback und deine eMojis-Forum-Posts zum Begutachten.

by Alexander Liebrecht

Neue Flarum Extension BBCode Alerts und Notifications

flarum-extension-bbcode-alerts-und-meldungen-hinweise-internetblogger-de

Hallo lieber Leser! Verfolgst du bei mir noch das Flarum Forum Thema? Es gibt jetzt wieder eine neue und coole Erweiterung namens BBCode Alerts & Notifications. Diese Erweiterung lässt gestylte Erfolgsmeldungen, Hinweise oder Warnungen anzeigen. Zu dem offiziellen Flarum-Forum-Post geht es unter https://discuss.flarum.org/d/6044-0e800-s-bbcode-alerts-notifications.

Ich habe diese Extension schnell installiert und hierzu im eigenen Flarum-Board einen neuen Thread aufgemacht. Das wäre dann unter http://flarum.internetblogger.de/d/202-flarum-erweiterung-bbcode-allerts-erfolgsmeldungen , was du dir mal ansehen kannst. Das macht Spass, denn du machst den Forum-Content etwas interaktiver und kannst deine Forum-Leser auf dies oder jenes aufmerksam machen.

Wie installiert sich diese Erweiterung?

BBCode Alerts & Notifications Installation

Nutze bitte das SSH/SFTP-Tool namens BitVise, in welchem du dich lediglich einzuloggen brauchst. Dann navigierst du zum Flarum-Rootverzeichnis mit dem “cd-Befehl” und führst dort diesen SSH-Befehl aus.

php composer.phar require oe800/flarum-ext-bbcode-alerts

Die Extension wird installiert.

Danach loggst du dich im Flarum-Backend ein und gehst zu den Erweiterungen. Anschliessend gilt es, diese Erweiterung zu aktivieren. Im Frontend kannst du mit solchen BBCodes arbeiten wie diesen.

[AWARNING]{TEXT}[/AWARNING]

[AINFO]{TEXT}[/AINFO]

[ASUCCESS]{TEXT}[/ASUCCESS]

[ABASIC]{TEXT}[/ABASIC]

Im Flarum-Forum-Post im Forum findest du weitaus mehr gestylte BBCodes, um die Hinweise und deine Meldungen nach Belieben zu gestalten.

Mir sagt diese Flarum-Erweiterung voll und ganz zu und wenn ich es brauche, wird davon rege Gebrauch gemacht.

Nun, ich hoffe, dass du mit diesem Blogpost etwas Neues zu Flarum erfahren hast. Du kannst gerne auch das offizielle Flarum-Forum unter https://flarum.org verfolgen. Flarum-Extensions kommen weiterhin nach und nach heraus, sodass das eigene Board etwas mehr erweitert werden kann.

Bei Fragen zur Installation oder zum Composer wende dich hier an mich und ich helfe dir sehr gerne.

by Alexander Liebrecht

Neue Updates für Confluence Server und Bitbucket Server mit Fehlerbehebungen

confluenceblog-liebrecht-projekte-de

Hallo lieber Leser! Weisst du es schon, dass ich mit Atlassian Software arbeite. Dazu zählen meinerseits JIRA Software Server, Confluence Server und Bitbucket Server. Atlassian stammt aus Australien und ist ein Premium Software Anbieter, welches bei etlichen Unternehmen weltweit in Anspruch genommen wird.

 

Bei diesem Blogpost geht es mir um neue Updates von Confluence Server 6.2.1 und Bitbucket Server 5.0.2. Ich möchte dir hiermit zeigen, wie du updaten kannst und wie du zum Beispiel herausfindest, ob diese Instanzen im richtigen Installationsverzeichnis gestartet wurden.

Confluence und Bitbucket sind javascript-basierend und erfordern einen Windows/Linux-Rootserver, Node.js und Tomcat, damit du den BIN-Installer im Verzeichnis /usr/bin ausführen kannst. So ein SSH-Befehl kann zum Beispiel derart aussehen.

./atalssian-confluence-6.2.1-x64.bin

Danach folgst du den Hinweisen in der Kommandozeile. Das ist nicht sehr schwer, denn nur anfangs musst du ganz genau schauen, was du in der Konsole eingibst. Ich fange mal mit dem Update auf Confluence Server 6.2.1 an.

Update auf Confluence Server 6.2.1

Es ist ein Fehlerbehebungsupdate. Details hierzu kannst du offizielerseits unter https://confluence.atlassian.com/doc/confluence-6-2-release-notes-894219485.html entnehmen. Dort sind auch die Tickets vermerkt, die als erledigt gelten. Es ist sehr gut, denn das solltest du wissen, dass an Confluence allerhand professioneller Entwickler mitarbeiten und dadurch diese Linux/Windows-Software stetig verbessert wird oder werden kann.

Lade dir den Linux-Installer von der offiziellen Webseite unter https://atlassian.com herunter und lade den Installer ins Verzeichnis /usr/bin hoch. Vergebe ihm CHMOD-Rechte von 755 und starte es in der Konsole dermassen.

./atlassian-confluence-6.2.1-x64.bin

Dann nimmst du das Upgrade von a existing Instanz. Das siehst du dann dort, was in der Konsole steht. Beim Upgraden wird das Home-Verzeichnis unter /var/atlassian/application-data/confluence gesichert und das Installationsverzeichnis unter /opt/atlassian/confluence wird durch die neuen Files ersetzt.

So folgst du den Hinweisen in der Kommandozeile und gradest up. Bitte starte Atlassian Software, seien es JIRA, Confluence oder Bitbucket Server niemals als “root”, sondern immer als Nutzer dieser Instanzen.

Demnach gilt es in der Konsole immer zum jeweiligen User zu wechseln, was du so machen kannst.

su confluence

su atlbitbucket

su jira

Erst dann kannst die Instanzen in der Konsole für den Browser starten. Falls Confluence Server nicht gestartet ist bzw. im Browser nicht starten möchte, checkst du via SSH, welche Tomcat-Prozesse dann für Confluence sprechen. Dazu nimmst du diesen SSH-Befehl, welchen du in der Konsole als “root” ausführen kannst.

ps -aux | grep confluence

Dir wird dann alles angezeigt. Nicht korrekte Tomcat-Prozesse kannst du entweder mit dem Confluence-Befehl stoppen oder du nimmst das.

kill <pidid>

Die Pid-ID wird dir angezeigt, wenn du mit “grep” nach Confluence-Prozess gesucht hast. Dann einfach den Prozess killen und Confluence im Verzeichnis /opt/atlassian/confluence/bin so starten.

sh start-confluence.sh

Falls du via SSH mitverfolgen willst, wie Confluence startet und was alles startet, nimm diesen SSH-Befehl.

sh start-confluence.sh -fg

Denke daran, dass wenn du das Konsolen-Fenster schliesst, dass dann Confluence Start gestoppt wird. Du kannst das Konsolen-Fenster dann wieder öffnen und startest Confluence ohne die Endung “-fg“. “-fg” bedeutet, starten im Vordergrund. Das braucht man oft, wenn Confluence im Browser nicht starten will.

Nun hoffe ich, dass deine Confluence Server Instanz gestartet ist und du weiterhin arbeiten kannst. Bei Fragen wende dich einfach hier an mich oder du bemühst du übelst grosse Atlassian-Support-Community unter https://atlassian.com.

Update auf Bitbucket Server 5.0.2

Bitbucket 5.0.2 kam mit etlichen erledigten Tickets daher, sprich alles Fehlerbehebungen. Das kannst du den Erscheinungsnotizen unter https://confluence.atlassian.com/bitbucketserver/bitbucket-server-5-0-release-notes-889528342.html entnehmen.

Bitbucket wird im Verzeichnis /opt/atlassian/bitbucket/<nummer> installiert und das Home-Verzeichnis befindet sich beim Linux-System unter /var/atlassian/application-data/bitbucket. In der Konsole lädst du den Linux-Bin-Installer wiederum ins Verzeichnis /usr/bin hoch, vergibst ihm CHMOD-Rechte von 755. Danach in der Konsole so ausführen.

./atlassian-bitbucket-5.0.2-x64.bin

Ab dann beobachtest du und reagierst auf Upgrade-Hinweise. Du wirst wiederum eine bereits existierende Instanz upgraden müssen und so gilt es dann auch einzugeben. Das werden solche ziffern wie “1” und/oder “2” sein. Daneben steht in der Kommandozeile immer das, was dann passiert. Das siehst du dann alles via SSH.

Zum Upgrade-Ende wird die Instanz im Browser gestartet. Du kannst es bis dahin durchlaufen lassen, aber deine Instanz wird im früheren Installationsverzeichnis starten. Wenn du es vorher unter der Nummer /5.0.1 hattest, wird es wieder dort sein. Das heisst, wir müssen in Linux zum Verzeichnis /var/www/vhosts/system/deinebitbucketsubdomain/conf. Öffne die Datei httpd.conf und vermerke darin den DocumentRoot so.

 DocumentRoot "/opt/atlassian/bitbucket/5.1.0"

Das wird so sein, beachte das Endverzeichnis, dass dein DocumentRoot je nach Verzeichnisnamen definiert ist. Hast du dein Installationsverzeichnis unter /5.0.2, dann trage es auch so ein. Das gilt es dann zu ändern. Danach Apache neustarten mit diesem SSH-Befehl.

service httpd restart

Wenn die Konsole nicht meckert, ist alles bestens und du kannst dann nochmals herausfinden, welches Installationsverzeichnis nach dem Upgrade läuft.

Nimm dann diesen Befehl.

ps -aux | grep bitbucket

Kille den nicht richtigen Prozess mit “kill <pidid>” und starte den Tomcat-Prozess im richtigen Verzeichnis so.

su atlbitbucket
cd /opt/atlassian/bitbucket/verzeichnisname/bin
sh start-bitbucket.sh

Dann wird gestartet und habe im Browser nur etwas Geduld. Es werden alle Bereiche und Komponenten deiner aktuellen Instanz gestartet. Das kannst du gut beobachten.

So, jetzt habe ich dir alles erzählt, womit ich im Atlassian-Alltag zu tun habe. So gehe ich immer vor, um zu gewährleisten, dass JIRA, Confluence und Bitbucket im Browser starten. Diese Befehle kenne ich inzwischen auswendig, weil immer wieder angewandt.

Fazit zu Confluence, Bitbucket Updates

Es wird nötig sein, sich mit der Software zu befassen und auch SSH ist immer mit von der Partie. Falls du aber einen Linux-Server unter dir hast, wirst du bestimmt auch schon die Konsole entdeckt haben. Damit gilt es idealerweise täglich zu arbeiten, um die gängigen Linux-SSH-Befehle zu kennen. Ich kann dir etwas unter die Arme greifen, aber die SSH-Befehle müsstest du dir selbst merken.

[bctt tweet=”#Confluence + #Bitbucket #Updates erschienen. Updaten via SSH und FTP.” username=”blogsash”]

Ich hoffe, dass die obige Anleitung nicht kompliziert ist.

Freue mich ebenfalls auf dein Feedback und ggf. SocialMedia Signale.

 

Ein Versuch mit TikiWiki 17.0 alpha zu arbeiten gelingt mir

tikiwiki-internetblogger-de

Hallo lieber Leser und TikiWiki-User! Vor kurzem ist TikiWiki 17.0 Alpha erschienen, wie du es in den Downloads auf SourceForge.net unter https://sourceforge.net/projects/tikiwiki/files/?source=navbar finden kannst. TikiWiki 17.0 Alpha lasse ich bereits im eigenen TikiWiki unter https://internetblogger.de/tikiwiki laufen und anfangs war mein Tiki einfach unerreichbar, weshalb auch immer.

Weiterlesen

Sicherheitsupdates von MediaWiki 1.27.3 und 1.28.2

mediawiki-sicherheitsupdates-versionen-1-27-3-und-1-28-2-internetblogger-de

Hallo lieber Leser! Es handelt sich wieder von der Sicherheit des MediaWikis. Es sind zwei Versionen, wie 1.27.3 und 1.2.82 draussen. Beide Versionen sind der verbesserten Sicherheit geschuldet und alles habe ich bereis installiert.

Ich zeige dir in jedem Falle, wie solche MediaWiki-Updates ablaufen, denn es gibt manchmal User, die sich da nicht herantrauen. Der Composer muss upgedatet werden und du musst vom Wartungsverzeichnis aus update.php in der Konsole laufen lassen. Und so weiter, alles ein bisschen an Wissen, was du haben solltest, falls eine MediaWiki-Installation vorliegt.

Update auf MediaWiki 1.27.3

Ich bekomme immer eine Mail-Nachricht, wenn MediaWiki Updates online gestellt hat und lade mir die jeweilige Version direkt aus der Mail heraus herunter. So auch dieses Mal. Dann entpackst du das Paket. Gepackt als ZIP-Archiv sind es um die 30 MB und wie du das von mir schon kennst, arbeite ich mit BitVise. Ich fand heraus, dass es doch funktioniert, CHMOD-Rechte mit diesem SSH-Client zu ändern. Einfach genial, weil ich da Filezilla gar nicht mehr brauche.

Packen des Inhaltes zum ZIP-Archiv

Du hast den Inhalt des Paketes zum ZIP-Archiv gepackt, lädst es ins Rootverzeichnis deiner MediaWiki-Installation hoch. Dann benennst du die Datei, die im Rootverzeichnis ist, namens composer nach composer.phar um. Sie musst du in der Konsole ausführen. Dazu nimmst du diese beiden SSH-Befehle.

php composer.phar self-update

php composer.phar update

Das wird genügen und das machst du ein jedes Mal, wenn ein MediaWiki-Update da ist, aber erst nach dem Hochladen neuer Files zum FTP-Account.

Entferne bitte bei dieser einen Datei die Endung “phar” wieder, weil es sonst Unbefugte ausführen könnten und das wollen wir nicht.

Navigieren zum Wartungsverzeichnis mit dem “cd”-Befehl

Dann navigierst du mit “cd maintenance” zum Wartungsverzeichnis und tippst in der Kommandozeile diesen Befehl ein.

php update.php

Deine MediaWiki-Datenbank wird aktualisiert. Das geht auch bei allen MediaWiki-Versionen so.

So, danach loggst du dich im Frontend deines MediaWikis ein und navigierst im Browser zu /Spezial:Version. Dahinter kontrollierst du die aktuell vorliegende MediaWiki-Version. Das wäre das, was zu machen ist. Es ist nicht sehr kompliziert und du kannst es dir einprägen.

Update auf MediaWiki 1.28.2

Das wird analog nach der ersten Anleitung durchgeführt. Du machst alles genauso und daher lernst du es auch so. Wie oben erwähnt, gelten die beiden Updates der Sicherheit und wenn es darum geht, versuche ich, zeitnah zu handeln. Auch wenn heute der 1. Mai ist, Tag der Arbeit, arbeite ich dann auch ein bisschen 😉

Falls du Update-Materie nicht ganz verstehst, frage mich einfach hierzu hier in den Kommentaren aus. Da kann ich dir sicherlich behilflich sein.

So wünsche ich dir einen schönen 1. Mai und viel Update-Erfolg sowie Spass bei der Arbeit mit MediaWiki.

P.S. im Übrigen geht der BlueSpice beim MediaWiki 1.28 noch nicht. Das wird eventuell erst beim MediaWiki 1.29 kompatibel gemacht, aber sehr genau weiss ich es noch nicht.

by Alexander Liebrecht

 

MediaWiki-Sicherheitsupdates und Update von BlueSpice MediaWiki

bluespice-mediawiki-1-27-1-im-frontend

Hallo lieber Leser! Ja, so ist es bei mir im Webmaster-Alltag, täglich neue Updates, die auch verbloggt werden. Hierbei handelt es sich von MediaWiki und BlueSpice, einer Komponente für den MediaWiki. Für MediaWiki sind wichtige Sicherheitsupdates erschienen und BlueSpice beförderte ein Wartungsrelease nach draussen.

Weiterlesen

Neue Flarum Erweiterung BBCode FontAwesome Icons

flarum-forum-erweiterung-bbcode-fontawesome-icons-installation

Hallo lieber Leser! Heute blogge ich hier ein bisschen, weil es sein muss. Mir geht es in diesem Post um eine neue Flarum Forum Extension namens BBCode FontAwesome Icons, die unter https://discuss.flarum.org/d/4981-fontawesome-bbcode-extension vorgestellt wurde.

Diese Erweiterung stellt coole und web-affine Icons im Flarum Forum dar und ich habe es schon unter http://flarum.internetblogger.de/d/193-ich-teste-mal-die-neue-extension-bbcode-fontawesome-icons ausprobieren können.

Flarum Erweiterungen werden allesamt mithilfe des Composers und via Kommandozeile/SSH installiert. Einige Male ausprobiert, dürfte es bei jedem User gut klappen. Den Composer kannst du auch ab und an updaten, was mit diesem SSH-Befehl vonstatten geht.

php composer.phar update

Bitte ändere “composer.phar” nach “composer”, um Angriffe von Fremden fernzuhalten, ansonsten kann diese Datei auf dem Server ausgeführt werden.

Wie installierst du Flarum Extension BBCode FontAwesome Icons?

Du nimmst diesen SSH-Befehl vom Rootverzeichnis aus und führst ihn in der Kommandozeile via SSH aus.

php composer.phar require antoinefr/flarum-ext-bbcode-fa

Danach loggst du dich im Forum-Backend mit deinen Login-Daten ein und navigierst zu den Erweiterungen. Anschliessend klickst du in die Checkbox bei dieser Erweiterung und schon wird sie installiert. Du siehst es anhand meines oben verlinkten Forumposts, wie das Ganze mit den Icons live aussieht. Da geht noch wesentlich mehr und solche FontAwesome Icons findest du in der Regel unter http://fontawesome.io/icons/.

Dort erfährst du, was das für Icons sind. Um sie im Forumpost darstellen zu lassen, nimmst du den Iconnamen, kleingeschrieben, in diese Tags.

[fa]icon[/fa]

Das wird ausreichen und du kannst allerhand Symbole darstellen lassen. Das ist doch mal interaktiv und du lässt deine Icons sprechen. Ich werde es eventuell bei meinen Forumposts gerne nutzen. Dass diese Flarum Extension funktioniert, habe ich ja gesehen und so ist es gut zu wissen. Updaten kannst du diese Erweiterung, wenn du den Composer aktualisierst, was du alle Tage mal machen solltest.

Fazit zu BBCode FontAwesome Icons

Die Icons sind mal ganz cool und eignen sich super zum Posten im Flarum-Forum. Flarum Erweiterungen sind zur Zeit nicht wie Sand am Meer vertreten, aber es werden nach und nach immer mehr, weil auch viele Freizeitentwickler mit an Bord sind. Da wird fleissig weiterentwickelt und getan.

Falls du Flarum-Forum als OpenSource Forum Lösung noch nicht kennst, lass es dir gesagt sein, dass es eine gute Forumlösung mit Potential ist. Du postest in der Markdown Auszeichnungssprache, auch teilweise geht der BBcode, was in Foren üblich ist. Du hast eine Forumsignatur, kannst das Forum mittels Adsense monetarisieren und auch gibt es die deutsche Sprache beim Flarum Board.

Die Flarum-Community ist sehr wachsam und hilft bei allen Belange, was Flarum angeht. Installationstechnisch geht Flarum bei Uberspace, All-inkl, Hetzner, Serverprofis und vielen anderen deutschen Webhostern, ab PHP 5.6 aufwärts und mit der herkömmlichen MySQL-Version. Ich setze PHP 7.0/7.1 und MySQL 5.6 serverweit ein.

Nun, das wäre das zu den Icons und ich freue mich, über deine Erfahrungen mit FontAwesome Icons zu lesen. Feedbacken wie gehabt darunter.

by Alexander Liebrecht

Drupal Update 8.3.0 RC2 mit neuen Funktionen, mehr Sicherheit und Bugfixes

drupal830-im-frontend-internetblogger-de

Hallo lieber CMS-Leser! Es sind 2 Drupal 8 Versionen erschienen, einmal 8.2.7 und einmal 8.3.0 RC2. Die Version 8.2.7, die auch stabil ist, habe ich installiert, doch mein Design im Blog war dann zerschossen. Also was tun!? Nun habe ich dann die Entwicklerversion 8.3.0 RC 2 installiert und dann ging alles wieder.

Die erste Version war ein Wartungs-Sicherheitsupdate und wird wärmstens empfohlen. Die Version 8.3.0 RC 2 kam mit Fehlerbehebungen, neuen Funktionen und Verbesserungen daher. Darum geht es in diesem Blogpost.

Beide Drupal 8 Versionen sind doch mal nett und für welche du dich entscheidest, hängt davon ab, wie es bei dir damit kommt. Installiere erst einmal die Version 8.2.7, um zu sichten, ob dein Blogdesign dann in Ordnung sein wird. Falls doch nicht, dann musst du so wie ich die Version 8.3.0 installieren oder du wartest bis zur nächsten stabilen Drupal 8 Version.

Im Folgenden erzähle ich dir noch davon, wie das Upgrade auf die nächste Drupal 8 Version so zu machen ist.

Wie gradest du auf Drupal 8.3.0 RC2 up?

Du lädst dir die Version unter https://www.drupal.org/project/drupal/releases/8.3.0-rc2 herunter, entpackst es lokal, sicherst deine MySQL-Datenbank und packst den Inhalt des Downloadpaketes zum ZIP-Archiv namens 830.zip. Das muss dann ins Rootverzeichnis deiner Installation hochgeladen werden.

Ich arbeite mit der Konsole, wenn ZIPs entpackt werden sollen und dafür nimmst du diesen SSH-Befehl.

unzip 830.zip

Du löschst das Archiv hinterher dermassen.

rm -rf 830.zip

Danach wird es etliche Aktualisierungen zu installieren geben. Dafür begibst du dich zum Statusbericht im Drupal 8 Backend und datest die Datenbank up. Auch kannst du noch bei den Sprachen und Übersetzungen manuell überprüfen, ob es Updates gibt. Falls doch, wird es dir angezeigt und du kannst fehlende Übersetzungen in deinen D8-Blog verfrachten. Das machte ich eben so und es wurden mehr als 1300 neue Übersetzungen hinzugefügt.

Das wäre im Grossen und Ganzen unser Upgrade und wenn dann im Statusbericht alles OK ist, hast du es vollbracht. Wie du hier sichten kannst, ist ein Drupal Update halb so tragisch, muss aber regelmässig erfolgen.

Der Statusbericht schaut designtechnisch beim Drupal 8.3.0 viel schöner aus, aber das ist nur so zum Wahrnehmen und ändert nichts an deiner D8-Installation. Das ist mir nur heute aufgefallen und ich nahm es zur Kenntnis.

Bei Fragen zum Update laut kommentieren!

Falls du Fragen zur Kommandozeile und/oder zum eigentlichen Update hast, einfach hier drunter feedbacken und gemeinsam finden wir heraus, warum du Update-Probleme hast. Auch kannst du dich an die deutschsprachige Drupal-Community gerne wenden. Es sind dort auch Entwickler am Posten, sodass diese sich mit der Materie noch wesentlich besser auskennen als ich. Wie du magst!

Dir viel Erfolg beim Upgraden und ich freue mich über jegliches Feedback von dir.

by Alexander Liebrecht

 

Backdrop 1.6.1 CMS erschienen mit Bugfixes

backdrop-cms-releases-github-repository

Hallo lieber Leser! In meiner Familie herrscht tiefe Trauer, weil ein sehr naher Verwandte seit Tagen vermisst wird. Das hat mich ganz schön mitgenommen, doch es muss irgendwie weitergehen und in Hoffnung wartend, dass dieser Mensch noch gefunden wird.

In diesem Blogpost geht es um die neue Backdrop CMS Version 1.6.1, die vor kurzem erschienen war.

Beim Backdrop CMS 1.6.1 gab es meistens Fehlerbehebungen und einige Verbesserungen, die den Entwicklern zugute kommen können. Ich machte das Upgrade bereits unter https://alexanderliebrecht.de und unter https://github.com/backdrop/backdrop/releases findest du die letzte Version. Dort kannst du sie auch herunterladen.

Ich will dir als dem neuen Leser von Internetblogger.de zeigen, wie du problemlos und erfolgreich ein Update machen kannst.

Wie grade ich auf Backdrop CMS 1.6.1 up

Das ist nicht sonderlich schwer, aber du wirst die Kommandozeile und FTP brauchen. Lade dir die letzte Backdrop 1.6.1 Version von GitHub herunter, entpacke es lokal und packe das Verzeichnis /core zum ZIP-Archiv namens core.zip.

Das lädst du dann ins Rootverzeichnis deiner Installation zum FTP-Account hoch. Danach entpackst du in der Konsole dermassen.

unzip core.zip

Falls deine Installation sich im Unterverzeichnis befindet, wechsele dorthin mit dem Befehl “cd mein unterverzeichnis”. Von dort aus aus dem Rootverzeichnis heraus sind die Befehle auszuführen.

Lösche das ZIP-Archiv hinterher so.

rm -rf core.zip

Bevor du entpackst, sichere deine MySQL-Datenbank, nur für den Fall der eventuellen Fälle. Nachdem Entpacken loggst du dich im Backend deines Backdrop CMS Blogs ein und gehst zum Statusbericht, um von dort aus das Datenbank-Update zu erledigen. Das wird dir angezeigt und du machst ein Update. Ebenfalls sind die Updates der Module und Themes vorzunehmen. Das kannst du aus dem Statusbericht heraus ebenfalls erledigen.

Bei mir hat das Upgrade gut geklappt und anschliessend war alles ok, soweit ich es sichten konnte. Natürlich muss man sich noch mehr umschauen und alle Optionen durchgehen. Das geschieht erst wieder, wenn ich im Backdrop CMS bloggen werde.

Nun, das war das Upgrade auf Backdrop 1.6.1 CMS und bei Fragen kommentiere hier drunter. Ich denke, ich kann dir da helfen, seien es die Kommandozeile oder das Update selbst.

by Alexander Liebrecht

P.S. auch wenn mein Vater zur Zeit vermisst wird, muss ich online etwas machen und mich ablenken. Hoffnung, dass er lebend gefunden wird, schwindet mit jedem Tag.

 

 

Neue Flarum Erweiterung – Best Answer – Beste Antwort unter dem Forum-Post

flarum-erweiterung-beste-antwort-im-frontend-im-forum-internetblogger-de

Hallo lieber Leser und CMS-Nutzer! Nun, ich hoffe, dass du dennoch gerne hier bist, da ich doch gestern das Blog hier auf den Kopf stellte. Ein woocommerce-fähiges Theme musste her und so fand ich das offizielle Theme, installierte es, es ist sogar responsive. Was will ich da noch mehr.

Aber jetzt gleich zum Wesentlichen dieses Blogposts, denn es geht um eine neue Flarum Extension namens “Best Answer“. Zu Deutsch wäre das “Beste Anwort”.

 

Diese Flarum Erweiterung läuft auf der letzten Flarum-Version bei mir unter http://flarum.internetblogger.de bestens. Aber leider ist diese Erweiterung nicht ins Deutsche übersetzt, sodass es beim Deutschen im Flarum-Forum etwas heikel ist. Die Funktion der Erweiterung ist zwar gegeben, doch im Frontend ist der Link für Best Answer auf Englisch und dann noch so code-tag-mässig.

Flarumboard.de Forum-Startseite
Flarum-Forum im Frontend

Ich habe mein Flarum-Forum gleich auf Englisch umgestellt und sah es mir an. Funktioniert alles bestens und die Best Answer konnte ich verfassen.

Installation der Flarum-Extension “Best Answer”

Das ist wieder mal mit der Kommandozeile und schaue dir erst noch die Erweiterung offiziellerseits unter https://discuss.flarum.org/d/3868-select-post-best-answer an.

Du nimmst den SSH-Zugang, loggst dich in der Konsole mit Putty, Bitvise oder einem anderen SSH-Client ein und navigierst zum Rootverzeichnis deines Flarum-Boards. Wenn du ins Unterverzeichnis wechseln musst, nutze den Befehl: “cd meinverzeichnis”. Das wird helfen.

Danach vom Rootverzeichnis aus führst du den unteren SSH-Befehl aus. Dieser lautet dermassen.

php composer.phar require wiwatsrt/flarum-ext-best-answer

Composer muss vorher installiert sein und noch solltest du wissen, dass dir die Konsolen-Kenntnisse in der Flarum-Handhabung nicht schaden werden.

Als Nächstes loggst du dich im Flarum-Backend als Admin ein und gehst zu den Extensions/Erweiterungen, installierst diese Erweiterung. Screenshot-technisch schaut es in den Extensions so aus.

flarum-erweiterung-installation-best-answers-beste-antwort
Ansicht mit den Flarum-Erweiterungen im Forum-Backend

Siehst du “Best Answer” auf dem Bildchen? Denke ja. Es also installieren und im Forum-Frontend kannst bei einem der Forum-Posts eine Antwort verfassen. Sie kannst du dann via einen kleinen Link als “Beste Antwort” auszeichnen. Es wird dann unter dem jeweiligen Forum-Post hervorgehoben. Live kannst du es dir bei mir im Flarum-Forum unter http://flarum.internetblogger.de/d/188-mein-neues-cms-installation-service-durch-internetblogger-de mal genauer ansehen.

Das wäre die ganze Hexerei bei der Flarum-Erweiterung “Best Answer”.

Update der Flarum-Extension “Best Answer”

Soweit ich es weiss, musst du nur den Composer updaten, was so geht.

php composer.phar update

Lösche gleich nach der Installation der Erweiterung den Flarum-Cache, was so funktioniert. Im Rootverzeichnis in der Kommandozeile führst du diesen SSH-Befehl aus.

php flarum cache:clear

Das wird ausreichen.

Hattest du dieses Tutorial nachvollziehen können?

Ich hoffe, dass du diesem Flarum-Erweiterung-Tutorial folgen konntest und bei Fragen hierzu, feedbacke hier in den Kommentaren.

Da ich in meinem Flarum-Forum ganz allein bin, werde ich das kaum nutzen. Bei grösseren und wachsenden Communitys käme diese Extension eher in Frage.

Übrigens wandte ich mich heute an das Flarum-Support-Forum und fragte danach, wie ich alle Forum-Kategorien im Forum-Index anzeigen lassen kann. Bisher sind es nur ein paar Tags gewesen, aber ich möchte alles anzeigen lassen. Das ist machbar, soweit ich es weiss.

Freue mich auf dein Feedback zur Flarum-Extension “Best Answer – beste Antwort”.

by Alexander Liebrecht

5 nützliche Flarum-Forum-Erweiterungen und ihre Installation

flarum-forum-frontend-internetblogger-de

Hallo lieber Leser! In diesem Blogpost möchte ich mich wieder dem Flarum-Forum und 5 nützlichen Flarum-Erweiterungen widmen. Flarum-Erweiterungen werden im Terminal und mithilfe von Composer installiert.

Hier im Blog habe ich mich bereits in der Vergangenheit zu einigen Flarum Extensions geäussert. In diesem Post möchte ich es etwas zusammenfassen. Auch werde ich die dementsprechenden SSH-Befehle für die Installation verraten.

Flarum Erweiterung Summarys – Forumpost-Anleser auf der Diskussionsseite

Mit dieser Extension ermöglichst du im Flarum-Forum die Anleser deiner Forum-Posts auf der Diskussionsseite. Es macht schon noch etwas her und so kann der Forumleser sich einen ersten Überblick verschaffen.

flarum-forum-forumpost-teaser-extension-summarys-internetblogger-de
Flarum-Forum: Extension “Summary” mit Forumpost-Anlesern auf der Diskussionsseite

Diese Summarys-Erweiterung wird mit diesem SSH-Befehl installiert.

php composer.phar require jordanjay29/flarum-ext-summaries

Den SSH-Befehl führst du in der Kommandozeile im Rootverzeichnis aus. Falls bei dir der Composer noch nicht installiert ist, musst du es im Vorfeld machen. Da du aber diese Inhalte hier fandest und Flarum nutzt, denke ich mal, dass der Composer dir bereits bekannt ist.

Diese Flarum-Erweiterung kannst offiziellerseits unter https://discuss.flarum.org/d/2151-summaries-showing-excerpts-on-discussions-page verfolgen. Zudem müsste es dazu noch ein GitHub-Repository geben.

Nun zu der zweiten nützlichen Flarum-Forum-Erweiterung namens “Links”.

Flarum-Forum-Erweiterung “Links”

Diese Flarum-Erweiterung macht die Anzeige der Links im Forum-Header möglich. Das schaut auf dem Screenshot dermassen aus.

flarum-forum-links-header-extension-links-internetblogger-de
Flarum-Forum: >> Extension “Links” und eingebundene Links im Forum-Header

Diese Flarum-Extension wird mit dem SSH-Befehl installiert.

php composer.phar require sijad/flarum-ext-links

Ebenfalls im Rootverzeichnis in der Kommandozeile ausführen. Danach aktivierst du die Links-Erweiterung im Flarum-Backend unter Erweiterungen.

[dropcap size=”5″]D[/dropcap]u solltest noch die Erweiterung “Pages” nutzen. So kannst du im Flarum-Forum ein paar neue statische Seiten anlegen und verlinkst diese mittels Links im Forum-Header. Aber achte darauf, dass sehr viele Header-Links kann das Forum nicht aufnehmen, denn dann rutscht die Suchmaske nach unten und würde im Falle der Adsense im Header auf dem Adsense-Banner sein.

Im offiziellen Flarum-Support-Forum wäre diese Erweiterung unter https://discuss.flarum.org/d/2230-links. Auf der ToDo-Liste der Erweiterung stehen noch die Berechtigungen und das Erstellen von Untermenüs. Wenn das soweit ist, kannst du auch eine Menünavigation mit Links realisieren. Ich verfolge das mal für dich.

Jetzt komme ich zur Flarum-Erweiterung “Pages”.

Flarum-Forum-Erweiterung Pages

Diese Erweiterung macht statische Seiten im Flarum-Forum möglich. Solche Seiten kannst mit der anderen Extension namens Links im Forum-Header verlinken. Im Frontend schaut es so aus.

flarum-forum-extension-pages-statische-seiten-im-forum-internetblogger-de
Flarum-Forum: >> Extension Pages für statische Seiten im Forum. Solche Seiten kannst mit der Extension “Links” im Header verlinken.

Installiert wird diese Erweiterung durch diesen SSH-Befehl.

php composer.phar require sijad/flarum-ext-pages

Die Optionen, falls es welche gibt, findest du im Flarum-Backend links unter Erweiterungen. Pages werden in der Auszeichnungssprache Markdown erstellt. HTML habe ich, glaube ich jetzt zu wissen, auch sichten können. Das müsste eine Checkbox dafür da sein. Schaue es dir einfach an, ansonsten bleibt dir nur Markdown, wie beim Flarum Forum so üblich ist.

Zur dieser Flarum-Pages-Erweiterung gibt es diesen offiziellen Forum-Thread unter https://discuss.flarum.org/d/2605-pages. Du findest dort ein paar andere Infos wie die ToDo-Liste der Erweiterung.

Jetzt komme ich zu der Flarum-Erweiterung “Signature”, was eine Forumsignatur möglich machen wird.

Flarum-Erweiterung Signature

Im Frontend sieht die Forum-Signatur in etwa so aus.

flarum-extension-signatur-installation-internetblogger-de
Flarum, Erweiterung “Signature” im Frontend. Du kannst deine Links einfügen und ein paar Details zu deiner Person.

Diese Flarum-Erweiterung wird so installiert.

php composer.phar require xengine/flarum-ext-signature

Diesen SSH-Befehl führst du wie gehabt vom Rootverzeichnis aus aus. Die Einstellungen der Erweiterungen müssten im Forum-Profil zu finden sein und dort kannst du deine Forum-Signatur auch erstellen.

[dropcap size=”5″]I[/dropcap]ch konnte bei mir ein paar Links zu eigenen Seiten und Blogs unterbringen und habe ein paar Worte zu meiner Wenigkeit gesagt. Signatur-Links scheinen sogar doFollow zu sein, was aber nicht zwingend notwendig ist.

Den offiziellen Forum-Thread zu der Signature-Erweiterung gibt es unter https://discuss.flarum.org/d/4222-signature-extension. Dort kannst du nach Support verlangen oder einfach deine Anregungen bzgl. der Flarum-Erweiterung mitteilen. Ich wende mich eher selten an den Flarum-Support, weil bisher alles gut gelaufen war.

Wenn nichts mehr geht, muss ich das auch machen.

Nun komme ich zu der letzten Flarum-Erweiterung dieses Blogposts und das ist Adsense im Flarum-Forum.

Flarum-Extension Ads und ihre Installation

Google Adsense siehst du bei mir im Flarum-Forum unter http://flarum.internetblogger.de. Den passenden Forum-Thread dazu gibt es zur Zeit unter https://discuss.flarum.org/d/4785-flagrow-ads-bombarding-your-users-with-ads-everywhere-if-you-want. Dort gibt es auch den Support für diese Erweiterung.

Ich lasse im Flarum-Forum Adsense im Forum-Header, unter den Kategorien in der linken Sidebar und zwischen den Forum-Topics anzeigen. Das kannst du alles in den Erweiterungseinstellungen einstellen.

Installiert wird diese Flarum-Extension mit diesem SSH-Befehl.

php composer.phar require flagrow/ads

Diesen Befehl auch im Rootverzeichnis in der Kommandozeile ausführen. Es wird etwas dauern, falls du auf deiner Forum-Domain noch nie Adsense schalten liess. Aber gedulde dich, stelle diese Adsense-Extension ein und poste ein bisschen im Forum herum.

Nach etlicher Zeit wird Google Adsense überall angezeigt.

Nachdem du die Adsense-Codes in den Extension-Optionen eingebunden hast, lösche den Flarum-Cache mit diesem SSH-Befehl.

php flarum cache:clear

Den SSH-Befehl führst du ebenfalls im Rootverzeichnis in der Kommandozeile aus.

Das waren die Flarum-Erweiterungen, die ich dir gerne zeigen wollte. Sie alle werden in der Kommandozeile installiert und vom Rootverzeichnis aus. Wenn du ein paar Extensions installiert hast, lösche dann mal den Flarum-Cache mit dem obigen SSH-Befehl. Stelle diese Extension dementsprechend ein, wenn Optionen unter Erweiterungen im Backend vorhanden sind.

Mit Google Adsense Einblendungen wird es etwas dauern, aber nur nicht verzweifeln. Es wird alles nach einer Zeit angezeigt.

Fazit zu den Flarum Extensions wie Summarys, Pages, Links, Ads und Signature

Wenn es um das Erweitern meiner Foren geht, so bin ich immer fleissig dabei. Natürlich musst du alle Plugins, Addons und Extensions nach und nach updaten. Wenn du aber weisst wie das funktioniert, machst du das nebenbei.

Falls du Fragen zur Kommandozeile und der Installation dieser Flarum-Erweiterungen hast, nutze bitte hier die Kommentare.

Ansonsten dir viel Erfolg beim Installieren der gebrachten Extensions.

by Alexander Liebrecht

 

 

Flarum-Forum: Sitemap-Erweiterung installieren – wie geht das?

flarum-forum-sitemap-extension-sitemap-xml-im-frontend

Hallo lieber Leser! Wie findest du eigentlich die Flarum-Forum-Lösung? Zugegeben, die Arbeit damit geht mit Composer und der Kommandozeile, aber falls du dich damit auskennst und/oder es gerne lernen möchtest, hast du ein cooles und modernes Forum mit allerhand Erweiterungen.

In diesem Blogpost handelt es sich von der Flarum-Forum-Erweiterung “Sitemap”.

 

Ich habe es für dich vor diesem Bericht getestet. Diese Sitemap nach der Installation der Erweiterung ist unter /sitemap.xml verfügbar. So kannst du es später in der Google Search Console einreichen. Aber eins nach dem anderen. Wie installierst du diese Sitemap-Erweiterung?

Flarum-Sitemap-Installation

Ich beziehe mich dabei auf den ursprünglichen Forum-Post unter https://discuss.flarum.org/d/3688-flarum-sitemap-generator. Dort kannst du dir noch mehr Details zu dieser Erweiterung ansehen.

flarum-forum-sitemap-extension-im-flarum-backend-unter-erweiterungen
Flarum-Forum: Sitemap-Erweiterung im Backend unter Erweiterungen

Installiert wird im Terminal mittels SSH und diesem SSH-Befehl.

php composer.phar require terabin/flarum-ext-sitemap

Diesen SSH-Befehl führst du vom Rootverzeichnis aus aus. Damit du mit Composer auf deinem Shared Webhosting arbeiten kannst, muss diese phar-Extension bei dir installiert sein. Erst dann kannst du den Composer im Rootverzeichnis installieren und erst dann lässt sich allerhand Software aufsetzen und updaten.

Frage deinen Webhoster nach der PHP-Extension “phar” und falls nicht installiert, bitte um eine Installation. Das geht sehr schnell und ab dann kannst du mit Flarum super herumwerkeln.

flarum-forum-im-frontend-startseite-internetblogger-de
Flarum-Forum im Frontend auf der Forum-Startseite

Zurück zum obigen SSH-Befehl. Du führst es in der Kommandozeile aus und dann begibst du dich zum Flarum-Backend und aktivierst die Sitemap-Extension. Unter /sitemap.xml kannst du anschliessend im Browser checken, ob die Sitemap angezeigt wird. Sie trägst du dann einfach in der Search Console ein.

Bei mir wurden binnen 24 Stunden alle 184 Forum-Threads übermittelt.

 

Wie kannst du Composer oder eine bestimmte Flarum-Erweiterung in der Konsole updaten?

Composer-Update geht immer von dem Verzeichnis aus, wo die Datei composer.phar ist und das geht dann so.

php composer.phar update
flarum-sitemap-extension-installation-update-per-kommandozeile
Flarum-Forum: >> Sitemap-Extension in der Kommandozeile via SSH updaten

Alle Details, die in der Datei composer.json hinterlegt sind, wirken sich auf das Composer-Update aus. Manchmal muss man von Hand in dieser Datei etwas anders machen, damit du keine Fehler im Forum-Frontend hast. Aber das ist eher selten.

Sitemap-Extension-Update mittels SSH

Dazu nimmst du diesen Befehl.

php composer.phar update terabin/flarum-ext-sitemap

Das waren so die Sachen, die du beachten kannst. Falls du mit Composer und Konsole nicht weiter kommst, frage mich hier einfach um Rat. Ich arbeite mit der Kommandozeile täglich.

Fazit zu der Flarum-Sitemap-Extension

Sie ist nützlich und der Entwickler dieser Erweiterung berichtete im dortigen Forum-Post, dass er übelst viele Forum-Topics hat und alles hat funktioniert.

Auf der ToDo-Liste der Extension stehen noch solche Sachen wie das Mitteilen der Sitemap den Suchmaschinen, Eingabe der Details der Sitemap im Flarum-Backend und einiges andere.

Daher bleibe auf die Sitemap-Erweiterungsentwicklung gespannt.

Ich freue mich auch auf dein Feedback, falls du ein Flarum-Forum-Besitzer bist.

by Alexander Liebrecht

 

Flarum-Forum: Google Adsense Extension erschienen und Integration der Ads

flarum-forum-google-adsense-integrieren-internetblogger-de

Hallo lieber Leser! Heute finde ich wieder Zeit, um hier etwas zu bloggen. Mir geht es bei diesem Blogpost um die neue Flarum-Erweiterung, mit der du Google Adsense ins Forum packen kannst.

Diese Flarum-Extension befindet sich auf GitHub und zudem findest du Infos darüber unter https://discuss.flarum.org/d/4785-flagrow-ads-bombarding-your-users-with-ads-everywhere-if-you-want.

Etwas Forum-Vermarktung ist nicht ganz verkehrt, wenn es jemand haben möchte. Eine lange Zeit gab es beim Flarum-Forum dafür kein passendes Werkzeug und keine einzige Erweiterung. Doch seit ein paar Tagen ist das ganz anders und diese Ads-Extension erblickte die Welt.

Installation von Flarum Ads Extension

Du installierst diese Adsense-Erweiterung mittels Terminal und Composer. Installiere dir auf einem Windows OS ein kostenloses Tool namens Bitvise und damit solltest du eh immer arbeiten. Es tut, was es soll. Also das Tool installieren und du loggst dich dann in Bitvise mit deinen SSH-Daten ein.

SSH-Zugang dürften die meisten Webhoster von Haus aus anbieten, so auch bei Hetzner, Serverprofis, All-inkl, Strato und dem Rest der deutschen Webhoster-Elite. So würde ich das denken. Diese hier erwähnten Webhoster haben SSH in jedem Falle.

Du bist dann in der Kommandozeile im Rootverzeichnis und falls dein Flarum-Forum im Unterverzeichnis, wechselst du dorthin mit “cd verzeichnis”.

Danach führst du den unteren SSH-Befehl aus.

php composer.phar require flagrow/ads

Zudem solltest du noch den Composer selbst updaten, was so geht.

php composer.phar update

Diese Ads-Erweiterung kannst du auch mittels Composer dermassen updaten.

php composer.phar update flagrow/ads

Nach der Composer-Extension-Installation

Danach gehst du zum Admin-Sektor im Flarum-Backend und aktivierst diese Extension. Das dürfte dann klappen und links in der Seitenleiste erscheint ein neuer Bereich namens “Ads”. Dorthin musst du und dahinter fügst du die Codes mit Google Adsense dementsprechend ein.

Zuoberst, was so aussieht…

flarum-forum-google-adsense-extension-backend
Adsense-Erweiterung beim Flarum-Forum im Backend, da wo du Adsense einfügen kannst

….kannst du bestimmen mit einer bestimmten Zahl, nach welchem Forum-Post Adsense zwischen den Posts angezeigt wird. Ich habe es bei einer “1”, weil ich alleine im Forum berichte und auch meine Threads bestehen meistens aus ein paar Topics, nicht mehr.

Dann gibt es die Header-Position für Adsense und noch unter den Forum-Tags, den Kategorien, im Frontend auf der linken Seite. Wie das live aussieht, sieh dir bei mir im Flarum-Board unter http://flarum.internetblogger.de mal an.

Ads-Erweiterung ist mal ganz hilfreich

Falls es bei dir eine wachsende Community ist, wirst du durch Adsense auch etwas einnehmen. Ich teste es bei mir noch und belasse es dann dabei dauerhaft. Auch ist es bei Google Adsense so, dass dir meistens relevante Werbung angezeigt wird. Dein Forum wird erst durch Google abgescannt und das was dabei herauskommt, macht dann die Ads auch aus.

CookieBar ist Pflicht bei Adsense

Das ist die zweite Sache, was du dann auch umsetzen musst. Den Code für die CookieBar platzierst du im HTML-Text-Feld unter “Erscheinungsbild” im Backend. Dort gibt es ein Textfeld mit der individuellen Kopfzeile im Forum. Platziere dort den CookieBar-Code und dann, wenn du all das, was hier steht, gemacht hast, lösche den Flarum-Cache mit diesem SSH-Befehl.

php flarum cache:clear

Das führst du im Terminal vom Rootverzeichnis aus aus.

Ich denke, dass du dieses Tutorial nachvollziehen kannst. Aber natürlich musst du wissen, dass es alles mit Composer und dem Terminal ist. Flarum arbeitet damit und lässt sich im Handumdrehen in der Konsole updaten. Flarum-Cache kannst du mittels Konsole löschen und auch alle Erweiterungen installieren.

Falls du Fragen zur Kommandozeile und Flarum hast, immer raus damit. Alles, was ich selbst schon weiss, verrate ich es dir.

Freue mich auf dein sinnvolles Feedback.

by Alexander Liebrecht

 

 

Tikiwiki 16.2 online verfügbar – wichtiges Sicherheitsupdate

tikiwiki-16-2-online-neue-funktionen-verbesserungen-und-mehr-internetblogger-de

Hallo lieber Leser! Ich hoffe, dass du aktuelle Inhalte hier im Blog nicht vermisst hast, denn ich war fast die ganze Woche krank geschrieben und konnte kaum etwas machen. Aber heute geht es mir viel besser und hier kommt gleich ein kurzer Bericht zu der neuen TikiWiki-Version 16.2.

 

TikiWiki 16.2 online verfügbar

Es ist die neue TikiWiki-Version 16.2 und zugleich ein sehr wichtiges Sicherheitsupdate, wie du das unter https://doc.tiki.org/Tiki16#Tiki_16.2 entnehmen kannst. Daher ist jeder Tiki-User dazu angehalten, ein Update zu vollbringen. Wir machen es aber hier zusammen, damit du weisst, wie das zu machen ist.

Wie grade ich auf TikiWiki 16.2 up?

Du lädst dir die letzte TikiWiki-Version von https://sourceforge.net herunter, entpackst es lokal und packst den Inhalt zum ZIP-Archiv namens tiki.zip.

Das muss ins Rootverzeichnis deiner Tiki-Installation hochgeladen werden. Danach kannst du das ZIP-Archiv in der Konsole so entpacken.

unzip tiki.zip

Sichere bitte vorher noch die MySQL-Datenbank, nur für den Fall der eventuelle Fälle und um auf Nummer sicher zu gehen.

Dann alles entpacken und hinterher löschst du das Archiv wieder dermassen.

rm -rf tiki.zip

Du loggst dich im Control Panels deiner TikiWiki-Installation im Browser ein und falls die Datenbank upgedatet werden musst, wird dir dort der dementsprechende SSH-Befehl für die Kommandozeile angezeigt. Dieses Mal war es nicht der Fall, denn ich denke, dass an der Datenbank nichts geändert wurde.

Das wäre dann dein Upgrade auf TikiWiki 16.2. Mehr musst du nicht machen. Nun erzähle ich dir noch etwas darüber, was alles neu beim TikiWiki 16.2 ist.

Neue Funktionen beim TikiWiki 16.0/16.2

Ab dem TikiWiki 16.0 wird dringend PHP 5.6 benötigt. Frage deinen Webhoster nach der Umstellung oder oft ist es möglich, durch einen dementsprechenden Eintrag in der sich im Rootverzeichnis befindlichen .htaccess-Datei, umzustellen. Die nötige Regel dafür hat meistens dein Webhoster in den Anleitungen hinterlegt.

tikiwiki-frontend-internetblogger-de
TikiWiki im Frontend im Browser

Mein Portfolio ist zum grössten Teil auf dem Managed Server bei All-inkl. und da habe ich PHP 5.5 als Standard. Hier auf der Domain ist aber PHP 7.0 aktiviert, sodass Internetblogger.de und alle Subdomains bzw. Unterverzeichnisse in dessen Genuss kommen können.

Beim neuen TikiWiki können auch Gäste die Kommentare per Mail abonnieren. Es ist aber weiterhin so, dass deine Webseite in den Kommentaren nicht verlinkt wird. Aber im Modul letzte Kommentare in der Sidebar wird es verlinkt. Das sorgt etwas für die gegenseitige Vernetzung und alle haben etwas davon.

tikiwiki-kommentare-spam-schutz-mit-recaptcha-email-abo-internetblogger-de
TikiWiki-Kommentare im Frontend mit Spam-Schutz durch ReCaptcha und dem Mail-Abo für Comments

Einige Libraries wurden upgegradet

Im Beitragsbild zuoberst wird dir angezeigt, welche Libraries einem Update unterzogen wurden. Auch wurde verbessert die Tatsache mit den erweiterten Funktionen im Control Panels. Wenn du dich im Control Panels eingeloggt hast, kannst du besser umswitschen.

Wenn dort “advanced” eingestellt ist, bekommst du wesentlich mehr Funktionen angezeigt und kannst auch im Control Panels danach suchen. Das zeige ich dir hier auf dem unteren Screenshot.

tikiwiki-16-2-control-panels-option-advanced-internetblogger-de
TikiWiki 16.2 im Control Panels. Siehst du zuoberst die Einstellung “Advanced”?

Auch gab es Neues bei den Wiki-Plugin im TikiWiki. Ich habe mal einen Screenshot aus der offiziellen englischsprachigen Doku gemacht und das schaut dermassen aus. Im Prinzip findest du alle Änderungen und Verbesserungen in TikiWiki 16.2 in dieser Dokumentation.

Hier der Screenshot.

tikiwiki-16-2-wiki-plugins-verbesserungen-internetblogger-de
TikiWiki 16.2 >> Verbesserungen bei den Wiki-Plugins

Tracker bekam etliches Neues

Im Tracker wurde vieles verbessert laut der offiziellen Dokumentation. Den Tracker nutze ich selbst bei mir unter https://internetblogger.de/tikiwiki eher nicht, aber wenn jemand im Team im TikiWiki arbeitet, wird es sicherlich zu schätzen wissen.

tikiwiki-16.2-tracker-einstellungen-und-funktionen-im-control-panels-internetblogger-de
TikiWiki 16.2 >> Tracker-Einstellungen und Funktionen im Control Panels

Der TikiWiki ist eine klasse OpenSource Wiki-Lösung mit allerhand Funktionen, den Modulen, dem Blog, den Artikeln, dem Forum, dem Wiki und nützlichen Plugins.

Du findest in meiner TikiWiki-Installation all das, womit ich zu tun habe und auch arbeite. Feedback bekomme ich dort eher selten, denn dafür musst du den TikiWiki im Vorfeld sehr populär machen und dort regelmässig beigehen. Ich beposte es nur ab und an, meistens bei neuen Updates oder dergleichen.

Mein Fazit zu TikiWiki 16.2

Den TikiWiki-Entwicklern war es wieder mal gut gelungen, alle Neuerungen zu integrieren. Wie du dem obigen Post entnehmen kannst, ist das Update nicht so tragisch, muss aber gemacht werden. Die Handhabung des TikiWikis kann nach einer ganzen Weile erlernt werden.

Damit kannst du gut bloggen oder du setzt das Forum als Startseite. Das ist auch machbar. Zudem ist noch der Wiki selbst nicht zu unterschätzen. Der Tracker rundet das Ganze noch etwas ab und auch die User-Registrierungen sind an Bord.

Ich kann den TikiWiki 16.2 mit BlueSpice MediaWiki gleichsetzen und vermutlich ist es sogar etwas besser, weil extrem viele Funktionen.

Wie ist es bei dir mit dem TikiWiki? Welche Version ist bei dir so im Einsatz und was konntest du schon alles beim Tiki erlernen?

Freue mich auf dein Feedback hier drunter und bei Fragen zum Upgrade wende dich hier an mich.

by Alexander Liebrecht

Bildquellen by Alexander Liebrecht via https://internetblogger.de/tikiwiki

 

B2evolution CMS 6.8.5 online verfügbar – Behebungen in Sicherheit und in Fehlern

b2evolution-cms-im-backoffice-version-6-8-5

Hallo lieber Leser! Am Sonntag zu bloggen, hat auch etwas und bei vielen BloggerInnen steht es auf dem Redaktionsplan, welchen ich so nicht habe. Ich blogge wie es mir meine Freizeit erlaubt. Heute funktioniert das und ich möchte dich auf die neue B2evolution CMS Version 6.8.5 aufmerksam machen.

Das war erst vor kurzem nach draussen gelassen. In der Regel erscheinen Updates von diesem OpenSource CMS monatlich, nicht aber die letzten drei Updates. Sie sind nacheinander in kürzeren Zeitabständen erschienen.

 

Worum geht es bei B2evolution 6.8.5

Bei diesen drei letzten Updates war mitunter die Sicherheit gewährleistet, die extrem wichtig in der Welt der OpenSource Software ist. Also haben die Entwickler Sicherheitslücken geschlossen, was den Nutzern zugute kommt.

Auch wurde an der Performance geschraubt. Jetzt kannst du im FrontOffice Anhänge hinzufügen. Im BackOffice beim Erstellen der Blogposts kannst du Bilder hinzufügen, ohne dass du den Post zwischenspeichern musst. Das muss ich testen, sollte aber schon funktionieren.

Und zuallerletzt waren es etliche Fehlerbehebungen, die du bei jedem B2evolution-Update haben kannst. Dieses CMS wird immer einen Stück verbessert sowie nach vorne gebracht.

Nun zeige ich dir noch einmal, was beim Update zu tun ist.

Wie grade ich auf B2evolution 6.8.5 up?

Einige Stammleser von Internetblogger.de bekamen so etwas bereits mit und für die neuen Leser verblogge ich solche Themen immer mal wieder.

Du musst die neue B2evolution-Version von http://b2evolution.net/downloads/6-8-5 downloaden, es lokal entpacken. Den Inhalt packst du zum ZIP-Archiv namens bevo.zip und lädst es ins Rootverzeichnis hoch. Beim Packen achte darauf, dass die Datei .htaccess links liegen gelassen wird. Sie hast du bereits im FTP-Account und wir wollen sie auch nicht überschreiben.

Auch solltest du vorher die MySQL-Datenbank backupen, nur für den Fall der Fälle. Nachdem alles gemacht wurde, navigierst du im Browser zu /install und widmest dich dem Upgrade-Script. Das wird dann fast selbsterklärend sein und du stösst das Update an.

Hinweise zum Entpacken in der Kommandozeile

Mit diesem SSH-Befehl entpackst du.

unzip bevo.zip

So löschst du das Archiv wieder.

rm -rf bevo.zip

Das kannst du dir mal einprägen, weil du es immer wieder brauchen wirst.

Das wäre eigentlich das ganze Upgrade und du loggst dich aus dem Upgrade-Script heraus im BackOffice ein und checkst zuunterst die aktuelle B2evolution-Version. Es wird mit 6.8.5 hinterlegt sein. Das wäre alles, was dir hier heute und jetzt vermittelt werden sollte.

Ich werde noch die Neuerungen unter die Lupe nehmen

Das mache ich dann, wenn ich es mit dem Bloggen im B2evolution-Blog unter http://alexliebrecht.com/blogs wieder fortsetze. Dann schaue ich mir insbesondere den Upload eines Bildes beim Bloggen an.

Falls du Fragen zum Kommandozeilen-Update hast oder dir nicht sicher bist, wie du das Upgraden genau anstellen kannst, nutze dafür bitte die Kommentare hier drunter.

Dir sei noch viel Spass bei der Arbeit mit einem guten OpenSource CMS namens B2Evolution gewünscht.

by Alexander Liebrecht

 

Backdrop CMS 1.6.0 erschienen – Bugfixes und Verbesserungen + Features

backdropcms-1-6-0-online-bugfixes-verbesserungen-features-internetblogger-de

Hallo lieber Leser! Es geht hier jetzt um das Backdrop CMS. Es ist nämlich ein grosses Update dieses OpenSource CMS, die Version 1.6.0 erschienen. Das kannst du den Releases des offiziellen GitHub-Repositorys unter https://github.com/backdrop/backdrop/releases gerne entnehmen.

Das Update im eigenen Backdrop CMS Blog unter http://wpzweinull.ch/cms/backdrop machte ich gestern schon und alles hatte super geklappt.

Im Folgenden erzähle ich dir davon, wie das Update zu machen ist und auch etwas zu den neuen Bugfixes, Verbesserungen sowie den Features.

Backdrop CMS 1.6.0

Im GitHub-Repository in den Releases kannst du schon nachlesen, was alles dazu gekommen ist. Die Version 1.6.0 kommt sowohl den einfachen Backdrop CMS Usern als auch den Entwicklern zugute. Es sind etliche Fehlerbehebungen, Verbesserungen, Änderungen ermöglicht worden.

backdropcms-1-4-4--update-erfolgreich-internetblogger-de

Zudem haben sich die Backdrop CMS Developers auch neue Funktionen einfallen lassen. Zum Beispiel wurden zu den Kommentaren ein Template und ein Style hinzugefügt.

Änderungen in den Kommentaren und dem Content

[dropcap size=”5″]A[/dropcap]us “Admin Content” wurde “Manage Content” und aus “Comments” wurde “Manage Comments. Diese und viele weitere Änderungen gab es beim Backdrop CMS in der Version 1.6.0. Die vollständige Liste der Änderungen findest du hinter dem obigen Link zu den Github-Erscheinungen, den Releases.

backdropcms-1-6-0-manage-content-manage-comments-backend
Backdrop CMS: Manage Content und Manage Comments im Backend eingeloggt

Jetzt zeige ich es dir nochmals wie das Update vonstatten geht. Das ist nicht sehr kompliziert, sollte aber durchgeführt werden. Es kam viel Neues auf den Backdrop Nutzer zu.

Backdrop CMS auf die Version 1.6.0 updaten – wie geht das?

Auf GitHub aus den Releases lädst du die Version einfach mal herunter und entpackst es lokal. Dann  loggst du dich in deinem Backdrop CMS Blog schon einmal mit deinen Login-Daten ein. Das wird zum Updaten notwendig sein. Danach packst du das Verzeichnis /core zum ZIP-Archiv namens core.zip und lädst es zum FTP-Account ins Rootverzeichnis hoch.

Als Nächstes gilt es, wieder mit der Konsole zu arbeiten. Installiere dir das kostenlose Windows-Tool namens Bitvise, was dir zugleich SSH und SFTP machbar macht. Damit arbeite ich nur noch und täglich.

bitvise-kostenloses-windows-tools-für-ssh-und-sftp-unter-windows-7-64bit
Kostenloses SSH/SFTP-Windows-Tool namens Bitvise >> Das findest du schnell in Google, wenn du danach suchst 🙂

Entpacken des ZIP-Archivs in der Kommandozeile geht per diesen SSH-Befehl. Vorher bitte nochmals ein MySQL-Datenbank-Backup machen.

unzip core.zip

Löschen des Archivs geht dann so.

rm -rf core.zip

Nun kannst du im Browser, da du ja schon eingeloggt bist, dieses eintippen.

MeineDomain.de/core/update.php

Du aktualisierst deine Backdrop CMS Installation und anschliessend gehst du zum Statusbericht. Wenn noch weitere Updates vorliegend sind, alles updaten, was uptodaten ist. Es können durchaus noch Module und Themes sein.

backdropcms-1-6-0-statusbericht-im-backend-updates-werden-angezeigt
Im Statusbericht wird dir immer angezeigt, was zu aktualisieren ist. Bei jedem Update kannst du damit arbeiten.

Module und Themes musst du in den letzten Versionen von http://backdropcms.org, dort aus den Modules und Themes, herunterladen. Dann per FTP in die dementsprechenden Verzeichnisse wieder hochladen und die alten Inhalte mit den neuen überschreiben.

Dann dürfte dein Statusbericht im grünen Bereich sein und deine Backdrop CMS Installation ist dann vollständig uptodate.

Falls noch etwas ist im Statusbericht, schaue bitte danach und date alles up

Manchmal meckert der Statusbericht und versuche, alle offenen Aufgaben zu erledigen. Falls du dabei Hilfestellung benötigst, kann ich tätig werden, denn ich bin ein Member in der GitHub-Community von Backdrop CMS. Zudem kannst du auf GitHub im offiziellen Issue-Tracker deine Probleme zu den Issues bringen und dir schnell helfen lassen.

Das wäre auch möglich.

Nun komme ich zum Fazit.

Fazit zu Backdrop CMS 1.6.0

Die neue Version 1.6.0 ist sehr innovativ und macht deine Backdrop CMS Installation etwas besser. Es wurde viel ermöglicht, geändert, verbessert und neu kreiert, sodass es dir nur zugute kommen wird.

Du kannst das Ganze gerne noch auf GitHub, so wie ich, verfolgen und wärst dann immer uptodate. Auch kannst du Backdropcms.org etwas beobachten, denn nicht zu selten gibt es neue Module und Erscheinungen bei den Themes.

drupal7-blog-frontend
Drupal 7 Blog im Frontend

Alles in allem ist Backdrop CMS zwar ein  Drupal 7 Fork, wird aber stetig weiterentwickelt und stabil gehalten, das was wir Nutzer uns vorstellen.

Nun ein paar Fragen an dich.

[note note_color=”#7fff66″ radius=”0″]Welche Backdrop CMS Version hast du im Einsatz und warum datest du nicht auf 1.6.0 up? Wie sind deine Erfahrungen mit diesem OpenSource CMS und setzt du vielleicht schon Drupal 7 ein? >> es sind ähnliche CMS und wenn Drupal 7, dann ist der Einstieg in Backdrop CMS nicht so schwer.[/note]

[quote cite=”Alexander Liebrecht”]Freue mich auf dein sinnvolles Feedback und ggf. SocialMedia Signale. Zudem sei dir weiterhin viel Spass bei der Arbeit mit dem Backdrop CMS gewünscht.[/quote]

by Alexander Liebrecht

 

Neues CMS-Update: B2evolution 6.8.3 erschienen

b2evolution-cms-version-6-8-3-bugfixes-verbesserungen-internetblogger-de

Hallo lieber Leser! Ich kann dir sagen, dass diese Woche eine Woche der zahlreichen CMS-Updates bei mir ist und alles muss zeitnah installiert werden. Die Sicherheit des Managed Servers hat höchste Priorität und so tue ich das, was ich am besten kann, alles aktualisieren.

Bei diesem Blogpost geht es mir um die neue B2evolution CMS-Version 6.8.3, die erst vor kurzem die Welt erblickte.

Falls du hier ein Stammleser bist, weisst du bereits, was für eine Update-Anleitung gleich kommt. Aber falls du hier neu bist, führe ich dich an das Updaten des B2evolution CMS Systems langsam, aber sicher heran. Das Update wird nach mehrfachem Aktualisieren eine reine Routine-Geschichte sein.

Wie date ich auf B2evolution 6.8.3 up?

Hinweise und den Download der CMS-Software findest du auf GitHub unter https://github.com/b2evolution/b2evolution/releases. Dort die letzte B2evolution Version einfach herunterladen, lokal entpacken und den Inhalt zum ZIP-Archiv namens 683.zip packen.

Dieses Archiv muss ins Rootverzeichnis hochgeladen werden. Meine Sammlungen sind im FTP-Account unter /blogs und so musste ich in der Kommandozeile erst einmal zum Unterverzeichnis wechseln. Das geht immer mit dem SSH-Befehl “cd”. So schaute es meinerseits aus.

cd blogs

Danach entpackst du das ZIP-Archiv dermassen.

unzip 683.zip

Du wirst es ab dann nicht mehr benötigen und kannst es gleich wieder löschen.

rm -rf 683.zip

Nun bleibt dir nur noch das Updaten per Browser und das Updatescript ist immer unter /install. Tippe im Browser Meinedomain.de/install ein und schon darfst du dort das Upgrade nehmen. Du bleibst im Browser nicht mal eine ganze Minute und deine B2evolution-Installation wird schnell upgedatet.

B2evolution-Update ist nicht kompliziert

Nun wie du siehst, alles halb so tragisch, denn das Update ist wirklich einfach. Aus dem Update-Script heraus kannst du entweder zum Front-Office oder dem Back-Office gelangen. Gehe mal zum Back-Office und überzeuge dich von der neuen B2evolution-Version, die zuunterst auf der Seite angezeigt wird.

Das sollte es auch schon gewesen sein und du geniesst wieder die Arbeit in deinen B2evolution-Sammlungen wie dem einfachen Blog, dem Foto-Blog, dem Forum oder dem Handbuch.

Was tun bei schwerwiegenden Problemen?

In solchen Fällen kannst du den GitHub-Issue-Tracker darum bemühen und dein Anliegen dort posten. Oder wende dich an das englische Support-Forum von B2evolution. So oder so wird dir recht schnell geholfen. Speziell zu dieser Update-Anleitung kannst du mich hier in den Kommentaren gerne ausfragen, weil eben die Konsole gebraucht wird.

Ich kann mir kein CMS-Update mehr ohne das Terminal vorstellen. Es ist schnell getan und ich bin schneller fertig, verblogge das Thema hinterher schnell.

Zuallerletzt: Was gab es Neues bei B2evolution?

Es wurde etliches unter der Haube verbessert. Auch gab es einige Bugfixes/Fehlerbehebungen, sodass es deinen B2evolution-Onlineauftritt nur noch besser macht. Im Beitragsbild hier zuoberst zeige ich dir einen Teil der neuen Bugfixes sowie Änderungen noch einmal genau.

Ich komme nun zum Fazit dieses Blogposts.

Mein kurzes Fazit zum B2evolution 6.8.3 Update

Das Update muss vollbracht werden, denn Updates sind dafür da, um installiert zu werden. Bei diesem Update wird auch die Datenbank geändert, sodass du vorher ein Datenbank-Backup machen müsstest.

B2evolution CMS entwickelt sich rasant und gehört mit seinen Multiblogs zu einem sehr guten OpenSource CMS. Damit zu arbeiten, wird dir auf Deutsch möglich sein. Sammlungen zu erstellen, ist nicht so sehr schwer und ansonsten erkunde das Front-Office sowie das Back-Office.

Zum Schluss stelle ich dir noch diese paar Fragen.

Welche B2evolution-Version setzt du ein und falls es zu alt ist, was hält dich vom Updaten ab?

Freue mich auf dein sinnvolles Feedback in den Kommentaren.

by Alexander Liebrecht

 

MyBB 1.8.10 erschienen – Wartungsupdate

webmasterwelten-de-mybb-forum-im-frontend

Hallo lieber Leser! Über die OpenSource Forum Software namens MyBB gibt es etwas Neues zu hören und zu lesen. Die neue Version MyBB 1.8.10 erblickte gestern die Welt und das Update machte ich jetzt eben schon.

Du kannst dir diesen Informationen und Details zum Update unter https://www.mybb.de/forum/thread-34106.html gerne antun. Warum solltest du das Update auch installieren?

Weiterlesen

ImpressCMS 1.3.10 erschienen – wichtiges Sicherheitsupdate

impresscms-portal-frontend-wpzweinull-ch

Hallo lieber Leser! In diesem Blogpost geht es auch um OpenSource CMS und zwar wurde eine neue Version  des ImpressCMS 1.3.10 herausgebracht. Ich werde jetzt nicht lange drumherum reden und komme gleich zum Wesentlichen.

Die neue ImpressCMS Version 1.3.10 ist ein sehr wichtiges Sicherheitsupdate und du solltest diene ImpressCMS-Installation mal schnell einem Update unterziehen. Kurze Infos zum Update gibt es auf der offiziellen Webseite unter http://community.impresscms.org/modules/smartsection/item.php?itemid=703

Weiterlesen

PHPBB 3.2 Rhea erschienen – Verbesserungen, PHP 7.0-Support, Emojis und mehr

phpbb32-forum-frontend-im-topic-wpzweinull-ch-gepostet-auf-internetblogger-de

Hallo lieber Leser! Ich möchte einen kleinen Beitrag dazu leisten, dass meinerseits verwendete  OpenSource/Flat File CMS etwas bekannter werden. Aus diesem Grunde berichte ich darüber, so oft ich kann und auch portfolio-weit. Ich habe ja die Weiterentwicklung von PHPBB, der klasse OpenSource Forum Software, so gut es ging, verfolgt.

Gestern erschien die Version 3.2.0, wie du diesem Post im offiziellen deutschen PHPBB-Forum unter https://www.phpbb.de/community/viewtopic.php?f=9&t=238511 entnehmen kannst.  Da war meine Freude beim Updaten recht gross und das Update klappte gleich beim ersten Mal. Dazu erzähle ich dir im Folgenden etwas.

 

Wie funktionierte das Update auf PHPBB 3.2.0 Rhea

Ich hatte vorher die Version RC2, sodass das Updaten sehr leicht war. Derzeit gibt es im deutschen PHPBB-Support-Forum in den Downloads die neue Version noch nicht. Aber dafür kannst du es dir unter http://phpbb.com in den Downloads besorgen. Zudem hat PHPBB noch einige GitHub-Repositories, wo der Download bereits zur Verfügung steht.

Auf phpbb.com gibt es auch, denke ich mir mal, Updater, die aus drei Verzeichnissen wie vendor, install und noch einem Verzeichnis bestehen. Das kannst du nehmen oder du nimmst die Original-Version auf Englisch. Das Sprachpaket dazu nimmst du von PHPBB 3.1.10, was du im deutschen Support-Forum in den Downloads finden kannst.

Dann wird es wie gehabt sein.

Neue Version herunterladen, entpacken, zum ZIP-Archiv packen und hochladen

Das lädst du ins Rootverzeichnis hoch und entpackst mittels Terminal und diesem SSH-Befehl.

unzip phpbb.zip

Anschliessend kannst du das Archiv wieder so löschen.

rm -rf phpbb.zip

Nun musst du im Browser deiner Wahl zu /install gehen und findest dort den Reiter “Update” vor. Dahinter musst du gehen und das Aktualisieren ist dann nur noch mehrere Minuten dauernd. Ich musste dieses Mal nur die Datenbank updaten, weil die Verzeichnisse und Dateien im FTP-Account bereits nach dem Hochladen top aktuell waren.

So datete ich die Datenbank up und navigierte im Browser zum ACP meines PHPBB 3.2.0 Forums. Die neue Version wurde mir angezeigt und ich konnte mich zurücklehnen. Die Arbeit war getan und dann hatte ich es auch im Forum unter http://wpzweinull.ch/cms/phpbb32/phpbb-3-2-forum-f2/phpbb-3-2-rhea-erschienen-update-hinweise-neue-fun-t18.html#p24 gepostet. Das gilt für das Forum und falls dort jemand nach solchen Update-Inhalten suchen sollte.

Hier bei Internetblogger.de bist du eh nach dem Aufwachen uptodate und kannst dir im Laufe des Tages dein Forum vornehmen und das Update installieren. Auch solltest du darüber im Forum berichten bzw. darüber, ob du Probleme beim Updaten hattest oder was dir nicht zusagte, eben auch gefallen hatte.

Was sind die neuen Funktionen beim PHPBB 3.2.0 Rhea?

phpbb32-forum-frontend-forum-startseite-wpzweinull-ch-gepostet-auf-internetblogger-de
Startseite des PHPBB 3.2 Forums >> wpzweinull.ch/cms/phpbb32

Das hast du sicherlich schon dem Link von oben entnommen. Es wurden die Emojis möglich gemacht. Zudem bekam PHPBB 3.2 die volle Kompatibilität mit PHP 7.0/7.1. Auch wird das Template Subsilver2 nicht mehr weiterentwickelt und du musst du dich leider davon trennen ,falls es noch bei dir zum Einsatz kommt.

Unter der Haube wurde etwas verbessert und im Grossen und Ganzen ist das PHPBB 3.2 Forum ein Superschritt in die PHPBB-Zukunft. Im Übrigen achte darauf, dass du dein PHPBB 3.0 Forum mal ordentlich einem Upgrade unterziehst. Diese Forumversion wird schon bald nicht mehr supportet, sodass du nur noch die Versionen wie 3.1/3.2 hast.

phpbb32-forum-acp-im-backend-wpzweinull-ch-phpbb32-board
Im ACP des PHPBB 3.2 Forums – es schaut aus wie vorher, aber ein paar neue Funktionen sind hinzugekommen 🙂

Ich besitze zweierlei PHPBB-Foren, jeweils mit den Versionen 3.1 und 3.2. Das reicht zum Spielen, Erkunden und Testen. Mehr brauche ich nicht. Und was geschieht zur Zeit beim PHPBB-Fork namens phpBBex?

Etwas zu phpBBex, dem guten PHPBB-Fork

Hierzu kann ich dir das neue Support-Forum unter http://phpbbex.ru empfehlen, falls du des Russischen mächtig bist. Ansonsten bleibe hier ein Stammleser und wenn die neue phpBBex Version 3.0 erschienen ist, date ich mein Forum up und berichte hier ausführlich darüber.

phpbbex-forum-frontend
Forum-Frontend von phpBBex-Forum

Es wird schon bald dazu kommen und zudem hast du immer noch die Versionen wie phpBBex 1.9 und 2.0.4. Sie setze ich auch irgendwo ein.

Mich würde mal die neue Aufmachung von phpBBex 3.0 interessieren. Ob  es schon auf phpbbex.ru installiert ist, kann ich dir nicht sagen, schaut dort alles aber anders als auf phpbbex.com aus. Na, schauen wir mal. Ich halte dich darüber auf dem Laufenden.

Fazit zu PHPBB 3.2.0 Rhea

Du musst wissen, dass alte PHPBB-Versionen bald nicht mehr unterstützt werden. Setze auf PHPBB 3.1 bzw. 3.2 oder aktualisiere deine Forumversion. Erweiterungen von der Version 3.1 funktionieren zum grössten Teil auch in der Version 3.2. So waren meine bisherigen Erfahrungen.

In meinem PHPBB 3.2 Board habe ich etliche Extensions installiert und heute noch die Sidebar links im Frontend ermöglicht. Zudem monetarisiere ich das Forum etwas intensiver und ansonsten, freie Bahn zum Beposten des Boards. Ab und an bringe ich darin meine cms-blogger-lastigen Themen, um ein paar Leser uptodate zu halten.

Bekommst du Update-Probleme, schaue danach, es hier zu schildern. Unter Umständen kann ich dir beim Updaten sogar helfen. Wenn nichts mehr geht und ich nicht weiter weiss, kann dir die deutsche Support-Community unter http://phpbb.de bestimmt weiterhelfen. Dir viel Spass mit dem Forum in der neuen 3.2er Version.

Freue mich auf dein Feedback oder Anregungen.

by Alexander Liebrecht

Drupal 8.2.5 online verfügbar – Fehlerbehebungen

drupal-8.1.8-im-frontend-blog-startseite

Hallo lieber Leser!  Es geht dann hier mit den OpenSource CMS gerne weiter. CMS-Updates muss ich oft genug installieren und in diesem Falle war Drupal 8.2.5 erschienen. Das entnimmst du der Quelle unter https://www.drupal.org/project/drupal/releases/8.2.5.

Die neue Drupal-Version habe ich bereits unter http://wpshopde.de installiert und im Folgenden erzähle ich dir, wie du das Update anstellen kannst.

Falls du ein Stammleser hier im Blog bist und meine CMS-Update-Tutorien bereits kennst, wirst du wissen, worauf es ankommt. Aber da ich hier bei Internetblogger.de täglich mehr neue Leser als wiederkehrende habe, möchte ich immer mal wieder auf die einzelnen CMS-Updates detailliert eingehen.

Drupal 8.2.5-Update installieren – Wie geht das?

Du schaust hinter der oben erwähnten Quelle auf der offiziellen Drupal-Webseite nach dem Download, lädst es herunter und entpackst es lokal. Da wir es hier mit einem grösseren Datenpaket zu tun haben, arbeiten wir mit der Kommandozeile via SSH. So steigerst du auch deine Produktivität im Webmaster-Alltag.

Also lokal entpackt und dann den Inhalt bis auf die .htaccess-Datei zum ZIP-Archiv namens 825.zip packen. Das lädst du dann ins Rootverzeichnis zum FTP-Account hoch. Anschliessend loggst du dich mit dem Windows-Tool, wahlweise Putty oder Bitvise in der Konsole ein und entpackst das vorher hochgeladene ZIP-Archiv mit diesem SSH-Befehl.

unzip 825.zip

Das Archiv wirst du danach nicht mehr brauchen und kannst es dermassen vom FTP-Account wieder entfernen.

rm -rf 825.zip

Dann wird es wie gehabt sein, indem du dich im Backend deiner Drupal 8 Installation einloggen musst. Navigiere im Browser zum Statusbericht und date alles up, was aktualisiert werden muss. Die Datenbank muss dieses Mal nicht upgedatet werden, aber vermutlich werden es deinerseits Module und Themes sein. Auch manchmal sind es die Sprachdateien und Übersetzungen. Diese kannst du ebenfalls aus dem Backend heraus aktualisieren.

Nachdem deine Updates vollständig sind, schaust du dir erneut den Statusbericht an und wenn alles gut ist, dann wäre das vollbracht. Wie du hier sichten kannst, sind solche Drupal 8 Updates halb so tragisch und können durchaus von jedermann vollzogen werden.

Was gab es Neues bei Drupal 8.2.5?

Es waren lediglich Fehlerbehebungen und einige Änderungen, sodass das deinem Drupal 8 Webauftritt zugute kommen wird. Eines meiner Drupal 7 Blogs meldete auch eine Aktualisierung der Version, aber offiziell ist von Drupal 7 noch nichts draussen. Die letzte Drupal 7 Version war 7.53 vom Anfang Dezember 2016. Vermutlich wird da noch die Tage ein neues D7-Update die Welt erblicken.

Ich nehme mir auch dafür die Zeit und werde es dir hier im Blog gerne zeigen, wie das Updaten funktioniert.

Falls du Fragen hierzu haben solltest, zögere nicht damit, hier zu feedbacken. Ich kann dir nun weiterhin viel Spass bei der Arbeit mit Drupal 8 wünschen. Es ist ein recht cooles OpenSource CMS, ausgelegt für Projekte jeder Grösse.

by Alexander Liebrecht

P.S. >> MetaTag-Modul funktioniert bei mir leider nicht. Es gibt beim Artikelerstellen keine Metatag-Felder zum Ausfüllen, warum auch immer. Aber ein neues Metatag-Update gab es heute schon.

Flarum Forum Extension Signatur installieren

flarum-extension-signatur-installation-internetblogger-de

Hallo lieber Leser! Flarum Forum Software entwickelt sich stetig weiter und ich verfolge es in der offiziellen Support-Community unter http://flarum.org. Entdeckt habe ich eine neue Erweiterung namens Signature und diese installierte ich.

Dir hier möchte ich davon erzählen wie die Installation vonstatten geht und was du alles dabei beachten musst.

 

Installation Flarum Forum Extension Signatur

Offizielle Infos zu dieser Flarum Erweiterung gibt es unter https://discuss.flarum.org/d/4222-signature-extension und installiert wird sie im Terminal mit solchen Tools wie Putty oder Bitvise. Beides sind Windows-Tools und auch kostenlos.

Wenn du mit der Flarum Forum Software arbeitest, wirst du immer wieder die Kommandozeile brauchen und weiss es dann auch etwas zu schätzen.

Mit diesem SSH-Befehl installierst du in der Konsole diese Signatur Extension.

php composer.phar require xengine/flarum-ext-signature

Je nach Server bzw. Webhosting musst du entweder “composer” oder “composer.phar” nehmen. Die phar-Extension ist auf den meisten Webspaces und den Servern installiert. Falls du einen Rootserver hast, musst du in Plesk oder cPanel schauen, ob die phar-Extension installiert ist. Das gehört dann zu PHP.

Diese Flarum Signatur Extension wird vom Rootverzeichnis aus installiert. Falls dein Forum sich im Unterverzeichnis befindet, musst du im Terminal zu diesem Verzeichnis mit solchem SSH-Befehl wechseln.

cd unterverzeichnis

Danach den obigen SSH-Befehl ausführen.

Auf dem obigen Beitragsbild

Auf dem Bild kannst du die Signatur schon sichten. Dafür habe ich dort den Signatur-Bereich rot gekennzeichnet. Auch kannst du es dir in meinem Flarum Forum unter http://flarum.internetblogger.de/d/160-markdown-editor-beim-flarum-forum live ansehen.

Durch die Forum-Signatur besteht dann eben die Möglichkeit, auf sich und sein Projekt innerhalb des Forums aufmerksam zu machen. Die Signatur-Links scheinen sogar doFollow zu sein. Das spielt für mich persönlich aber keine Rolle mehr. Viel mehr hätte ich noFollow-Links und ich möchte keine Backlinks im eigenen Portfolio für das Portfolio sammeln. Das bringt google-technisch gesehen nichts.

Die Signatur Flarum Erweiterung kannst du im Flarum Backend unter Erweiterungen noch etwas einstellen. Du kannst wohl noch die Anzahl der Zeichen in der Signatur bestimmen und noch etwas mehr. Von Haus aus müssten es 1000 Zeichen sein, was locker ausreicht. Den visuellen Editor hast du in den Optionen der Extension auch.

Die Signatur an sich wird aus dem Frontend heraus hinter deinem User-Namen, wenn du eingeloggt bist, erstellt. Dort einfach nach Signatur schauen und welche erstellen. Ich vermutete die Signaturerstellung zwar im Flarum Backend, aber dem war es nicht so und es ist unter dem eigenem Profil versteckt.

Mein Fazit zu Flarum Signatur Extension

Diese Flarum Forum Erweiterung ist durchaus sehr nützlich und wie oben schon erwähnt, machst du auf dich aufmerksam. Ob es nun dofollow/NoFollow-Links sind, ist nicht wirklich das Thema. Falls du in so einem Flarum Forum sehr aktiv bist und es eine grosse Community ist, werden die User auf deine Links vermutlich auch klicken.

Bisher habe ich ausser dem englischen Support-Forum kein/e einzige/s grosse/s deutsche/s Flarum Forum/Community gesehen. Ich habe ein solches Forum, aber nur für mich und für dich zum Lesen. Aber sonst hat es vermutlich noch keiner. Da musst du auch speziell danach in Google suchen, was bei diesem Blogpost nicht das Thema ist.

Ich freue mich in jedem Falle über deine Erfahrungen mit dieser Flarum Erweiterung und wie das in deinem Flarum Forum ankommt. Vielleicht hatten sich alles Nutzer sehr gefreut, denn schliesslich ist es ein tolles Feature für das Flarum-Forum.

P.S. Den Composer kannst du noch updaten. Das geht vom Rootverzeichnis aus mit diesem SSH-Befehl.

php composer.phar update

by Alexander Liebrecht

 

Tikiwiki 16.1 online – mehr Sicherheit, Bugfixes und Verbesserungen

tikiwiki-frontend-internetblogger-de

Hallo lieber Leser! Ich setze um die 30-50 CMS, Foren, Portal-CMS, Wikis und allerhand sonstige Software ein. Updates hierzu erscheinen wöchentlich oder mehrmals in der Woche. Natürlich mache ich mir immens viel Arbeit, die aber gemacht werden muss. Es gibt nichts Schlimmeres wie veraltete Software mit eventuellen Sicherheitslecks.

Vor kurzem erschien TikiWiki 16.1, welches mit mehr Sicherheit, Fehlerbehebungen und einigen Verbesserungen daher kam. Das kannst du dem offiziellen Post unter https://tiki.org/article443-Security-update-Tiki-16-1-Tiki-15-3-and-Tiki-12-10-released gerne entnehmen.

 

Das eigentliche Update habe ich soeben durchgeführt, was von Erfolg gekrönt war. Es war schon etwas Routine, dennoch muss ich immer wachsam sein und die englischen Hinweise, falls es welche gibt, beachten. Im Folgenden erzähle ich es dir, wie du auf TikiWiki 16.1 updaten kannst.

Update auf TikiWiki 16.1 – Wie geht das?

Alle verfügbaren TikiWiki-Versionen bekommst du im Projekt TikiWiki CMS Groupware unter https://sourceforge.net und dort in den Files des Projektes lade dir die letzte Version herunter. Wöchentlich wird diese Groupware und CMS heruntergeladen, sodass man sagen kann, es sei populär. Ist es auch so. Es ist zwar kein WordPress, aber als Groupware kenne ich nichts besseres als den TikiWiki.

Du lädst demnach die letzte Version herunter. Der Download ist je nach DSL-Speed schnell getan, aber das Entpacken dauert eine ganze Weile. Entpacke es lokal und packe den Inhalt zum ZIP-Archiv namens tiki.zip. Das lädst du ins Rootverzeichnis zum FTP-Account hoch und musst in der Kommandozeile so entpacken.

unzip tiki.zip

Lösche das Archiv hinterher so.

rm -rf tiki.zip

Du musst dieses Mal die Datenbank nicht backupen, denn nach dem Update musste ich die Datenbank auch nicht updaten, was du immer in der Konsole machen kannst. Im Control Panels nach dem Hochladen und dem Entpacken des Paketes wird dir der dafür nötige SSH-Befehl angezeigt. Diesen führst du in der Konsole aus und schon ist das geschehen.

Diese Tiki-Version kam mit Bugfixes daher

Welche Fehlerbehebungen es genau waren, kann ich nicht sagen, aber ich weiss, dass es um mehr Sicherheit ging und dass etwas verbessert worden ist. In der Summe lohnt sich dieses neue Update und du tust es für dein eigenes TikiWiki-Projekt. Das Projekt von mir kannst du gerne unter https://internetblogger.de/tikiwiki einsehen. Vielleicht magst du auch etwas Feedback hinterlassen.

Ich weiss immer noch nicht, ob die Besucher mit URL und Name feedbacken können. Im offiziellen TikiWiki geht das URL-Feld zwar, doch es wird nichts verlinkt. Eine, kann ich schon sagen, Kinderkrankheit des TikiWikis und ich bemängele es bei jeder neuen Version.

Einmal zeigte mir ein Developer von GitHub wie ich das Webseiten-Feld, sodass die URL verlinkt wird, ermöglichen kann. Doch jetzt weiss ich es auch nicht mehr und muss auf GitHub mal stöbern.

Warum die Entwickler es endlich nicht in das Update mit hineinnehmen, ist mir nicht klar. Durch das Webseiten-Feld findet doch erst recht die Vernetzung über Blogger-Freundschaften statt. WP zeigt es dir am besten und auch Joomla und Drupal.

Updates sind extrem wichtig und installiere diese auch mal

Du kommst nicht drumherum, denn Updates sichern deine TikiWiki-Installation und machen ein Gefühl für die Besucher, dass das Projekt stabil und sicher ist. Was willst da noch mehr. Kümmere dich immer darum und erstelle dir auf SourceForge.net oder auf GitHub einen eigenen Account. Abonniere das Repository und auf SourceForge.net kannst du Updates auch erhalten.

Zudem halte ich dich hier auf dem Laufenden.

Nun, falls du keine Fragen zum Update offen hast, geniesse die Arbeit mit deinem TikiWiki in der Version 16.1. Freue mich über jegliche Erfahrungen und Anregungen zu dieser CMS-Groupware.

by Alexander Liebrecht

Confluence Server 6.0.2 erschienen – etliche Issues wurden erledigt

confluence-dashboard-enterprise-theme-premium

Hallo lieber Leser! Ich kann es dir jetzt schon verraten, dass ich nun etwas grosszügiger bin, was doFollow hier im Blog angeht. Du bekommst sogar nach dem ersten Kommentare doFollow. Einen Comment musst du schon noch machen. Wenn das nicht etwas verlockend ist zum Feedbacken 😉

Jetzt aber zum Wesentlichen dieses Blogposts. Ich bekomme in meinem Confluence Server Projekt unter http://confluence.liebrecht-projekte.de:8060 Updates im Header angezeigt und heute war es soweit. Confluence Server 6.0.2 war erschienen.

Weiterlesen

Frage an die Leser: Kannst du meinen CMS-Anleitungen noch folgen

mecha-cms-frontend

Hallo lieber Leser! Du weisst sicherlich, dass ich gerne hier im Blog mit dir kommuniziere. Ich gehe auf so gut wie alle Kommentare von meinem Wissensstand ausgehend ein. Mich beschäftigt seit heute die eine Frage, ob du meinen CMS-Anleitungen noch folgen kannst?

Mich erreichte auf einem anderen Blog seltsames Feedback, was auch etwas Spam sein könnte. Ich habe es als Kritik verstanden, weil wohl bemängelt wird, dass ich zu viele englische Wörter verwende.

 

Ist es tatsächlich so, dass du damit nicht zurecht kommst? Weisst du, was eine Kommandozeile oder ein Terminal ist? Wann hast du das letzte Mal etwas mit SSH und Konsole gemacht? Kennst du dich damit aus und inwieweit kannst du deinen Webhosting-Account bedienen? Ich möchte dir solche Fragen stellen, um dich besser kennenzulernen.

Für mich ist es so, dass ich mit dem Terminal täglich arbeiten muss. Ich habe noch einen eigenen Rootserver und dieser datet sich ja nicht von alleine up. Ich muss stets die Konsole verwenden und auch geht es um Plesk-Updates, die immer mal wieder gemacht werden müssen.

Kannst du meinen CMS-Tutorien noch folgen und benutze ich wirklich zu viele englische Begriffe

Du hast es sicherlich schon mitbekommen, dass ich seit 2013 CMS teste. Was ein CMS ist, muss ich nicht mehr erklären. Auch ist es ein Fakt, dass ich viel mit der englischen Sprache im Webmaster/Blogger-Alltag zu tun habe. Es ist nun einmal so, seien es die GIT-Repositorys auf GitHub, meine Accounts auf SourceForge.net, bei Gitlab oder in der Bitbucket Cloud.

Die GIT ist übrigens die Versionskontrolle, bei der du eine Software-Entwicklung verfolgen kannst. Du kannst Branches erstellen, ein Repository forken oder mehrere Entwicklungszweige erstellen.

Damit habe ich nun mal zu tun und ich weiss derzeit nicht, wer sich alles auf Internetblogger.de herumtreibt und ob die Stammleser meinen Anleitungen noch folgen können. Ich bin der Ansicht, dass es dir weiterhelfen kann, wenn ich bestimmte SSH-Befehle in meine Anleitungen aufnehme. Auch strebe ich produktives und schnelleres Arbeiten im Internet an. Es muss alles funktionieren, klappen und auch Spass machen. Nur so kommst du vorwärts.

Viele CMS muss ich auf Englisch nutzen, weil es nicht anders geht

Das wäre ein weiterer Fakt und ist auch nun mal so. Deutschsprachige CMS sind die bekanntesten, aber solche CMS-Exoten wie Subrion, Mecha und Yellow sind leider auf Englisch.

Ich versuche meine Anleitungen so zu gestalten, dass es jeder, der eine Schulausbildung hatte, es verstehen kann. Dazu kommt noch, dass meine ersten CMS-Anleitungen nicht sehr ausführlich waren, weil ich das Wissen dazu noch nicht hatte. Die Kommandozeile kannte ich noch nicht vor zwei Jahren und erst seit einer ganzen Weile arbeite ich damit täglich.

Die Zielgruppe von Internetblogger.de sind nicht die Blog-Neulinge, die noch nie ein Backend von innen sahen. Nein, diese können hier im Blog höchstens neue Erfahrungen sammeln und etwas lernen. Aber im Grossen und Ganzen richten sie meine Anleitungen an diejenigen, die schon seit Jahren im Internet sind und eben das eine oder das andere CMS erfolgreich updaten wollen.

CMS-Feedback gibt es hier bei den Anleitungen sehr wenig, weil ich weiss, dass fast alle Blogger und Neublogger auf WordPress setzen. Auch ist mir bewusst, dass in Google kaum deutsche Anleitungen sind, wenn es um ein exotisches OpenSource CMS geht. Diesen Bereich möchte ich mit meinem Wissen befüllen und es dir hier anbieten. Darum geht es mir, zu zeigen, dass anderweitige CMS es wert sind, angeschaut zu werden.

Ich erhoffe mir in den nächsten Tagen etwas Feedback von dir und ob die englischen Wörter dich hier stören? “Bugfixes” nutze ich immer wieder und als Stammleser weisst du, was das ist. Auch Security Fixes erwähnte ich manchmal, was Fehlerbehebungen in der Sicherheit sind.

Updaten und upgraden dürfte jedem Blogger/Webmaster bekannt sein. Wenn du noch noch keine Markdown-Auszeichnungssprache beherrschen kannst, ist nicht schlimm, denn das brauchst du nicht. Ich arbeite damit auf GitHub, SourceForge.net und beim GRAV CMS-Blog. Das ist aber cms-abhängig. Die Markdown -Syntax ist dennoch einfacher als HTML und kann schnell erlernt werden.

Nun, ich komme zum Schluss.

Welches Wissen hast du, wenn es ums Webhosting, Server, Webspace, CMS, Kommandozeile/SSH geht? Sind meine CMS-Anleitungen zu schwer zu nachvollziehen oder kannst du mir gut folgen? Wie lange bist du schon ein Webmaster und bist du ein Blogbesitzer oder nur ein Inhaber einer statischen Seite mit WordPress CMS drauf?

Auf diese Fragen hätte ich ein paar Antworten von dir, um zu erfahren, welcher Leser hier im Blog wirklich vorhanden sind.

Freue mich auf dein Feedback.

by Alexander Liebrecht

Drupal 8.2.2 verfügbar mit Bugfixes

shariff-share-buttons-drupal-8-tutorial-internetblogger-de

Hallo lieber Leser! Wie das halt so ist, ist wieder eine neue Drupal 8.2.2 Version erschienen und diese findest du unter https://www.drupal.org/project/drupal/releases/8.2.2. Dort im Drupal-Beitrag findest du auch alle Änderungen und Bugfixes, die ermöglicht wurden. Das Update habe ich für dich und mich bereits gemacht und hier darunter erzähle ich dir wie du das anstellen kannst.

Drupal 8 wird im Monatszyklus aktualisiert, sodass ich schon immer darauf warte, bis der nächste Monat anbricht und ich hoffentlich problemlos updaten kann.

Weiterlesen

B2evolution 6.7.8 verfügbar – Bugfixes und ein paar Verbesserungen

b2evolution-6-7-6-frontoffice-blog-startseite

Hallo lieber Leser! Es ist wie gehabt, dass ich dich hier über CMS-Updates auf dem Laufenden halte. Vor kurzem ist eine neue B2evolution CMS-Version 6.7.8 erschienen und dazu findest du unter http://b2evolution.net/downloads/6-7-8 welche Update-Installationshinweise. Dieses CMS kann sogar auf Deutsch verwendet werden und das geht ohne Weiteres.

 

B2evolution hat vier Haupt-Sammlungen, solche wie Foto-Blog, herkömmliches Blog, das Handbuch und ein Forum. Das lässt dein B2evolution-Projekt als vollwertiges Projekt aussehen und du kannst damit alles anstellen, was du willst. Sicher ist es kein Projektverwaltungstool wie Confluence oder Bitbucket, aber es ist eben eine Blog-Software und ein passables OpenSource CMS.

Nun noch ein paar kurze Hinweise wie das Upgraden einer bestehenden Installation vonstatten geht.

Upgrade von B2evolution auf Version 6.7.8

Du lädst dir das Download-Paket herunter, entpackst es lokal und betrittst den Orden in Windows. Dann packst du alles zum ZIP-Archiv namens b2evolution.zip oder bevo.zip. Das lädst du in das Rootverzeichnis deiner Installation zum Webspace hoch und entpackst in der Kommandozeile mit diesem SSH-Befehl.

unzip bevo.zip

oder

unzip b2evolution.zip

Hinterher löschst du das ZIP-Archiv wieder dermassen.

rm -rf bevo.zip

Als Nächstes gehst du im Browser zu /install und dahinter wird noch das Upgrade-Script sein. Du nimmst das Upgraden einer früheren Version. Wenn dort auch deine Datenbankdaten zu sehen sein werden, dann kannst du das Upgraden anstossen, ansonsten musst du schauen warum die Datenbankdaten nicht angezeigt werden. Sollte aber eher nicht der Fall sein und wenn die Konfigurationsdatei dort ist, wo sie sein sollte, sollte alles funktionieren.

Upgraden geht nach Sekunden und ist somit schnell fertig

Das Upgraden an sich dauert nur Sekunden und schon ist dein B2evolution CMS Blog uptodate und du kannst noch gerne darüber bloggen sowie deine Stammleserschaft auf den Laufenden bringen. Meinerseits sind solche Updates eine reine Routine und nur selten gibt es damit etwas Schlimmes.

In jedem Falle solltest du vorher eine Datenbanksicherung anlegen, so für den Fall der eventuellen Fälle und falls mal etwas passiert. So kann dir nicht viel passieren.

Nun hoffe ich, dass du diese Standard-Update-Anleitung gut nachvollziehen konntest. Bei Fragen wie gehabt darunter feedbacken.

Freue mich auch auf deine Update-Erfahrungen und ein paar Tipps zu diesem OpenSource CMS.

by Alexander Liebrecht

P.S. bei dieser B2evolution-Version gab es Bugfixes und Verbesserungen unter der Haube. Somit ist das Updaten wärmstens empfohlen und macht deine Installation einen kleinen Stück funktionsfähiger sowie besser. Kommuniziere das auch bitte deiner Leserschaft, denn manchmal bekommt jemand so ein Update gar nicht mit.

MyBB 1.8.8 erschienen – Fehlerbehebungen und Sicherheitsupdate

mybb-1-8-7-zu-1-8-8-update-webmastertwelten-de

Hallo lieber Leser! Es gibt noch mehr CMS/Forum-News, denn es ist eine neue MyBB-Version 1.8.8 erscheinen. Das entnimmst du diesem Thread auf der offiziellen deutschen myBB-Webseite unter https://www.mybb.de/forum/thread-33812.html.

Das neue 1.8.8er-Sicherheitsupdate ist auch etwas Wartung für das myBB-Forum. Es wurden Sicherheitslecks geschlossen und Bugs gefixt. Das Upgraden muss dringend gemacht werden. Ich habe es unter http://webmasterwelten.de schon vollbracht, was auch sehr einfach war.

Ich vermute mal, dass du vorher MyBB 1.8.7 hattest und wenn nicht, solltest du in jedem Falle upgraden. Wenn du myBB 1.8.7 hattest, brauchst du lediglich die geänderten Files von Mybb.de aus den Downloads herunterzuladen. Sie packst du dann schnell zu einem Zip-Archiv und lädst dieses ins Rootverzeichnis deiner myBB-Installation hoch. Danach entpackst du in der Shell mit diesem SSH-Befehl.

unzip archiv.zip

oder

unzip mybb.zip

Sichere bitte vorher die Datenbank für den Fall der eventuellen Fälle, damit du später alles rückgängig machen kannst. Nach dem Entpacken lösche das Archiv wieder mit diesem SSH-Befehl.

rm -rf archiv.zip

bzw.

rm -rf mybb.zip

Jetzt nur noch die Upgrade-Routine durchgehen

Diese findest du browser-technisch unter /install und dort folgst du allen Hinweisen sowie Anweisungen, die du zu sichten bekommst. Das wird zu nachvollziehen sein. Es werden Datenbank-Einträge geschrieben und die Templates zurückgesetzt. Aus diesem Grunde hat sich mein Forum-Logo ausgetauscht und wurde auf das Standard-myBB-Logo zurückgesetzt, welches mir aber so gefällt wie es ist. Vielleicht lasse ich es sogar so bestehen.

webmasterwelten-de-mybb-forum-im-frontend

Das Upgraden dauert nicht sehr lange und am Ende sollte das Install/Upgrade-Verzeichnis mit einem Lock versehen werden. Diese eine Lock-Datei findest du im /install-Verzeichnis im FTP-Account. Gerne kannst du das /install-Verzeichnis ganz löschen.

Install-Verzeichnis per Kommandozeile löschen

Wenn du das per Kommandozeile machen willst, was immer am schnellsten ist, dann nutze dafür diesen SSH-Befehl.

rm -rf install

So, nun wäre dein MyBB 1.8 Board wieder top aktuell und du kannst dich vielleicht noch in den neuen 1.8er Plugins umsehen. Übrigens habe ich im Forum auf Webmasterwelten.de das Tagging-Plugin und User Tagging installiert, jetzt sieht man die Tags im Forum-Footer und du kannst als Forum-Nutzer andere Nutzer taggen.

Vielleicht werden diese sogar dann per Mail benachrichtigt. Das muss ich selbst noch ausprobieren, was ich mit meinem Nick machen werde. Tags kannst du beim Erstellen eines Forum-Topics erstellen und diese sollten noch irgendwo in der Ansicht eines ersten Threads angezeigt werden.

Das erfahre ich noch im Laufe der nächsten Zeit. Das Tagging soll nun mal die interne Verlinkung herstellen und das wäre ganz gut für Google und Co.

Falls du andere Forum-Probleme hast, kannst du dich gleich an die offizielle Seite von myBB deutscher-seits wenden. Dort gibt es für die neue myBB-Version bereits einen Thread. So kann ich dir jetzt viel Spass in deinem Forum wünschen. Ich denke, dass du nicht mal Fragen zum Upgrade haben wirst, denn es ist nicht kompliziert zu erledigen.

by Alexander Liebrecht

P.S. das Forum-Blog gibt es nicht mehr, weil wer soll das auch noch mit Inhalte füllen. Ich habe schon etliche Blogs, die dauerhaft betrieben werden. Daher trennte ich mich vom Forum-Blog.

 

 

Backdrop 1.5.1 CMS erschienen mit zahlreichen Bugfixes

backdropcms-1-4-4--update-erfolgreich-internetblogger-de

Hallo lieber Leser! Nun es geht wieder um OpenSource CMS. Es ist eine neue Backdrop 1.5.1 CMS-Version erschienen. Es gab unzählige Fehlerbehebungen, die du unter https://github.com/backdrop/backdrop/releases einsehen kannst. Das Update von 1.5.0 auf 1.5.1 machte ich eben unter http://wpzweinull.ch/cms/backdrop und das war von Erfolg gekrönt. Es war ein reines Routine-Update und diesen nahm ich einfach mal so mit.

 

Vom Backdrop OpenSource CMS gibt es im Jahr bis zu 12 Updates und es sind immer wieder die Fehlerbehebungen, so genannte Bugfixes, die da ermöglicht werden. Wie du das Update anstellen kannst, erfährst du hier im Folgenden.

Wie du auf Backdrop 1.5.1 updaten kannst

Du lädst dir die neueste Backdrop CMS-Version aus der GitHub-Quelle herunter und entpackst es lokal. Dann packst du den Ordner /core zum ZIP-Archiv namens core.zip. Dieses muss ins Rootverzeichnis deiner Installation zum Webspace gebracht werden. Dann sicherst du das Verzeichnis /files/config_xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx und entpackst mit der Konsole dieses ZIP-Archiv. Das wird wie gehabt sein und geht mit diesem SSH-Befehl.

unzip core.zip

Lösche das Archiv danach wieder mit diesem SSH-Befehl.

rm -rf core.zip

Schon kannst du zum Statusbericht navigieren, wenn du dich eingeloggt hast. Du kannst aber gleich ein Datenbank-Update machen. Das wird im Browser unter /core/update.php sein und du musst eingeloggt sein, eher du das anstellen kannst. Das machst du dann und ich denke, dass alles andere bei dir vielleicht schon uptodate sein wird. Falls nicht, dann auch die Module und Themes updaten.

Das wäre dann das ganze Update und noch kann ich dir das Modul easy_xmlsitemap empfehlen.

Backdrop Modul easy_xmlsitemap

Das XML-Sitemap Modul befindet sich unter https://backdropcms.org/project/easy_xmlsitemap und du kannst es herunterladen, ins Verzeichnis mit den Modules im FTP-Account wieder hochladen. Danach aktivierst du es im Backdrop CMS-Backend unter Modules und schon gehst du wieder im Backend zur Konfiguration>> easy_xmlsitemaps und erstellst eine Sitemap.

Sie wird im FTP-Account im Verzeichnis /files/easy_xmlsitemap abgelegt. Diese URL wie Deinedomain.de/files/easy_xmlsitemap/sitemap.xml brauchst du für die Google Search Console und du kannst dort deine Sitemap ruckzuck einreichen. Ich habe eben 83 URLs eingereicht und es wird alles indexiert, wenn nicht längst geschehen.

In den XML-Sitemap-Optionen kannst du wohl noch einstellen, in welchem Intervall die Sitemap erstellt wird. Ja, so war es glaube ich. Tägliche Sitemap-Erstellung bietet sich ja gut an, falls du täglich bloggst und Googlchen wird immer wieder darauf zugreifen können.

Wegen Adsense und Co. brauchst du das Modul mit der Cookie Bar

Falls du so wie ich mit Google Adsense und Social Share Buttons arbeitest, brauchst du das Modul mit der Cookie Bar. Das wäre dann offizieller-seits unter https://backdropcms.org/project/eu-cookie-compliance

Kannst du mir bitte bestätigen, dass du bei mir diese Cookie Bar zu sichten bekommst?! Ich hatte heute den Eindruck, dass sie nur eingeloggt angezeigt wird, was so nicht sei darf. Anonyme Blogbesucher müssen sie sonst sehen und nicht ich eingeloggt. Ich zwar auch, aber ausgeloggt auf der Startseite.

Schaue dir noch etliche Module beim Backdrop CMS mal an. Diese findest du unter https://backdropcms.org im Module-Verzeichnis.

Ein paar sehenswerte Backdrop Themes gibt es aber auch. Und vielleicht findest du einen Gefallen an dem Theme, welches ich einsetze. Oben war der Link zu meinem Backdrop CMS Blog. Ansonsten sind wir nun fertig und du hast das Update hoffentlich gut überstanden. Falls du Fragen zum Updaten des Backdrop CMS hast, zögere nicht damit, mich hier zu kontaktieren. Für mich sind solche Update eine reine Routine und ich schaue mir natürlich vorher auch die Upgrade-Anleitung an. Bei all den eingesetzten CMS kannst du auch mal etwas vergessen haben.

by Alexander Liebrecht

Installation von Bluespice MediaWiki unter CentOS 7 und mit Plesk 12.5

bluespice-mediawiki-1-27-1-im-frontend

Hallo lieber Leser! Seit mehreren Tagen installiere ich wieder interessante Software und kam auch dazu, den Bluespice Mediawiki auf meinem Rootserver aufzusetzen. Den Server musste ich dieses Mal auch komplett neu installieren, weil es nicht anders ging. Na ja, wie kannst du den BlueSpice MediaWiki unter Centos 7 und mit Plesk aufsetzen?!

Ich habe den Server vor ein paar Tagen neu aufgesetzt und installierte PHP 7.0.11 und allerhand PHP-Extensions. Das wird wichtig sein, wenn die Systemvoraussetzungen für MediaWiki erfüllt werden sollen. Bei mir war alles ganz gut verlaufen.

Hier möchte ich dir Schritt für Schritt zeigen wie du Bluespice installieren kannst. Auch bediente ich mich eines englischen Tutorials, um da ein paar Sachen in Erinnerung zu rufen.

Bluespice MediaWiki unter Centos 7 und bei Plesk 12.5 aufsetzen

Du lädst dir die letzte MediaWiki Version von http://mediawiki.org herunter und entpackst es lokal. Den MediaWiki musst du zuerst installieren und danach BlueSpice sowie alle anderen Erweiterungen, die deinerseits nicht fehlen sollen.

Nach dem lokalen Entpacken packst du es wieder zum ZIP-Archiv namens mediawiki.zip und lädst es ins Rootverzeichnis hoch. Ich habe vorher noch in Plesk eine neue Datenbank erstellt und setzte MediaWiki im Unterverzeichnis von Liebrecht-projekte.de auf.

Ich denke, dass so etwas auch auf einer Subdomain mit Plesk und VirtualHost gehen würde. In Plesk erstellst du eine neue Subdomain und musst dann im FTP-Account unter /var/www/vhosts/system/deineSubdomain/conf die Datei httpd.conf bearbeiten.

Darin an der Stelle mit Port :80, darunter musst der VirtualHost rein. So beobachte ich es zumindest, wenn ich so etwas vorhabe und auf einer Plesk-Subdomain eine neue Software installieren will.

Falls du es im Unterverzechnis installieren willst, so….

Falls du es im Unterverzeichnis installieren willst, ist alles viel viel einfacher. Du entpackst das vorher gepackte ZIP-Archiv mit diesem SSH-Befehl und navigierst zum Browser. Die Installationsroutine wird schon angezeigt.

Ab dann folgst du Schritt für Schritt allen Anweisungen und Hinweisen auf dem Desktop. Ich machte für dich auch etliche Screenshots und diese kann ich dir hier gerne zeigen sowie etwas erklären.

mediawiki-install_centos-7-installationsschritt2-ueberpruefung-der-servervoraussetzungen
Installationsschritt 2: Überprüfen der Servervoraussetzungen(bei mir sah es ganz gut aus)

In diesem zweiten Schritt wird dir angezeigt, was alles der Server braucht, um den MediaWiki aufzunehmen. Wie du siehst, setze ich PHP 7.0.11 ein und der MediaWiki 1.27.1 funktioniert damit gut. Zudem braucht das System ImageMagick für die Miniaturansichten von Bildern. Ich weiss es nicht so genauz, ob Plesk es von Haus mitbringt.

Ich hatte diesen ImageMagick schon einmal und musste somit nichts unternehmen. Wenn es bei dir nicht installiert ist, suche promt in Google nach “centos 7 install imagemagick“. Das wird nicht so schwer sein, würde ich mal behaupten. Auch musst du die Git-Versionskontrolle installieren. Git kannst du mit dem YUM-SSH-Befehl installieren. Das geht dann so.

yum install git

Die Pecl-Erweiterung habe ich auch installiert, aber vermutlich muss noch etwas gemacht werden, damit der MediaWiki es annimmt. Bei der Installation des MediaWikis störte es aber nicht, daher habe ich nichts unternommen. Zudem musst du noch PHP APC(Alternative PHP Cache) installieren. Das geht mit dem Befehl Yum dermassen.

yum -y install php-pecl-apc

Du kannst dich dieses kurzen Tutorials hinter dem Link gerne bedienen. Wenn du es fertig hast, machen wir weiter mit der Installation und der Routine.

mediawiki-install_centos-7-installationsschritt3-datenbankdaten-eingeben-mysql-mariadb
Schritt 3: Datenbank-Daten ausfüllen

Im nächsten Schritt füllst du die Datenbankdaten aus. Nehme eine MySQL-Datenbank, die vorher erstellt werden muss. Zudem soll sie die Kollation UTF 8 haben. Auch wird es InnoDB sein. Du sieht bei diesem Schritt alles, was du noch eingeben musst. Jetzt weiter.

mediawiki-install_centos-7-installationsschritt5-wiki-name-und-benutzer-daten-eingeben
Schritt 5: Wiki-Name und Benutzer-Daten ausfüllen

Hierbei vergibst du deinem neuen Wiki einen passenden Namen und trägst deine Account-Daten ein. Nun geht es weiter.

mediawiki-install_centos-7-installationsschritt6-zwischenspeicherung-von-objekten-php-apc-caching
Auswahl des Caches: APC Erweiterung installierten wir schon vorher

Hier geht es um das Objektcaching und ich hatte schon vorher den Alternativen PHP Cache installiert. Daher beliess ich es dabei und ging in der Installationsroutine gerne weiter.

mediawiki-install_centos-7-installationsschritt8-eigentliche-mediawiki-installation-alles-erledigt
Die Mediawiki-Installation an sich(wenn alles als erledigt dargestellt wird, war es erfolgreich)

Hier geht es um die Installation selbst und wenn du überall “erledigt” zu sichten bekommst, dann ist alles gut und du kannst weiter gehen. Bei mir war alles auf Anhieb top. Ich installierte den MediaWiki 1.2.71 zu Ende. Du musst im nächsten Schritt die Datei LocalSettings.php downloaden. Der Download startet meistens automatisch. Diese Datei lädst du ins Rootverzeichnis deiner MediaWiki-Installation hoch.

Darin befindet sich auch die index.php. So weisst du genau, wo das ist.

Nun, der MediaWiki dürfte jetzt schon stehen und wir müssen noch den BlueSpice installieren.

BlueSpice Installation beim MediaWiki 1.27.1

BlueSpice 2.27.0 beta lädst du wie gehabt von https://sourceforge.org herunter. Du betrittst den Ordner, nachdem du es lokal entpacktest und packst das Verzeichnis /extensions zum ZIP-Archiv namens extensions.zip. Danach packst du das Verzeichnis /skins zum ZIP-Archiv namens skins.zip.

Beides musst du ins Rootverzeichnis hochladen und in der Konsole entpacken. Das SSH-Entpacken kennst du sicherlich schon. Das geht folgendermassen.

unzip extensions.zip

unzip skins.zip

rm -rf extensions.zip

rm -rf skins.zip

Mit den letzten beiden SSH-Befehlen hast du die ZIPs gleich gelöscht, weil du sie nicht mehr gebrauchen kannst.

Wenn du soweit bist, schau dir noch dieses Tutorial an. Da wird alles angesprochen, was gemacht werden muss. Du wirst die Pfade umbenennen müssen und zudem setzt du noch Schreibrechte bei ein paar Verzeichnissen. Im Tutorial ist das noch beschrieben. Ich zeige dir hier noch schnell diesen Screenshot.

bluespice-mediawiki-installation-pfade-umbenennen-schreibrechte-setzen
Bluespice-Installation: Pfade umbenennen und Schreibrechte setzen

Datei LocalSettings.php bearbeiten

Damit Bluespice im MediaWiki aktiviert ist, musst du in der Datei LocalSettings.php diese Anweisungen setzen.

require_once("$IP/extensions/BlueSpiceDistributionConnector/BlueSpiceDistributionConnector.php");
require_once("$IP/extensions/BlueSpiceFoundation/BlueSpiceFoundation.php");
require_once("$IP/extensions/BlueSpiceExtensions/BlueSpiceExtensions.php");
require_once("$IP/extensions/BlueSpiceTagCloud/BlueSpiceTagCloud.php");
require_once("$IP/skins/BlueSpiceSkin/BlueSpiceSkin.php");

Zudem aktivierst du noch den BlueSpiceSkin. Damit dieser Skin als Default gilt, musst du es noch in der LocalSettings.php dermassen haben.

 ## Default skin: you can change the default skin. Use the internal symbolic
## names, ie 'vector', 'monobook':
$wgDefaultSkin = "BlueSpiceSkin";

Dann dürfte der Skin aktiv sein und du findest deinen MediaWiki mit einem anderen Design vor. Im Grossen und Ganzen wäre das die ganze Installation und zwei Links zu den Tutorien habe ich hier gesetzt.

Die BlueSpice Installation an sich ist nicht sehr kompliziert und du wirst damit zurecht kommen. Deinen Centos Server setztest du eh schon auf, nehme ich stark an. So musst du lediglich ein paar PHP-Erweiterungen installieren. Auch kannst du ein Unterverzeichnis für die Installation nehmen, so wie ich es dir hier zeigte.

In den nächsten Blogposts hier im Blog versuche ich auch noch zu zeigen wie du Shariff Social Share Buttons und die MediaWiki-Erweiterung SocialProfile installieren kannst. Mit SocialProfile hast du ein wesentlich umfangreicheres Profil als MediaWiki von Haus aus hat.

Fazit zur BlueSpice MediaWiki Installation unter Centos 7 und bei Plesk 12.5

Bluespice und Media Wiki funktionieren bei PHP 7.0.11 und auch auf Linux unter Centos 7. Das ist gut zu wissen und denke mal, wird auch oft genug eingesetzt. Du kannst noch den Composer installieren und auch updaten, weil die MediaWiki Installation das Verzeichnis /vendor hat. Dorthin werden alle Abhängigkeiten installiert.

Ansonsten schaut die fertige Installation im Frontend so aus wie hier auf dem Beitragsbild.

Meine Installation befindet sich unter http://liebrecht-projekte.de/cms/bluespicewiki

Falls du Fragen zur Installation hast, kannst du mich hier gerne feedbacken. Womöglich kann ich dir dann helfen.

by Alexander Liebrecht

BlueSpice Mediawiki Update von Version 2.23.3 auf 2.27.0 Beta

bluespice-mediawiki-update-auf-version-2-27-0-erfolgreich

Hallo lieber Leser! Wie gewohnt versorge ich dich hier mit OpenSource/CMS-Themen und dieses Mal machen wir zusammen ein BlueSpice MediaWiki-Update von der Version 2.23.3 auf 2.27.0 Beta.

Die neue BlueSpice-Version ist neulich erschienen und darüber gibt es noch nicht viele Informationen. Es heisst offiziellerseits, dass es noch nicht für den produktiven Einsatz geeignet wäre. Es ist noch mehr zum Testen geeignet. Ausserdem wenn du BlueSpice 2.27.0 von Null auf installieren willst, gibt es noch keinen Installer.

 

Die Installation auf dem Rootserver für mich wäre höchst kompliziert wie ich mir das angesehen habe. Ich betreibe einen BlueSpice MediaWiki mit MediaWiki 1.27.0 unter http://webmasterwelten.de/wiki. Das neue Update habe ich auch schon installiert.

Falls du auch updaten willst, halte dich an dieses Tutorial und dann dürfte es gut klappen.

Wie date ich BlueSpice 2.23.3 auf 2.27.0 Beta up

Als Erstes lädst du die neue Version von https://sourceforge.net/projects/bluespice/files/ herunter und entpackst es lokal. Mache auch eine Datenbanksicherung für den Fall der Fälle. Meine neue Installation funktioniert zwar gut, aber du kannst es nicht wissen, was passieren kann.

Du arbeitest wie bei jedem meiner Tutorien mit der Kommandozeile, weil das Paket doch schon ganze 100 MB umfasst.

Du hast also alles lokal entpackt und betrittst den Ordner mit den Extensions. Den Inhalt dieses Ordners packst du zum ZIP-Archiv namens extensions.zip.

Danach loggst du dich mit dem kostenlosen Tool Putty in der Konsole ein und datest erst einmal den Composer up. Dazu nimmst du diesen SSH-Befehl vom Rootverzeichnis aus.

php56 composer.phar update

Wenn das geschehen ist, navigierst du mit diesem Befehl zum Verzeichnis /extensions.

cd extensions

bzw.

cd wiki

cd extensions

Das ist je nachdem, wo deine Wiki-Installation ist.

Danach lädst du das vorher gepackte ZIP-Archiv ins Verzeichnis /extensions hoch und entpackst dieses in der Konsole mit diesem SSH-Befehl.

unzip extensions.zip

Danach löschst du es gleich so.

rm -rf extensions.zip

BlueSpice Skin Updaten

Als Nächstes muss du noch den BlueSpice Skin hochladen und in das dafür vorgesehene Verzeichnis /skins entpacken.

Dazu gehst du wieder zum Rootverzeichnis deiner Wiki-Installation mit “cd ~” und weiter gibst du ein:

Du siehst ja in der Konsole den Pfad zum Rootverzeichnis, also navigiere dorthin mit dem “cd-Befehl”.

Dann zum Schluss mit “cd skins”.

Im Dowloadpaket ist das Skin-Verzeichnis verfügbar und du packst es zum ZIP-Archiv namens skin.zip. Dieses lädst du in das /skin-Verzeichnis hoch und entpackst in der Konsole so.

unzip skin.zip

Anschliessend bitte auch gleich löschen.

rm -rf skin.zip

Nun dürfen wir das Ganze in der Konsole updaten.

Dafür gehst du wieder zum Rootverzeichnis und dann mit “cd maintenance” zum Update-Verzeichnis. Von dort aus gibt es du diesen SSH-Befehl ein.

php56 update.php

Du wartest bis das Update durch ist und darfst anschliessend deinen neuen BlueSpice MediaWiki mit BlueSpice 2.27.0 beta und MediaWiki 1.27.0 im Browser aufrufen.

Wenn du dich eingeloggt hast, gehst du im Browser zu /Spezial:Version um sich die neue Version anzusehen. So überzeugst du dich immer davon, ob die neue Version von BlueSpice und Mediawiki installiert ist.

Das war unser BlueSpice 2.27.0 beta Upgrade

Das wäre unser Upgrade und du kannst dir alles noch einmal ansehen. Im Frontend des BlueSpice MediaWiki siehst du links in der Seitenleiste zufällige Seite und Kategorien. Eines von beiden dürfte neu sein. Zufällige Seite dürfte wahrscheinlich neu sein. Zuerst hatte ich beim Aufrufen der zufälligen Seite eine Fehlermeldung, doch beim wiederholten Aufrufen war damit alles in Ordnung.

Auch darfst du gleich im Wiki darüber berichten. Erstelle eine neue Seite mit “BlueSpice 2.27.0 Update” oder so etwas in der Art. Das musst du natürlich nicht, kannst aber. Auch über das BlueSpice Blog kannst du deinen Lesern über das neue Update erzählen.

Falls du Fragen zum Update hast, setze dich hier in den Kommentaren mit mir in Verbindung. Bisher hatten meine Tutorien bei mir selbst gut geklappt und wenn du noch etwas Konsolen-Kenntnisse hast, dann sollte das Update gut klappen.

Welche BlueSpice/MediaWiki-Versionen hast du im Einsatz?

Welche vergleichbare PHP-Wiki-Software ist dir noch bekannt bzw. setzt du noch ein?

Freue mich auf dein Feedback.

by Alexander Liebrecht

Social Share Buttons im Flarum Forum: Google Plus, Facebook, Twitter und Co.

flarum-forum-social-share-buttons-zum-anklicken

Hallo lieber Leser! In diesem Blogpost geht es um Social Share Buttons für das Flarum-Forum. Über diese OpenSource Forum-Lösung berichtete ich hier mindestens 5 Mal und dieses Mal habe ich die Erweiterung mit den Social Share Buttons entdeckt.

Wie das live mit dem Sharen aussieht, kannst du glatt in meinem Board gerne testen. Das schaut im Frontend dermassen aus.

 

flarum-forum-social-share-buttons-einzelner-forumpost
Flarum Forum: Social Share Möglichkeit im Frontend im einzelnen Forum-Post

Jetzt können meine Forumleser und bei steigender Popularität dieses kleinen Forums die Inhalte gerne nach Twitter, Facebook, G+ und Linkedin teilen. Social Media ist derzeit nicht weniger wichtig wie das Bloggen selbst. Für mich ist wahrscheinlich das Bloggen zwar wichtiger, aber dennoch bediene ich mich meiner Social Media Kanäle auf Twitter, Facebook, G+ und Pinterest, manchmal auch auf Xing.

Die Social Share Buttons im Flarum Forum sollten funktionieren und ich habe selbst lediglich auf einen der Buttons geklickt. Wie installierst du diese aber?? Nun ja, das kann ich dir promt und gerne verraten.

Social Share Buttons beim Flarum Board installieren

Flarum von Haus aus arbeitet gerne einmal mit dem Terminal, sprich der Kommandozeile und alle Extensions/Erweiterungen installierst du auch in der Shell. Für diese Social Share Extension muss dieser SSH-Befehl her.

php56 composer.phar require avatar4eg/flarum-ext-share-social

Entweder nimmst du am Anfang des SSH-Befehls “php56” oder gar nur “php”, je nach dein Shared Webhosting. So installierst du das. Ach ja, wenn du schon im Terminal bist, date doch einmal deinen Composer up. Das geht dann mit diesem SSH-Befehl.

php56 composer.phar update

Vermutlich werden es irgendwelche Abhängigkeiten sein, die nicht aktuell sind. Diese kannst du gleich mitupdaten.

Nachdem du in der Kommandozeile durch bist, gehst du im Browser zum Admin des Flarum-Forums und dort unter Erweiterungen installierst du Social Share Buttons. Dann ebenfalls dort ganz klein rechts auf das Icon klicken und du gelangst zu den kurzen Optionen dieser Extension. Stelle dann die SocialNetworks ein, die du brauchst.

Ich habe mich auf die vier oben erwähnten Netzwerke beschränkt, weil mehr wird da eh nicht geteilt und falls überhaupt in einem Forum oder…

Das Teilen im Flarum-Forum kann nun erfolgen

Das ist denn auch schon alles und du kannst im Frontend im Flarum Board deine eigenen Inhalte mit der treuen Stammleserschaft deiner Netzwerke gerne teilen. Vermutlich nutze ich es auch, wenn meine Forum-Posts Tutorien oder informative Inhalte sein werden. So bei jedem Pipi-Kram wie kurz ein Projekt vorgestellt, werde ich es sein lassen. Das können meine Portfolio-Leser dann selbst ausfindig machen, was auch teilweise in den Blogger/CMS-Foren wie unter http://rostockerblogger.de/xenforo publiziert wird.

Nun denke ich, dass du die Installation der Social Share Buttons beim Flarum Forum gut nachvollziehen konntest. Falls etwas in der Konsole sein sollte, bemühe bitte einmal diese Kommentare hier drunter.

Freue mich auch über deine Erfahrungen, falls es jemanden geben sollte, der deine Forum-Inhalte teilt. In einem Forum ist es nicht immer sehr wahrscheinlich, dass es dazu kommt.

by Alexander Liebrecht

 

QuickApps CMS mit Composer installieren – wie geht das

quickapps-cms-im-frontend-startseite-der-webseite

Hallo lieber Leser! Nachts zu bloggen, kann auch viel Spass machen, wenn einem die Ideen nicht ausgehen. Heute hatte ich einen Misserfolg und einen Erfolg in Sachen CMS-Installation. Einerseits konnte ich den Phusion Passenger in Apache nicht konfigurieren. Etwas stimmt da noch nicht und ich bleibe da mal am Ball.

Und andererseits habe ich das QuickApps CMS mit Composer erfolgreich installieren können. Das neue Test-Projekt befindet sich nun auf einer Subdomain unter http://quickapps.wpzweinull.ch/blog und wird dort hoffentlich für immer bleiben. Ich werde das Projekt mittels Composer Update immer wieder auf den neusten Stand bringen und gut ist.

 

Es ist doch so, dass ich dieses OpenSource CMS schon einmal installierte, doch damals konnte ich nicht mit der Kommandozeile umgehen. Einiges hat sich seitdem zum Positiven hin geändert und mit dem Terminal arbeite ich oft täglich. Also wie installierst du nun QuickApps OpenSource CMS mit Composer.

QuickApps CMS mit Composer installieren

Das ist nicht sonderlich schwer und du arbeitest mit der Shell und dem kostenlosen Tool namens Putty, welches auch unter Windows 7 und 10 läuft. Den Composer selbst installierst du vom Rootverzeichnis deiner Domain aus mit diesen SSH-Befehlen. Tippe sie einfach in der Konsole ein bzw. kopiere und füge sie wieder ein.

php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
php -r "if (hash_file('SHA384', 'composer-setup.php') === 'e115a8dc7871f15d853148a7fbac7da27d6c0030b848d9b3dc09e2a0388afed865e6a3d6b3c0fad45c48e2b5fc1196ae') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r "unlink('composer-setup.php');"

Wenn das gut ist, installierst du QuickApps in einem Unterverzeichnis deiner Domain mit diesem Composer-SSH-Befehl.

php56 composer.phar create-project -s dev quickapps/website blog

Das sorgt dafür, dass deine neue QuickApps-Webseite sich im Browser unter `Meinedomain.tld/blog` befinden wird. Du kannst auch alle Files ins Rootverzeichnis verschieben, denn anschliessend musst du dieses OpenSource CMS per Browser zu Ende installieren.

Es basiert auch auf PHP und MySQL, sodass eine Browser-Installation immer machbar ist. Dazu machte ich auch etliche Screenshots, die ich dir hier gerne zeigen werde.

Screenshots der Installationsroutine beim QuickApps OpenSource CMS

quickapps-cms-installation-schritt1
Im Schritt 1 kannst du die Sprache der Installation wählen

Es sind nur zwei Installationssprachen wie Englisch und Spanisch verfügbar. Finde dich damit ab, dass solche CMS nicht immer das Deutsche mitbringen können und wir nur mit dem Englischen arbeiten können. Vermutlich haben sich die deutschen Mitentwickler dazu noch nicht durchgerungen oder haben gar kein Interesse an QuickApps CMS.

Nun zum nächsten Installationsschritt.

quickapps-cms-installation-schritt2-servervoraussetzungen
Im Schritt 2 werden Servervoraussetzungen festgestellt

Hier macht der Installer fest, ob der Server für die Installation von QuickApps geeignet ist. Meinerseits läuft dieses CMS auf Managed Server bei All-inkl und mit PHP 5.6 sowie der letzten MySQL-Version, die das Webhosting hergeben kann.

Nun zum nächsten Schritt der Browser-Installation.

quickapps-cms-installation-schritt4-datenbankinstallation
Im Schritt 4 wird die Datenbank initialisiert und auch installiert – gebe deine Daten ein!

Hier darfst du die Datenbank-Daten deiner dafür vorher erstellten MySQL-Datenbank eingeben. Sie muss immer vorher erstellt werden.

Nun zum nächsten Installationsschritt.

quickapps-cms-installation-schritt5-account-erstellung
Im Schritt 5 wird der Account erstellt

Hierbei erstellst du den Account und gibst alle Daten ganz genau ein. Dann geht es in Ordnung und du setzt die Installationsroutine gerne fort. Es ist nicht mehr weit bis zur Fertigstellung der Installation des QuickApps CMS.

quickapps-cms-installation-schritt6-finale-der-installation
Finale der Installation des QuickApps OpenSource CMS

Du kannst dann gleich zum Backend wechseln, loggst dich mit den vorher erstellten Account-Daten ein und wirst erst einmal einiges zu tun haben.

Was musst du in QuickApps als Erstes denn anstellen?

Es bedarf der Erstellung von Impressum und Datenschutz. Dafür nutzt du E-recht24.de und dort generierst du deine rechtlichen Seiten. In QuickApps im Backend hast du die Möglichkeit, Artikel und Basic Pages zu erstellen. Du nimmst zuerst die Basis Pages und erstellst das Impressum und den Datenschutz.

Das geht ganz leicht und du wirst einen visuellen Ckeditor vor der Nase haben. Es gibt in der Werkzeugleiste des visuellen Editors auch die so wichtige Rechtschreibprüfung für “German”. Damit wirst du oft genug arbeiten müssen.

Wenn du zwei rechtliche Seiten erstellt hast, musst du sie in der Struktur zum Hauptmenü der QuickApps-Webseite erst noch hinzufügen. Das geht ebenfalls leicht und wenn du die Option mit der Seitenstruktur gefunden hast(es ist links in der Leiste im Backend dieses OpenSource CMS). Dort fügst zwei neue Links hinzu und dabei kannst du sogar die vorher erstellten Seiten auswählen, wenn du in das Feld mit dem Link reinklickst.

Probiere es einfach mal aus und du wirst sichten wie einfach das doch geht. Im Grossen und Ganzen kannst du dieses OpenSource CMS locker erlernen und wenn du damit nur etwas bloggen willst, musst du auch nicht lernen wie du Plugins entwickeln oder etwas mit PHP machen musst. Das mache ich nicht mal, weil ich finde, dass ich es nicht brauche. Ich will mit einem CMS gut bloggen, es einwandfrei bedienen und ein Blog erstellen. Mehr brauche ich nicht.

Heute erstellte ich schon einen GitHub-Issue wegen der Routes in QuickApps

Ja, da wollte meine Erstinstallation vor einigen Wochen heute nicht funktionieren und mir wurde angezeigt, dass die Seite nicht gefunden werden kann. Die komplette Neuinstallation des QuickApps CMS brachte dann auch Erfolg und jetzt habe ich bei mir auch schon die statischen rechtlichen Seiten erstellt, sodass du es dir ansehen kannst.

Ich kann ab und an auf meiner QuickApps-Webseite etwas berichten und mich zu den einigen CMS-Sachen und Projekte äussern. Übrigens gibt es hauseigene Kommentare mit ReCaptcha, was gehen sollte. Auch ein Feld für eigene Webseite dürftest du in den Kommentaren haben. So versteht sich die gegenseitige Vernetzung der Moderne und nicht wie beim PHP Fusion CMS, wo niemand seine Seite in den Kommentaren verlinken kann. Das ist aber auch ein Wahrzeichen des PHP Fusion CMS.

Nun hoffe ich, dass du dieses kurzes Tutorial gut nachvollziehen konntest. Das mit der Arbeit mit dem Terminal kannst du noch gerne erlernen und wirst es im Falle eines CMS immer wieder brauchen. Bei WordPress brauche ich es auch, denn ich warte nicht mehr, bis mehr als 20 MB per FTP hochgeladen werden müssen. Da wird alles in der Shell entpackt und gut ist.

Welche Probleme hattest du bei der QuickApps CMS Installation?

Hattest du meine Anleitung genau befolgt und dennoch Schwierigkeiten oder ging alles super?

Freue mich auf dein Feedback und die eventuellen Fragen.

by Alexander Liebrecht

 

B2evolution 6.7.6 CMS-Update mit Bugfixes – Fehlerbehebungen

b2evolution-6-7-6-frontoffice-blog-startseite

Hallo lieber Leser! Ich habe ein neues CMS-Thema für dich und zwar ist die neue B2evolution-Version 6.7.6 erschienen. Darüber möchte ich mit dir sprechen.

Alle CMS-Updates, so klein diese auch sein mögen, gehören zeitnah installiert und ich habe mich schon einmal darum heute gekümmert. Die neue B2evolution 6.7.6 Version hatte lediglich etliche Fehlerbehebungen, so genannte Bugfixes, die seit der letzten Version ermöglicht wurden.

 

 

Wie stellst du nun das Updaten an?

Update von B2evolution auf Version 6.7.6

Du nimmst wieder das Terminal, sprich die Kommandozeile, um das vorher gepackte ZIP-Archiv zu entpacken. Noch vorher machst du ein Datenbank-Backup und dann lädst du dir die letzte B2evolution-Version von http://b2evolution.net herunter. Das Paket entpackst du lokal und packst den Gesamt-Inhalt zu bevo.zip.

Dieses ZIP-Archiv lädst du ins Rootverzeichnis zum Server hoch und entpackst dann mit dem kostenlosen Tool Putty in der Shell so.

unzip bevo.zip

Anschliessend musst du das Archiv wieder so löschen.

rm -rf bevo.zip

Normalerweise musst du einige Verzeichnisse im FTP-Account backupen, wie es in der englischen Upgrade-Anleitung hinter diesem Link steht. Ich habe es nicht gemacht, weil solche B2evolution-Updates habe ich bereits zuhaufen machen dürfen.

b2evolution-6-7-6-backoffice-sammlungen
B2evolution CMS im Backoffice: Sammlungen

Du entpackst und gehst im Browser zu /install und weiter zum Upgrade-Script. Dort musst du unten deine Datenbank-Daten zu Gesicht bekommen. Wenn dies nicht der Fall ist, dann stimmt etwas nicht. Im Normalfalle wird alles stimmen, soweit ich es beurteilen kann. Dann kannst du das Upgrade gleich erledigen.

Es dauert wahrlich nicht mal drei Minuten, die aber sehr wichtig für dein B2evolution-Blog sind. Als Nächstes loggst du dich im Backoffice deines Blogs ein und schaust nach ganz unten: Die neue Version wird dir angezeigt. Somit hast du ein erfolgreiches Upgrade machen können und alles ist wieder im grünen Bereich.

Spamaufkommen durch Pingbacks und Trackbacks beim B2evolution CMS

Das ist wahrlich extrem bei mir und heute habe ich die Pingback-Funktion ganz ausgeschaltet. So etwas brauche ich nur bei WordPress-Blogs und nirgends sonst. Falls du auch Spam dadurch hast, kannst du Pingbacks deaktivieren. Wenn du mich hier danach fragst, schaue ich noch einmal nach, wo sich diese Option im Backoffice genau befindet.

Kurz zu B2evolution CMS selbst

Es ist ein gutes OpenSource CMS mit vier Sammlungen wie dem Hauptblog, dem Fotoblog, dem Forum und dem Handbuch. Alles unter einem Dach, auf deutsch nutzbar und du kannst dich frei entfalten.

b2evolution-6-7-6-frontoffice-blog-startseite
B2evolution CMS im Frontend auf Startseite

Schöne B2evolution-Designs gibt es auch, wie du auf der offiziellen Webseite dieses CMS entnehmen kannst. Bei den Plugins ist es so, dass etliche davon in die Jahre gekommen sind und nicht mehr upgedatet wurden.

Daher ist die Kompatibilität mit dem Kern dieses CMS nicht garantiert. Schaue einfach danach wie sich deine Plugins verhalten und musst ggf. ein paar davon wieder deinstallieren sowie gleich aus dem FTP-Account ganz löschen. Wenn sie nicht mehr aktuell sind, brauchst du sie auch nicht mehr auf dem Server.

So viel heute dazu und bei Fragen melde dich bei mir einfach hier in den Kommentaren. Dir sei nur erfolgreiches Upgraden gewünscht und informiere anschliessend deine Stammleser zu diesem neuen Update und B2evolution 6.7.6.

Freue mich auf dein Feedback.

by Alexander Liebrecht

 

Drupal 8.2.0 Beta 3 online – neue Funktion Datetime Range + Bugfixes

datetime-range-neue-funktion-drupal-8-2-0-beta-3

Hallo lieber Leser! Über mein Portfolio weisst du nun wenigstens etwas, sicherlich nicht mehr als ich 😉 Davon erst einmal genug und ich möchte dich wieder mit den CMS belästigen.

Eine neue Drupal 8 Version mit der Nummer 8.2.0 Beta 3 ist erschienen und darüber kannst du etwas unter https://www.drupal.org/project/drupal/releases/8.2.0-beta3 nachlesen. Diese neue Version brachte wieder zahlreiche Fehlerbehebungen und eine neue Funktion Datetime Range mit. Es hat etwas mit solchen Modulen wie dem Calendar zu tun.

Hier im Beitragsbild habe ich für dich lediglich eine Browser-Übersetzung dieser Stelle aus dem Drupal-Post. Ich musste ja nur kurz überlegen, ob ich updaten will. Da es aber Fehlerbehebungen sind, lohnt es sich schon irgendwo zu aktualisieren. Demnach tat ich es promt. Das Updaten geht ganz easy und als Leser dieses Blogs weisst du sicherlich schon, was zu tun ist.

Update-Hinweise auf Drupal 8.2.0 Beta 3

Schaue dir einfach den letzten Post zu Drupal 8 hier im Blog an und darin findest du die Anleitung, wie du was machen kannst. Es ist bei mir und meinen Updateanleitungen ein ähnliches Prinzip. Immer wenn es erlaubt ist, werden die alten Dateien mit den neuen überschrieben. Das ist dieses Mal auch so. Achte nur darauf, dass du die .htaccess ausser Acht lässt – beim Packen meine ich. In der Konsole zu entpacken, geht immer so:

unzip archiv.zip

Zu löschen, geht immer dermassen:

rm -rf archiv.zip

Der Rest wird dir im Statusbericht angezeigt und die Datenbank musst du aber updaten. Mache bitte vorher eine Datenbanksicherung. Es ist nur eine einzige Aktualisierung im Vergleich zu Drupal 8.2.0 Beta 2 und diese machst du dann mit dem Updatescript. Dieses befindet sich im Drupal 8 Backend. Ggf. musst du noch deine Module und Themes updaten, falls welche Aktualisierungen vorliegen.

Ansonsten alles chillig und du hast dein Blog danach wieder. Das Ganze Packen und Entpacken dauert eine ganze Weile, daher mein Tipp an dich: Nehme das kostenlose Tool namens 7 Zip und du bist damit schneller durch.

Als Kommandozeile geht immer kostenloses Tool Putty

Als Kommandozeile geht wie gehabt das Tool Putty, welches unter Windows läuft und der Rest sollte problemlos über die Bühne gehen. Ich habe es schon letztens erwähnt, dass die Finalversion von Drupal 8.2.0 wahrscheinlich erst Oktober 2016 erscheinen wird. Bis dahin habe Geduld und begnüge dich mit deinem D8-Blog.

Ich kann mich noch an meine Erstinstallation von Drupal 8 entsinnen, welche ich mit Haken und Ösen gerade mal so schaffte. Irgendwas war ja immer dabei, aber ich hatte es vor Monaten hinbekommen. Im Normalfall sollte es damit gut klappen. Ich vermute einmal, dass bis zur Finalversion noch weitere Release Candidates die Welt erblicken werden. Wir werden sehen und dich halte ich hier auf dem Laufenden.

Drupal 8 Blog Wpshopde.de im Frontend
Drupal 8-Blog im Frontend

Falls du ein Drupal 8 Blog noch nie live sichten konntest, schaue es dir bei mir unter http://wpshopde.de gerne mal an. Ich setze auf bootstrap-fähiges Blog-Theme, welches responsive ist. Ein bisschen gutes Design und das Mobile, mehr wollte ich nicht haben.

Falls du Fragen zum Update hast, melde dich dann hier. Die letzten Drupal 8 Updates rutschten alle nur so durch und meine Fehler im Backend beim Aufrufen des Block-Layouts waren auch gleich mit weg. Daher alles gut mit Drupal 8 aus Anwendersicht. Die Entwickler haben ja ganz andere Probleme zu bewerkstelligen.

Freue mich auf dein Feedback.

by Alexander Liebrecht

MediaWiki 1.27.1 – wichtiges Sicherheitsupdate – empfohlen

mediawiki 1.27.1 update - Sicherheitsupdate erolgreich-installiert-internetblogger-de

Hallo lieber Leser! Heute geht es etwas um ein Sicherheitsupdate von MediaWiki, welchen auch die deutsche Wikipedia einsetzt. Es sind nämlich die Version 1.27.1 und auch Updates ein paar anderer MediaWiki-Versionen erschienen. Das Updaten wird einem Webmaster wärmstens empfohlen, weil Sicherheitslücken geschlossen wurden. Ich habe für dich das Update schon erfolgreich machen können und ich … Weiterlesen

TikiWiki 15.2 herausgebracht worden – Sicherheitsupdate

tikiwiki-frontend-internetblogger-de

Hallo lieber Leser! Weisst du schon, dass vom TikiWiki die neue Version 15.2 erschienen ist. Es ist nämlich ein wichtiges Sicherheitsupdate und du bist dazu angehalten, das Update zeitnah zu installieren. Die letzte TikiWiki-Version kannst du auf SourceForge.net hinter diesem Link herunterladen. Ich zeige dir in diesem Blogpost auch wie das Update gemacht werden kann. … Weiterlesen

Drupal 8.1.7 online – Sicherheit und Wartung – empfohlen

Drupal 8 Blog Wpshopde.de im Frontend

Hallo lieber Leser! Machst du etwas mit dem Drupal 8 CMS? Vielleicht schon noch oder gar nicht. Jedenfalls kam gestern eine neue Version Drupal 8.1.7 heraus. Das Updaten wird dringend angeraten, weil es sich dabei von der Wartung und der besseren Sicherheit handelt. Du kennst mich als Stammleser und selbstverständlich zeige ich dir hier, wie … Weiterlesen

PHPBB 3.2.0 RC 1 erschienen – Updaten klappte gut

phpbb320-rc-1-forumpost-im-frontend

Hallo lieber Leser! Hier kommt ein weiteres OpenSource CMS/Forum-Thema und zwar gibt es eine nagelneue Version des PHPBB 3.2 Forums und darüber postete ich schon in meinem eigenen PHPBB 3.2.0 Forum. Die Sache ist, dass es nicht mehr lange dauern wird, eher wir PHPBB-User die neue Version 3.2.0 haben können. Diese Version wird einiges an … Weiterlesen

WordPress 4.6 beta 1 und TikiWiki 15.1 erschienen

TikiWiki-Einstellungen experimentell

Hallo lieber Leser! Es kann wieder hier etwas gebloggt werden und ich belästige dich jetzt mit den CMS Themen wie WordPress 4.6 Beta 1 und TikiWiki 15.1. Es ist nämlich der Fall, dass beiderseits neue Updates verfügbar sind und diese kannst du gerne installieren.  Ich erzähle es dir auch, was es Neues dabei gibt und … Weiterlesen

Xoops 2.5.8 erschienen – Upgraden klappte, aber weisse Seite im Frontend und Backend

Xoops 2.5.7.1 Common Utilities Dashboard

Hallo lieber Leser! Kennst du das Xoops OpenSource CMS?? Es ist ganz passabel und ich arbeite damit unter http://wpzweinull.ch/cms/xoops. Es ist nämlich so, dass eine neue Version 2.5.8 die Welt erblickte wie du diesem Beitrag entnehmen kannst. Bei der neuen Version wurde die PHP 7-Kompatibilität hergestellt und es ist auch ein Sicherheitsupdate, welches ich eigentlich … Weiterlesen

Drupal 8.1.2 verfügbar mit Bugfixes – Updaten sehr empfohlen

drupal8-blog-frontend

Hallo lieber Leser! Hiermit starte ich in das Blogging-Feedback-Wochenende mit etlichen OpenSource-CMS-Themen. Es sind nämlich Drupal 8 Updates erschienen wie du dieser Quelle unter https://www.drupal.org/project/drupal/releases entnehmen kannst. Bei diesem neuen Drupal 8.1.2 Update wurde etwas geändert sowie verbessert und ich habe bereits upgegradet. Das Upgraden war für mich mehr Routine und ich zeige dir hier … Weiterlesen

TikiWiki 15.0 stable verfügbar – Updaten empfohlen

tikiwiki-blog-startseite

Hallo liebe Leser! Gestern kommentierte und las ich auf anderen Blogs und heute blogge ich selbst noch ein wenig. Mir ist es danach, euch über den TikiWiki 15 und das Update zu erzählen, denn es ist eine neue TikiWiki-Version, die auch stabil ist. TikiWiki 15.0 stable kann man hier downloaden und man muss die eigene … Weiterlesen

Wie installiert man den Composer richtig

composer-installation-ssh

Hallo liebe Leser! Jetzt etwas zur Composer Installation. Ihr habt es sicherlich als Stammleser von Internetblogger.de mitbekommen, dass ich euch immer wieder welche SSH-Befehle zeige. Und etliche OpenSource CMS wie auch einige Forum Software erfordern die Installation des Composers und was Composer genau ist, kann man in der deutschen Wikipedia unter https://de.wikipedia.org/wiki/Composer_%28Paketverwaltung%29 nachlesen. Composer ist … Weiterlesen

MediaWiki 1.25.5: Schritt für Schritt Installation und meine Erfahrungen

webmasterwelten-de-blogger-wiki-mit-bluespice-mediawiki

Hallo liebe Leser und Freunde der Software-Installation! Heute geht es mir um die Installation von MediaWiki 1.25.5, die ich gerade ermöglicht habe. Warum wollte ich den MediaWiki zum x-ten Mal installieren?? Nun ja, meine Flarumboard.de-Domain ist frei geworden und ich wollte sie mit einem neuen Projekt besetzen, sodass es Spass macht zu posten und das … Weiterlesen

Flarum Forum Installation bei dem Webhoster Uberspace

flarum-installation

Hallo liebe Leser! Könnt ihr euch noch daran entsinnen, dass ich hier bei Internetblogger.de über die Flarum Forum Installation bei Serverprofis und bei All-inkl berichtete?! Nach mehreren Monaten ist es so, dass ich im Flarumboard bei Serverprofis unter http://flarumboard.de/flarum nichts tun kann, ich kann eben nichts machen im Forum. Es liegt an der Serverkonfiguration oder … Weiterlesen

Backdrop CMS auf die Version 1.3.2 aktualisieren – wie geht das

backdrop cms frontend

Hallo liebe Leser! In diesem Blogpost wird es um die Aktualisierung des Backdrop CMS auf die Version 1.3.2 gehen und damit befasste ich mich heute etwas. Die letzte Backdrop Version könnt ihr hinter diesem Link herunterladen. Dort also downloaden, lokal entpacken und ihr werdet das Verzeichnis /core im FTP-Account löschen müssen. Vorher macht ihr eine … Weiterlesen

Updaten von PHP Fusion CMS mit Kommandozeile und FTP

putty-ssh-tool

Hallo liebe Leser! In diesem Blogpost wird es darum gehen, wie man das CMS namens PHP Fusion bequem über die Kommandozeile und FTP updaten kann. Ich weiss nicht, inwiefern ihr schon mit SSH und der Kommandozeile arbeitet. Wenn ein hochzuladendes Paket 10 MB hat, dann lohnt sich schon der Einsatz der Kommandozeile, weil es einfach … Weiterlesen