Wartungsreleases von MediaWiki 1.25.5 und 1.26.2 erschienen – Updaten empfohlen

Hallo liebe Leser und Freunde des Feedbacks! Da ich den MediaWiki einsetze, werdet ihr hier auch darüber und über die neuen Updates informiert. Es sind Wartungsreleases von Mediawiki 1.26.2, 1.25.5 und älteren Versionen erschienen und dabei hat man eine Sache gefixt.

In den Infos steht folgendes:

== Maintenance fixes ==
(T121892) Various special pages resulted in fatal errors

Daher muss man aktualisieren und ich habe eine Installation von mir schon auf den neuesten Stand gebracht. Wir daten auch dieses Mal mit SSH und FTP via Filezilla up und das geht folgendermassen.

Ihr lädt euch die letzte Version des MediaWikis hier herunter entpackt es lokal und packt es wieder zu einem Zip-Archiv namens mediawiki.zip. Das kann man mit einem Packer, wie dem WinRar oder einem anderen tun. Dann loggt ihr euch via Filezilla in eurer MediaWiki-Installation ein und öffnet die Dateien .htaccess und LocalSettings.php mit dem HTML-Editor, wie dem Phase5. Das nur zur Sicherheit.

Vorher könnt ihr noch eure Datenbank sichern, für den Fall der Fälle und falls mal alles schief geht. Also dann das gepackte Archiv namens mediawiki.zip ins Rootverzeichnis der Installation hochladen.

Danach loggt ihr euch in Putty ein und gebt diesen SSH-Befehl ein.

unzip mediawiki.zip

Das dann entpacken und gleich mit einem weiteren SSH-Befehl löschen.

rm -rf mediawiki.zip

Dann ist es gelöscht und ihr navigiert zum Verzeichnis “maintenance” mit diesem SSH-Befehl.

cd maintenance

und anschliessend muss man das das Update-Script laufen lassen, was wir mit diesem SSH-Befehl machen.

php update.php

So seht ihr dann in der Kommandozeile, dass alles aktualisiert wird und eure Datenbank ebenfalls.

Danach logt ihr euch in eurem Mediawiki ein und gebt im Browser hinter die /index.php dieses ein:

Spezial:Version

So seht ihr dort, dass ihr die letzte MediaWiki-Version habt.

mediawiki-1262-1-25-5-wartungs-releases

Das sollte es auch schon alles gewesen sein und ich muss nur noch meine anderen beiden BlueSpice Mediawiki-Installationen updaten. Die erste Installation unter http://internet-blogger.org/dokuwiki/Hauptseite habe ich schon aktualisiert.

Beachtet noch, dass ihr im Falle von BlueSpice lediglich mit dem MediaWiki 1.25.5 arbeiten könnt. Mit der allerletzten MediaWiki-Version 1.26.2 wird es noch nicht funktionieren. Die Supporter von BlueSpice sagten mir, dass die Kompatibilität erst mit MediaWiki 1.27 oder 1.28 hergestellt werden kann. Das wird aber noch lange dauern, nehme ich mal an.

So nun wünsche ich euch weiterhin viel Spass mit eurem MediaWiki.

by Alexander Liebrecht

Hinterlasse einen Kommentar, wenn du magst!

Write Your Review

Your email address will not be published. Required fields are marked *

CART

CMS-Produkte und Webseitenerstellung via Bolt CMS ab 150-500 EUR inkl. MwSt. Ausblenden

X