Aktualisieren auf MediaWiki 1.26.0 geklappt – aber BlueSpice Komponente funktioniert nicht mehr

mediawiki-1-26-0-online-bugfixes-und-verbesserungen

Hallo liebe Leser und Freunde des Feedbacks! Auch über den MediaWiki möchte ich euch gerne informieren, denn manche von euch haben eine Mediawiki-Installation auf dem Server bzw. einem Webspace. Ich setze den MediaWiki hier ein. Dort seht ihr kein BlueSpice mehr, weil es nach dem Updaten auf MediaWiki 1.26.0 nicht mehr funktioniert hat. Alles aber der Reihe nach 🙂

Ich habe hier die letzte MediaWiki Version 1.26.0 heruntergeladen und ab zum Server damit. Das klappte soweit und dann habe ich auch die letzte BlueSpice Version von SourceForge.net heruntergeladen und ebenfalls ab zum Server damit. Dann erinnerte ich mich daran, dass man sich per Konsole verbinden muss und dieses eingeben:

cd maintenance
php update.php

So wird eure ganze MediaWiki-Installation schnellstens aktualisiert und in der Regel erwartet man dann, dass im Frontend alles funktioniert und gut dargestellt wird, doch heute war es dem nicht so und ich bekam diese Fehler zu sichten. Das hat auch gleich mit der BlueSpice-Komponente zu tun.

Warning: OutputPage::getModuleStyles: style module should define its position explicitly: ext.bluespice.extjs.styles ResourceLoaderFileModule [Called from OutputPage::getModuleStyles in /www/htdocs/xxxxxx/wiki/includes/OutputPage.php at line 621] in /www/htdocs/xxxxx/wiki/includes/debug/MWDebug.php on line 300

Warning: OutputPage::getModuleStyles: style module should define its position explicitly: ext.bluespice.compat.vector.styles ResourceLoaderFileModule [Called from OutputPage::getModuleStyles in /www/htdocs/xxxxxx/wiki/includes/OutputPage.php at line 621] in /www/htdocs/xxxxxxx/wiki/includes/debug/MWDebug.php on line 300

Warning: OutputPage::getModuleStyles: style module should define its position explicitly: ext.bluespice.statebar.style ResourceLoaderFileModule [Called from OutputPage::getModuleStyles in /www/htdocs/xxxxx/wiki/includes/OutputPage.php at line 621] in /www/htdocs/xxxxxx/wiki/includes/debug/MWDebug.php on line 300

Ich habe auch schon einen Support-Ticket auf SourceForge.net erstellt und hoffe ich, bekomme ich heute/morgen ein Feedback dazu. Ich denke, dass es noch nicht viele zusammen nutzen, sprich die allerletzten Versionen von BlueSpice und Mediawiki, denn den Digest zu Mediawiki 1.26.0 bekam ich erst gestern, sprich alles nagelneu und frisch.

So warte ich jetzt mal ab, bis sich alles geklärt hat, eher ich BlueSpice wieder einsetzen kann.

Ihr könnt euren Mediawiki weiterhin mit einem anderen Skin wie „vector“ nutzen und dafür müsst ihr es in der LocalSettings.php einstellen und entfernt doch bitte aus dieser Datei diese Zeilen, denn sonst greift das System auf BlueSpice zurück.

require_once("$IP/extensions/BlueSpiceDistribution/BlueSpiceDistribution.php");
require_once("$IP/extensions/BlueSpiceFoundation/BlueSpiceFoundation.php");
require_once("$IP/extensions/BlueSpiceExtensions/BlueSpiceExtensions.php");
require_once("$IP/skins/BlueSpiceSkin/BlueSpiceSkin.php");

Dann dürfte man den MediaWiki normal nutzen und ich persönlich vermisse die BlueSpice-Komponente jetzt schon, denn damit hat man ein Blog und den visuellen Editor beim Erstellen von Wiki-Seiten. Damit lässt sich doch viel besser arbeiten als mit dem Wiki-Code. Ein bisschen was vom Wiki-Code kann man ja kennen, keine Frage, aber so dauerhaft damit arbeiten, möchte ich nicht und ihr vielleicht auch nicht.

Was brachte die neue MediaWiki-Version

Es wurden Bugs behoben und es gab Verbesserungen unter der Haube, nehme ich an, aber Bugs wurden ganz sicher gefixt und es wird wärmstens empfohlen, die eigene MediaWiki-Installation zu aktualisieren. Also falls ihr euch dafür etwas Zeit nehmen wollt, dann tut das.

So das wäre auch diese News und ich hoffe, ihr schaut danach, denn man sollte schon alle Software-Installationen immer uptodate halten und haben.

Update 27.11.2015

Ich habe nun weitere Erfahrungen gesammelt und musste auch durch die Hilfe des deutschen BlueSpice-Supports feststellen, dass BlueSpice in der letzten Version nicht mit MediaWiki 1.26.0 kompatibel zu sein scheint und diese Kompatibilität wird erst mit MediaWiki 1.27.0 hergestellt. Ich wollte auch MediaWiki 1.23.11 einsetzen, aber das haute bei mir wegen der Datenbank nicht hin, weil ich vorher schon MediaWiki 1.25.3 hatte.

Daher ruderte ich zurück und lud die letzte Version des Mediawiki 1.25.3 hoch. Dann liess ich die update.php via SSH-Console laufen und sieh da, der Wiki war wieder zurück und auch das Blog und meine Inhalte darin. Daher schaut bitte danach, dass ihr im Falle des BlueSpice mit einer höchsten MediaWiki-Version von 1.25.3 arbeitet. Alles was neuer ist, geht demnach nicht.

by Alexander Liebrecht

Bildquelle by Oleksiy Mark via Shutterstock.com

 

Teile den Blogpost mit deinen Freunden :)

Alexander

Ich bin 33j. jung, befasse mich mit dem Blogging, dem Webmastern und bin in den bekannten Social Networks wie Twitter, Facebook und Google+ aktiv. Weitere Blogs von mir sind solche wie Liebrecht.cc und Wpzweinull.ch. Ansonsten treibe ich gerne Sport und fotografiere gelegentlich mit meiner Canon-Kamera.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

To create code blocks or other preformatted text, indent by four spaces:

    This will be displayed in a monospaced font. The first four 
    spaces will be stripped off, but all other whitespace
    will be preserved.
    
    Markdown is turned off in code blocks:
     [This is not a link](http://example.com)

To create not a block, but an inline code span, use backticks:

Here is some inline `code`.

For more help see http://daringfireball.net/projects/markdown/syntax

CommentLuv badge